Руководство пользователя

Авторские права © 2010-2021 на данный документ принадлежит его разработчикам (соавторам), перечисленным ниже. Документ можно распространять и/или изменять в соответствии с правилами лицензии GNU General Public License (http://www.gnu.org/licenses/gpl.html), версии 3 или более поздней, или лицензии типа Creative Commons Attribution License (http://creativecommons.org/licenses/by/3.0/), версии 3.0 или более поздней.

Все торговые знаки этого руководства принадлежат его владельцам.

Соавторы

The KiCad Team

Перевод

KiCad Russian Team
alex9 <[email protected]>, 2016
Барановский Константин <[email protected]>, 2019-2021

Обратная связь

В проекте KiCad приветствуются отзывы, сообщения об ошибках и предложения по улучшению программного обеспечения и его документации. Получить больше информации о том как отправить отзыв или сообщить о проблеме можно в инструкции по адресу https://www.kicad.org/help/report-an-issue/

Знакомство c GerbView

GerbView предназначен для просмотра файлов в формате Gerber (RS 274 X) и отображения файлов сверловки из Pcbnew (в формате Excellon). Одновременно может быть показано до 32 файлов.

Для получения дополнительной информации о формате файлов Gerber воспользуйтесь спецификацией the Gerber File Format Specification. Информацию о формате файла сверловки можно получить здесь the Excellon format description.

Графический интерфейс

Основное окно

gerbview_main_screen_png

Верхняя панель инструментов

delete_gerber_png

Очистить все слои

load_gerber_png

Загрузить файлы Gerber

gerbview_drill_file_png

Загрузить файлы сверловки (формат Excellon из Pcbnew)

sheetset_png

Выбрать рамку листа для печати и показать/скрыть границы страницы

print_button_png

Открыть диалог печати

zoom_redraw_png

Перерисовать

zoom_in_png zoom_out_png

Увеличение и уменьшение масштаба

zoom_fit_in_page_png

Автомасштаб

zoom_area_png

Увеличить выделеное

gerbview_top_layer_png

Выбор слоя

gerbview_top_info_png

Информация о свойствах файла Gerber, загруженного в выбранный слой

gerbview_x2_component_png

Подсветить элементы, пренадлежащие выбранному компоненту (Gerber X2)

gerbview_x2_net_png

Подсветить элементы, относящиеся к выбранной цепи (Gerber X2)

gerbview_x2_attributeo_png

Подсветить элементы с указанным атрибутом (Gerber X2)

gerbview_top_dcode_png

Подсветить эелменты с указанным D-кодом на текущем слое

Левая панель инструментов

cursor_png

Выбор элементов

measurement_png

Измерение растояния между двумя точками

grid_png

Показать/скрыть сетку

polar_coord_png

Использовать полярные координаты

unit_inch_png unit_mm_png unit_mm_png

Выбор единиц измерения

cursor_shape_png

Изменить форму курсора

pad_sketch_png

Отображать контактные площадки в контурном режиме

track_sketch_png

Отображать линии в контурном режиме

opt_show_polygon_png

Отображать полигоны в контурном режиме

gerbview_show_negative_objects_png

Отображать негативные объекты в дополнительном цвете

show_dcodenumber_png

Отображать значения D-кодов

gbr_select_mode2_png

Отображать слои в режиме сравнения (дифференциальный режим)

contrast_mode_png

Отображать текущий слой в режиме высокой контрастности

layers_manager_png

Показать/скрыть менеджер слоёв

flip_board_24

Показать слои в отраженном виде

Менеджер слоёв

gerbview_layer_manager_png

Менеджер слоёв позволяет управлять и контролировать видимость всех слоёв. Стрелка указывает на активный слой, а с помощью отметок можно скрыть или показать нужные слои.

Функции кнопок мыши:

  • Щелчок левой кнопкой мыши на строке: выбор активного слоя.

  • Щелчок правой кнопки мыши на менеджере слоёв: управление отображением сразу всех слоёв.

  • Щелчок средней кнопкой мыши или двойной щелчок (на индикаторе цвета): выбор цвета слоя.

Вкладка Слои позволяет управлять отображением и цветом всех загруженных Gerber-слоёв или слоёв сверловки. Вкладка Элементы позволяет управлять отображением и цветом сетки, D-кодов и негативных объектов.

Команды меню

Меню Файл

gerbview_file_menu_png
  • Экспорт в Pcbnew имеет ограниченные возможности для экспорта Gerber-файлов в печатную плату Pcbnew. Конечный результат зависит от того, какие особенности формата RS 274 X используются в Gerber-файлах: растровые элементы (в основном, негативные объекты), не могут быть преобразованы; элементы, заданные командой Gerber "засветка", преобразуются в переходные отверстия; элементы, заданные командой Gerber "линия", преобразуются в отрезки (или в графические линии для не медных слоев)

Меню Инструменты

gerbview_tools_menu_png
  • Список D-кодов показывает используемые D-коды и некоторые их параметры.

  • Показать содержимое файла отображает содержимое Gerber-файла активного слоя в текстовом редакторе.

  • Измерительный инструмент позволяет измерять расстояния между двумя точками.

  • Очистить текущий слой стирает содержимое активного слоя.

Печать

Для печати слоёв используйте кнопку print_button_png или меню Файл → Печать.

Убедитесь, что элементы находятся внутри области печати. Выберите с помощью sheetset_png подходящий формат страницы.

Не забывайте, что фотоплоттеры могут использовать зону печати намного большую, чем размер страниц, используемых принтерами. Может потребоваться переместить весь набор слоёв.