Руководство пользователя

This document is Copyright © 2010-2021 by it’s contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

Все торговые знаки этого руководства принадлежат его владельцам.

Соавторы

The KiCad Team

Перевод

KiCad Russian Team
alex9 <[email protected]>
Барановский Константин <[email protected]>, 2019

Обратная связь

The KiCad project welcomes feedback, bug reports, and suggestions related to the software or its documentation. For more information on how to sumbit feedback or report an issue, please see the instructions at https://www.kicad.org/help/report-an-issue/

Знакомство c GerbView

GerbView предназначен для просмотра файлов в формате Gerber (RS 274 X) и отображения файлов сверловки из Pcbnew (в формате Excellon). Одновременно может быть показано до 32 файлов.

Для получения дополнительной информации о формате файлов Gerber воспользуйтесь спецификацией the Gerber File Format Specification. Информацию о формате файла сверловки можно получить здесь the Excellon format description.

Графический интерфейс

Основное окно

gerbview_main_screen_png

Верхняя панель инструментов

delete_gerber_png

Clear all layers

load_gerber_png

Load Gerber files

gerbview_drill_file_png

Load Excellon drill files

sheetset_png

Set page size

print_button_png

Print

zoom_redraw_png

Redraw view

zoom_in_png zoom_out_png

Zoom in or out

zoom_fit_in_page_png

Zoom to fit page

zoom_area_png

Zoom to selection

gerbview_top_layer_png

Select active layer

gerbview_top_info_png

Display info about active layer

gerbview_x2_component_png

Highlight items belonging to selected component (Gerber X2)

gerbview_x2_net_png

Highlight items belonging to selected net (Gerber X2)

gerbview_x2_attributeo_png

Highlight items with the selected attribute (Gerber X2)

gerbview_top_dcode_png

Highlight items of selected D Code on the active layer

Левая панель инструментов

cursor_png

Select items

measurement_png

Measure between two points

grid_png

Toggle grid visibility

polar_coord_png

Toggle polar coordinates display

unit_inch_png unit_mm_png unit_mm_png

Select inch, mils, or millimeter units

cursor_shape_png

Toggle full-screen cursor

pad_sketch_png

Display flashed items in sketch (outline) mode

track_sketch_png

Display lines in sketch (outline) mode

opt_show_polygon_png

Display polygons in sketch (outline) mode

gerbview_show_negative_objects_png

Show negative objects in ghost color

show_dcodenumber_png

Show/hide D Codes

gbr_select_mode2_png

Display layers in diff (compare) mode

contrast_mode_png

Toggle inactive layers between normal and dimmed display

layers_manager_png

Show/hide layer manager

flip_board_24

Show Gerbers as mirror image

Менеджер слоёв

gerbview_layer_manager_png

Менеджер слоёв позволяет управлять и контролировать видимость всех слоёв. Стрелка указывает на активный слой, а с помощью отметок можно скрыть или показать нужные слои.

Функции кнопок мыши:

  • Щелчок левой кнопкой мыши на строке: выбор активного слоя.

  • Щелчок правой кнопки мыши на менеджере слоёв: управление отображением сразу всех слоёв.

  • Щелчок средней кнопкой мыши или двойной щелчок (на индикаторе цвета): выбор цвета слоя.

Вкладка Слои позволяет управлять отображением и цветом всех загруженных Gerber-слоёв или слоёв сверловки. Вкладка Элементы позволяет управлять отображением и цветом сетки, D-кодов и негативных объектов.

Команды меню

Меню "Файл"

gerbview_file_menu_png
  • Export to PCB Editor is a limited capability to export Gerber files into a KiCad PCB. The final result depends on what features of the RS-274X format are used in the original Gerber files: rasterized items cannot be converted (typically negative objects), flashed items are converted to vias, lines are converted to track segments (or graphic lines for non-copper layers).

Tools menu

gerbview_tools_menu_png
  • Список D-кодов показывает используемые D-коды и некоторые их параметры.

  • Show Source displays the Gerber file contents of the active layer in a text editor.

  • Measure Tool allows measuring the distance between two points.

  • Очистить текущий слой стирает содержимое активного слоя.

Печать

To print layers, use the print_button_png icon or the File → Print menu.

Be sure items are inside the printable area. Use sheetset_png to select a suitable page format.

Не забывайте, что фотоплоттеры могут использовать зону печати намного большую, чем размер страниц, используемых принтерами. Может потребоваться переместить весь набор слоёв.