Referenzhandbuch

This document is Copyright © 2010-2021 by it’s contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

Alle Markenrechtsnamen in diesem Guide gehören den rechtmäßigen Eigentümern.

Mitwirkende

Das KiCad Team.

Übersetzung

André S. <[email protected]> 2015, Carsten Schoenert <[email protected]> 2016

Feedback

The KiCad project welcomes feedback, bug reports, and suggestions related to the software or its documentation. For more information on how to sumbit feedback or report an issue, please see the instructions at https://www.kicad.org/help/report-an-issue/

Einleitung zu GerbView

GerbView ist ein Betrachtungsprogramm für Gerberdateien (im RS-274X Format) und kann ebenfalls Bohrdaten-Dateien von Pcbnew anzeigen (im Excellon-Format). Es können bis zu 32 Dateien mit einmal angezeigt werden.

Für mehr Informationen über das Gerber Dateiformat lesen Sie bitte die Spezifikation unter Die Spezifikation des Gerber Dateiformats (von Ucamco). Details über das Format für die Bohrdateien können unter Das Excellon Format gefunden werden.

Benutzeroberfläche

Hauptfenster

GerbView Programmfenster

Obere Werkzeugleiste

delete_gerber_png

Clear all layers

load_gerber_png

Load Gerber files

gerbview_drill_file_png

Load Excellon drill files

sheetset_png

Set page size

print_button_png

Print

zoom_redraw_png

Redraw view

zoom_in_png zoom_out_png

Zoom in or out

zoom_fit_in_page_png

Zoom to fit page

zoom_area_png

Zoom to selection

gerbview_top_layer_png

Select active layer

gerbview_top_info_png

Display info about active layer

gerbview_x2_component_png

Highlight items belonging to selected component (Gerber X2)

gerbview_x2_net_png

Highlight items belonging to selected net (Gerber X2)

gerbview_x2_attributeo_png

Highlight items with the selected attribute (Gerber X2)

gerbview_top_dcode_png

Highlight items of selected D Code on the active layer

Linke Werkzeugleiste

cursor_png

Select items

measurement_png

Measure between two points

grid_png

Toggle grid visibility

polar_coord_png

Toggle polar coordinates display

unit_inch_png unit_mm_png unit_mm_png

Select inch, mils, or millimeter units

cursor_shape_png

Toggle full-screen cursor

pad_sketch_png

Display flashed items in sketch (outline) mode

track_sketch_png

Display lines in sketch (outline) mode

opt_show_polygon_png

Display polygons in sketch (outline) mode

gerbview_show_negative_objects_png

Show negative objects in ghost color

show_dcodenumber_png

Show/hide D Codes

gbr_select_mode2_png

Display layers in diff (compare) mode

contrast_mode_png

Toggle inactive layers between normal and dimmed display

layers_manager_png

Show/hide layer manager

flip_board_24

Show Gerbers as mirror image

Lagenverwaltung

Lagenmanager

Der Lagenmanager kontrolliert und zeigt die Sichtbarkeit aller Lagen an. Ein Pfeil zeigt die aktuell gewählte Lage, jede Lage kann durch Checkboxen eingeblendet oder ausgeblendet werden.

Zuordnungen der Mouse Buttons

  • Linksklick: aktive Lage auswählen

  • Rechtsklick: Anzeigen/Verbergen/Sortieren der Lagenoptionen

  • Middle click or double click (on color swatch): select the layer color

The Layers tab allows you to control the visibility and color of all loaded Gerber and drill layers. The Items tab allows you to control the color and display of the grid, D Codes, and negative objects.

Befehle in der Menüzeile

Menü Datei

Menü Datei
  • Export to PCB Editor is a limited capability to export Gerber files into a KiCad PCB. The final result depends on what features of the RS-274X format are used in the original Gerber files: rasterized items cannot be converted (typically negative objects), flashed items are converted to vias, lines are converted to track segments (or graphic lines for non-copper layers).

Tools menu

gerbview_tools_menu_png
  • "D-Codes auflisten" zeigt die benutzten D-Codes und einige D-Code Parameter.

  • Show Source displays the Gerber file contents of the active layer in a text editor.

  • Measure Tool allows measuring the distance between two points.

  • Clear Current Layer erases the contents of the active layer.

Drucken

To print layers, use the print_button_png icon or the File → Print menu.

Be sure items are inside the printable area. Use sheetset_png to select a suitable page format.

Vergessen Sie nicht das Photoplotter einen großen Druckbereich haben, der viel größer als die Blattgrößen von üblichen Druckern ist. Ein Anpassen des Maßstabs kann eventuell nötig sein.