リファレンス・マニュアル

This document is Copyright © 2010-2021 by it’s contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

このガイドの中のすべての商標は、正当な所有者に帰属します。

貢献者

The KiCad Team.

翻訳

murakou <murakou AT jp3cyc.jp>, 2018. starfort <starfort AT nifty.com>, 2017-2018. kinichiro <kinichiro.inoguchi AT gmail.com>, 2015. Norio Suzuki <nosuzuki AT postcard.st>, 2015. yoneken <yoneken AT kicad.jp>, 2011-2015.

フィードバック

The KiCad project welcomes feedback, bug reports, and suggestions related to the software or its documentation. For more information on how to sumbit feedback or report an issue, please see the instructions at https://www.kicad.org/help/report-an-issue/

GerbView の紹介

GerbView は、ガーバー・ファイル (RS 274 X フォーマット) と Excellon ドリル・ファイルのビューアです。同時に32個までのファイルを表示することができます。

ガーバー・ファイル形式についてのより詳しい情報は次の資料をご参照下さい。 the Gerber File Format Specification ドリル・ファイル・フォーマットについての詳細は以下のサイトで見つけることができます。http://web.archive.org/web/20071030075236/http://www.excellon.com/manuals/program.htm[the Excellon format description]

インタフェース

メイン・ウィンドウ

gerbview_main_screen_png

上部ツールバー

delete_gerber_png

Clear all layers

load_gerber_png

Load Gerber files

gerbview_drill_file_png

Load Excellon drill files

sheetset_png

Set page size

print_button_png

Print

zoom_redraw_png

Redraw view

zoom_in_png zoom_out_png

Zoom in or out

zoom_fit_in_page_png

Zoom to fit page

zoom_area_png

Zoom to selection

gerbview_top_layer_png

Select active layer

gerbview_top_info_png

Display info about active layer

gerbview_x2_component_png

Highlight items belonging to selected component (Gerber X2)

gerbview_x2_net_png

Highlight items belonging to selected net (Gerber X2)

gerbview_x2_attributeo_png

Highlight items with the selected attribute (Gerber X2)

gerbview_top_dcode_png

Highlight items of selected D Code on the active layer

左ツールバー

cursor_png

Select items

measurement_png

Measure between two points

grid_png

Toggle grid visibility

polar_coord_png

Toggle polar coordinates display

unit_inch_png unit_mm_png unit_mm_png

Select inch, mils, or millimeter units

cursor_shape_png

Toggle full-screen cursor

pad_sketch_png

Display flashed items in sketch (outline) mode

track_sketch_png

Display lines in sketch (outline) mode

opt_show_polygon_png

Display polygons in sketch (outline) mode

gerbview_show_negative_objects_png

Show negative objects in ghost color

show_dcodenumber_png

Show/hide D Codes

gbr_select_mode2_png

Display layers in diff (compare) mode

contrast_mode_png

Toggle inactive layers between normal and dimmed display

layers_manager_png

Show/hide layer manager

flip_board_24

Show Gerbers as mirror image

レイヤー・マネージャー

gerbview_layer_manager_png

レイヤー・マネージャーは全レイヤーの可視性を制御します。アクティブ・レイヤーは矢印で示され、各レイヤーはチェック・ボックスで表示または非表示に設定できます。

マウス・ボタンの割当て:

  • 左クリック: アクティブ・レイヤーを選択

  • 右クリック: 表示/非表示/ソートのレイヤー・オプション・メニューを表示

  • 中クリックまたはダブル・クリック (色見本上): レイヤー色を選択

レイヤー・タブはレイヤーの表示・非表示、読み込んだすべてのガーバーおよびドリル・レイヤーの色を変更することができます。 アイテム・タブはカラー、グリッドの表示、Dコード、ネガのオブジェクトの操作ができます。

メニュー・バーのコマンド

ファイル・メニュー

gerbview_file_menu_png
  • Export to PCB Editor is a limited capability to export Gerber files into a KiCad PCB. The final result depends on what features of the RS-274X format are used in the original Gerber files: rasterized items cannot be converted (typically negative objects), flashed items are converted to vias, lines are converted to track segments (or graphic lines for non-copper layers).

Tools menu

gerbview_tools_menu_png
  • Dコード・リスト は全レイヤーのDコード情報を表示します。

  • Show Source displays the Gerber file contents of the active layer in a text editor.

  • Measure Tool allows measuring the distance between two points.

  • 現在のレイヤーをクリア はアクティブ・レイヤーの内容を消去します。

印刷

To print layers, use the print_button_png icon or the File → Print menu.

Be sure items are inside the printable area. Use sheetset_png to select a suitable page format.

多くのフォト・プロッターは、殆どのプリンターで使用される用紙サイズより遥かに大きな広いプロット・エリアをサポートしていることに注意して下さい。もしかすると、全てのレイヤーを移動することが必要になるかも知れません。