参考手册

本文件的版权 © 2010-2021 由下列贡献者拥有。您可以根据 GNU 通用公共许可证(http://www.gnu.org/licenses/gpl.html)第 3 版或更高版本,或知识共享署名许可证(http://creativecommons.org/licenses/by/3.0/)第 3.0 版或更高版本的条款发布它和/或修改它。

本文档中出现的所有商标归其持有人所有。

贡献者

KiCad 团队。

翻译人员

Jim Jiang <[email protected]>, 2018.

taotieren <[email protected]>, 2019, 2020, 2021.

Telegram 简体中文交流群: https://t.me/KiCad_zh_CN

反馈

KiCad 项目欢迎与本软件或其文档相关的反馈、错误报告和建议。 关于如何提交反馈意见或报告问题的更多信息,请参见 https://www.kicad.org/help/report-an-issue/ 的说明

Gerber 浏览器介绍

Gerber 浏览器是一个 Gerber 文件(RS-274X 格式)与 Excellon 钻孔文件的查看器,其最多可以一次性显示32个文件。

关于 Gerber 文件的更多信息,可以阅读 Gerber文件格式规范 文档。关于钻孔文件格式的信息,可以阅读 http://web.archive.org/web/20071030075236/ Excellon格式描述 文档。

界面

主窗口

gerbview_main_screen_png

顶部工具栏

delete_gerber_png

清除所有图层

load_gerber_png

加载 Gerber 文件

gerbview_drill_file_png

加载 Excellon 钻孔文件

sheetset_png

设置页面尺寸

print_button_png

打印

zoom_redraw_png

重绘视图

zoom_in_png zoom_out_png

放大或缩小

zoom_fit_in_page_png

自动缩放(缩放适合)

zoom_area_png

缩放至选择

gerbview_top_layer_png

选择活动图层

gerbview_top_info_png

显示有关活动图层的信息

gerbview_x2_component_png

高亮显示属于所选元件的项目(Gerber X2)

gerbview_x2_net_png

高亮显示属于所选网络的项目(Gerber X2)

gerbview_x2_attributeo_png

高亮显示具有所选属性的项目(Gerber X2)

gerbview_top_dcode_png

高亮显示活动图层上所选 D码的项目

左方工具栏

cursor_png

选择项目

measurement_png

测量两点之间

grid_png

切换网格可见性

polar_coord_png

切换极坐标显示

unit_inch_png unit_mm_png unit_mm_png

选择英寸、密尔或毫米单位

cursor_shape_png

切换全屏光标

pad_sketch_png

以草图(边框)模式显示闪烁的项目

track_sketch_png

以草图(边框)模式显示线条

opt_show_polygon_png

以草图(边框)模式显示多边形

gerbview_show_negative_objects_png

以灰色显示负片对象

show_dcodenumber_png

显示/隐藏 D码

gbr_select_mode2_png

以差异(比较)模式显示图层

contrast_mode_png

在高对比度模式下显示当前图层

layers_manager_png

显示/隐藏图层管理器

flip_board_24

将 Gerbers 显示为镜像

层管理器

gerbview_layer_manager_png

层管理器管理着所有图层的显示。左方的三角形箭头指示着当前的活动层,而每一层都可以使用复选框来开启或关闭显示。

鼠标按钮作用:

  • 左键点击:选择活动层

  • 右键点击:显示/隐藏/排序层选项

  • 中键点击或在颜色标识上双击:选择层的颜色

在层标签页中,你可以控制各个图层的颜色和可见性。在项目标签页中,你可以控制网格、D码以及负片物体的颜色和可见性。

菜单栏命令

文件菜单

gerbview_file_menu_png
  • 导出到 PCB 编辑器 是将 Gerber 文件导出到 KiCad PCB 的有限功能。 最终结果取决于原始 Gerber 文件中使用的 RS-274X 格式的哪些功能: 无法转换栅格化的项目 (通常为负值对象),将完成的项目转换为过孔、线条转换为布线段 (或非铜层的图形线)。

工具菜单

gerbview_tools_menu_png
  • “D码列表” 菜单可以显示所有层中的D码信息。

  • 显示源文件 在一个文本编辑器中显示活动层的 Gerber 文件内容。

  • 测量工具 可以测量两点之间的距离。

  • “清除当前层” 菜单可以擦除活动层中的内容。

打印

要打印图层,请使用 print_button_png 图标或 文件 → 打印 菜单。

请确保项目在可打印区域内。使用 sheetet_png 来选择一个合适的页面格式。

需要注意的是,大多数的光电绘图仪都支持很大的打印区域,一般都会大于通常的打印机。故可能需要移动整层来适应光电绘图仪。