参考手册

本文件的版权 © 2010-2021 由下列贡献者拥有。您可以根据 GNU 通用公共许可证(http://www.gnu.org/licenses/gpl.html)第 3 版或更高版本,或知识共享署名许可证(http://creativecommons.org/licenses/by/3.0/)第 3.0 版或更高版本的条款发布它和/或修改它。

本指南中的所有商标均属于其合法所有者。

贡献人员

Jean-Pierre Charras, Fabrizio Tappero, Wayne Stambaugh, Jon Evans

翻译人员

taotieren <admin@taotieren.com>, 2019, 2020, 2021.

Telegram 简体中文交流群: https://t.me/KiCad_zh_CN

译者注:英文双引号包含的中文为软件的功能操作。

反馈

请将任何错误报告、建议或新版本引导到此处:

Pcbnew 简介

初始配置

第一次运行 Pcbnew 时,如果在 KiCad 配置文件夹中找不到全局封装表文件 fp-lib-table,Pcbnew 会询问如何创建该文件:

TODO:添加屏幕截图
TODO:添加有关这些选项含义的说明

默认的封装库表包括作为 KiCad 的一部分安装的所有标准封装库。

Pcbnew 用户界面

pcbnew user interface

主 Pcbnew 用户界面如上所示,其中指出了一些关键元素:

  1. 顶部工具栏 (文件管理、缩放工具、编辑工具)

  2. 左侧工具栏 (显示选项)

  3. 消息面板和状态栏

  4. 右侧工具栏 (绘图和设计工具)

  5. 外观面板

  6. 选择过滤器面板

导航编辑画布

编辑画布是正在设计的板上的视图。您可以平移和缩放到电路板的不同区域,也可以翻转视图以从底部显示电路板。

默认情况下,使用鼠标中键或鼠标右键拖动将平移画布视图,滚动鼠标滚轮将放大或缩小视图。您可以在偏好设置的鼠标和触摸板部分更改此行为 (有关详细信息,请参阅配置和自定义)。

快捷键

TODO:写下这一节

本手册中介绍的热键使用标准 PC 键盘上显示的键标签。在 Apple 键盘布局中,使用 Cmd 键代替 Ctrl 键,使用 Option 键代替 Alt 键。

通过热键可用的许多操作也可在上下文菜单中使用。要访问上下文菜单,请在编辑画布中单击鼠标右键。根据选择的内容或处于活动状态的工具,将提供不同的操作。

显示和选择控件

板层

Pcbnew 中的层表示线路板上的物理铜层,以及用于定义丝印、阻焊和线路板边缘等内容的图形层。编辑器中始终有一个处于活动状态的层。活动层绘制在其他层之上,并且将是指定给新创建对象的层。活动层在顶部工具栏的层选择器下拉框中指示,并在外观面板中高亮显示。若要更改活动图层,可以单击“外观”面板中的图层名称、使用顶部工具栏中的下拉式图层选择器或使用快捷键。可以隐藏图层以简化电路板视图。即使层是活动层,也可以隐藏该层。

外观面板

外观面板提供用于管理 Pcbnew 绘图画布中对象的可见性、颜色和不透明度的控件。它有三个选项卡:图层选项卡包含电路板层的控件,对象选项卡包含不同类型图形对象的控件,网络选项卡包含飞线和铜项外观的控件。

图层控件

在外观面板的图层选项卡中,每个电路板图层都显示其颜色和可见性状态。活动层在色样左侧高亮显示一个箭头指示器。左键单击层以将其选择为活动层。左键单击相应的可见性图标,在可见和隐藏之间切换图层。双击或中键单击色样以更改图层的颜色。

必须先在首选参数中创建自定义颜色主题, 然后才能在“外观”面板中更改图层颜色。

在图层列表下方是一个包含图层显示选项的可展开面板。第一个设置控制非活动图层的显示方式:正常、暗显或隐藏。层显示模式可用于简化视图并聚焦于单个层。当非活动层显示模式为 "暗显" 或 "隐藏" 时,不能选择非活动层上的项目。您可以使用热键 Ctrl+H 快速切换这些显示模式。

翻转电路板视图 将显示电路板,就像从底部看一样(即,绕 Y 轴镜像)。 此选项也可在视图菜单中使用。

对象控件

“外观”面板的“对象”选项卡类似于“图层”选项卡。主要区别在于某些对象没有颜色设置,而四种类型的对象 (布线、过孔、焊盘和区域) 都有不透明度控制滑块。此处的不透明度设置将与图层颜色中设置的任何不透明度相乘。默认情况下,除区域外,所有对象都是完全不透明的,区域被设置为半透明,以便更容易通过填充区域区域看到对象。

图层预设

图层预设存储哪些层和对象是可见和隐藏的,以便于调用。有几个内置的图层预设,您可以存储自己的自定义预设。自定义预设存储在电路板的工程设置中,因为预设可能特定于某个电路板堆叠。

要加载预设,请从外观面板底部的预设下拉菜单中选择它,或者按住 Ctrl 并按 Tab 使用快速切换器。快速切换窗口出现后,您可以按 TabShift+Tab 在可用的预设之间循环。松开 Ctrl 键后,会加载高亮显示的预设。

要保存自定义预设,请首先使用可见性控件选择要显示的层,然后选择保存预设…​。从预设下拉菜单。为您的预设命名,现在可以通过下拉菜单和快速切换器使用它。要修改自定义预设,请遵循相同的过程,并使用相同的名称保存修改后的版本,以覆盖现有版本。要删除自定义预设,请选择删除预设…​。选项,然后从列表中选择要删除的预设。

网络和网络类控件

外观面板的网络选项卡显示电路板中所有网络和网络类的列表。每个网都有一个可见性控件,用于控制该网在飞线中的可见性。在飞线中隐藏网络不会改变电路板的连接性,也不会影响设计规则检查器;这只是为了使飞线更容易理解。

每个网络和网络类还可以指定一种颜色。默认情况下,此颜色适用于网络 (或网络类中的所有网络) 的飞线。默认情况下,网络没有颜色;这由色样中的棋盘格图案指示。双击或右键单击网络或网络类颜色样本以设置颜色。

默认网络类不能分配颜色, 因为该类中的网络将仅使用颜色主题定义的默认飞线最高颜色。

您还可以通过外观面板选择并高亮网络和网络类:右击网络或网络类以在菜单中显示这些选项。

网络类列表下面是一个包含网络显示选项的可扩展面板。第一个选项控制如何应用网络颜色。当选择了“所有”时,属于网络或网络类别的所有铜项 (焊盘、布线、过孔和区域) 都将呈现所选的颜色。当选中“飞线”(默认值)时,只有飞线受网络和网络类别颜色的影响。 当选择“没有”时,网络和网络类颜色被忽略。

第二个选项控制如何绘制飞线。“所有图层”表示将在所有未连接的项目之间绘制飞线。“可见层”意味着不会向隐藏层上的项目绘制任何最新的飞线,即使这些项目是未连接的。

选择和选择筛选器

在编辑画布中选择项目是使用鼠标左键完成的。单击对象将选中该对象,拖动将执行框选择。从左到右的框选择将仅选择完全位于框内的项目。从右到左选择方框将选择接触该方框的任何项目。从左到右的选择框以黄色绘制,从右向左的选择框以蓝色绘制。

可以通过在单击或拖动的同时按住快捷键来修改选择操作。单击以选择单个项目时,将应用以下快捷键:

快捷键 (Windows/Linux) 快捷键 (macOS) 选择效果

Shift

Shift

将项目添加到现有选择。

Alt+Shift

Cmd+Shift

将项目删除到现有选择。

Alt

Cmd

切换项目的选定状态。

Ctrl

Alt

从弹出菜单中明确选择。

Ctrl+Shift

Cmd+Option

高亮选定焊盘或布线的网络

拖动以执行选框时,将应用以下快捷键:

快捷键 (Windows/Linux) 快捷键 (macOS) 选择效果

Shift

Shift

将项目添加到现有选择。

Alt+Shift

Cmd+Shift

将项目删除到现有选择。

Alt

Cmd

切换项目的选定状态。

Pcbnew 窗口右下角的选择过滤器面板控制可以用鼠标选择哪些类型的对象。关闭对不需要的对象类型的选择可以更容易地选择密集电路板中的项目。“所有项目”复选框是打开和关闭其他项目的快捷方式。“锁定的项目”复选框独立于其他复选框,并控制是否可以选择已锁定的项目。您可以在选择过滤器中的任何对象类型上单击鼠标右键以快速更改过滤器,使其仅允许选择该类型的对象。

当选中一个连接的铜项时,您可以使用右击上下文菜单中的展开选定内容命令,或默认情况下使用 U 快捷键,将选择扩展到同一网络的其他铜项。第一次运行此命令时,选择范围将扩展到最近的焊盘。第二次,选择范围将扩展到所有层上所有连接的项目。

Esc 将始终取消当前工具或操作,并返回到选择工具。在选择工具处于活动状态时按 Esc 将清除当前选择。

网络高亮

可以在 PCB 编辑器中高亮一个电气网络(或一组网络),以可视化该网络是如何在 PCB 上布线的。通过在 PCB 编辑器中点击要高亮的网络,或在启用交叉探针高亮时,在原理图编辑器中点击相应的网络,可以激活网络高亮 (见下文)。当网络高亮处于活动状态时,高亮的一个或多个网络将以较亮的颜色显示,而所有其他项目将以比正常颜色较暗的颜色显示。

有三种方法可以点击一个或多个网络在 PCB 编辑器中高亮:点击铜对象后使用热键 ` ,使用任何铜对象的上下文菜单,以及外观面板的网络选项卡的上下文菜单。当您按下高亮网络热键时,任何选定铜件的网络将被高亮。如果未选中铜项,则编辑器光标下的铜项的网络将高亮。如果光标下没有铜项目,则任何现有的高亮都将被清除。也可以使用清除高操作 (热键 ~) 清除高亮。

选择一个或多个网络进行高亮时,左侧工具栏上的切换网络高亮显示操作变为启用(也可通过热键 Ctrl+` 访问)。此操作将打开或关闭高亮,而无需选择要高亮的新网络。

从原理图交叉探测

KiCad 允许在原理图和 PCB 之间进行双向交叉探测。有几种不同类型的交叉探测。

选择交叉探测 允许您在原理图中点击一个符号或引脚,在 PCB (如果存在) 中点击相应的封装或焊盘,反之亦然。默认情况下,交叉探查将导致显示以交叉探查的项目为中心并缩放到合适的位置。可以在首选项对话框的显示选项部分禁用此行为。

高亮交叉探测 允许您同时高亮原理图和 PCB 中的网络。 如果在偏好设置对话框的显示选项部分中启用了选项 "高亮交叉网络", 则在原理图编辑器中高亮某个网络或总线将导致相应的一个或多个网络在 PCB 编辑器中高亮。

左侧工具栏显示控件

左侧工具栏提供了更改 Pcbnew 中项目显示的选项。

grid

打开/关闭栅格显示。

注意: 默认情况下,隐藏网格将禁用网格捕捉。 可以在偏好设置的显示选项部分更改此行为。

polar coord

在状态栏中的极坐标和笛卡尔坐标显示之间切换。

unit inch

unit mil

unit mm

以英寸、密耳或毫米为单位显示/输入坐标和尺寸。

cursor shape

在全屏和小编辑光标 (十字光标) 之间切换。

general ratsnest

打开/关闭飞线显示。

curved ratsnest

在直线型和弧线型飞线之间切换。

show zone

显示分区填充区域。

show zone disable

仅显示区域轮廓。

show zone outline only

将分区填充区域显示为轮廓。

pad sketch

在填充模式和轮廓模式之间切换焊盘的显示。

via sketch

在填充模式和轮廓模式之间切换过孔的显示。

showtrack

在填充模式和轮廓模式之间切换布线显示。

contrast mode

在正常和暗显之间切换非活动层显示模式。

注意: 当非活动层显示模式为暗显或隐藏时,此按钮将突出显示。 在这两种情况下,按下按钮都会将层显示模式更改为正常。 隐藏模式只能通过外观面板中的控件或快捷键 Ctrl+H 进入。

net highlight

选择要高亮的网络时,会打开或关闭高亮。

注意: 当没有高亮任何网络时,此按钮将被禁用。 要高亮网络,可使用热键 `, 右击网络中的任何铜对象并从网络工具菜单中选择高亮网络, 或右击外观面板的网络选项卡中列表中的网络。

show zone

显示覆铜填充区域。

show zone disable

仅显示覆铜轮廓。

show zone outline only

将覆铜填充区域显示为轮廓。

pad sketch

在填充模式和轮廓模式之间切换焊盘的显示。

via sketch

在填充模式和轮廓模式之间切换过孔的显示。

showtrack

在填充模式和轮廓模式之间切换布线显示。

layers manager

显示或隐藏编辑器右侧的外观和选择过滤器面板。

创建 PCB

基本 PCB 概念

KiCad 中的印刷电路板通常由代表电子元件及其焊盘的 封装、定义这些焊盘如何彼此连接的 网络、形成每个网络中焊盘之间的铜连接的 布线过孔填充区 以及定义电路板边缘、丝印标记和任何其他所需信息的各种图形形状组成。

KiCad 通常会将 PCB 上的网络信息与相关的原理图保持同步,但也可以直接在 PCB 编辑器中创建和编辑网络。

性能

KiCad 能够制造多达 32 个铜层、14 个技术层 (丝网、阻焊、元件粘合剂、焊膏等) 和 13 个通用绘图层的印刷电路板。

KiCad 中所有对象的内部测量分辨率为 1 纳米,测量结果存储为 32 位整数。这意味着可以制作出长约 4 米、宽约 4 米的电路板。

KiCad 目前支持每个工程/原理图一个电路板文件。

从原理图开始

从原理图创建电路板是 KiCad 的推荐工作流程。创建新工程时,KiCad 将生成一个与该工程同名的空电路板文件。要在创建原理图后开始设计电路板,只需打开电路板文件即可。您可以从 KiCad 工程管理器,或通过点击原理图编辑器中的 "在电路板编辑器中打开 PCB" 按钮来完成此操作。

从头开始

也可以创建没有匹配原理图的电路板,尽管此工作流程有一些限制,不建议大多数用户使用。为此,您必须独立启动 PCB 编辑器(而不是从 KiCad 工程管理器启动)。在开始设计之前,最好保存电路板文件,该文件还将创建一个工程文件来存储电路板设置。使用 "另存为…​" 从文件菜单选择保存电路板文件的位置。将在您选择保存电路板文件的相同位置创建一个同名的工程文件。

电路板设置

在开始您的线路板设计之前,使用电路板设置对话框来配置电路板的基本参数。要打开电路板设置,请单击顶部工具栏中的 options board 图标或选择 "电路板设置…​" 从文件菜单中选择。

配置电路板压层和物理参数

电路板设置有两个部分用于配置电路板的压层和层。电路板编辑器层部分用于启用或禁用技术(非铜)层,并在需要时为层指定自定义名称。物理压层部分用于配置铜层的数量,以及铜层和介质层的物理参数,例如厚度和材料类型。

要配置电路板的压层,从物理压层部分开始:

pcbnew board setup physical stackup

在左上角设置铜层的数量,然后根据需要输入压层的物理参数。 这些参数可以保留其默认值,但请注意,在导出电路板的三维模型时,将使用电路板的厚度值,所以如果你打算使用这个功能,最好确保压层厚度是正确的。

KiCad 目前仅支持铜层数为偶数的压层。要创建具有奇数层的设计 (例如,柔性印刷电路或金属芯印刷电路),只需选择下一个最高的偶数,而忽略额外的层。

接下来,如果需要,可以使用电路板编辑器层部分重命名或隐藏您不会在设计中使用的非铜层。例如,如果您不打算在设计中使用背面丝印,请取消选中 B.Silkcreen 层旁边的复选框。

pcbnew board setup board editor layers
在电路板编辑器层部分,可以将铜层指定为信号、电源平面、混合或跳线。 本说明书仅供用户参考。无论在此对话框中将类型配置如何, 都可以在任何铜层上布线和覆铜。

在电路板编辑器对话框的电路板完成和阻焊/锡膏部分可以找到一些其他的电路板压层设置。电路板完成部分包含用于定义铜电镀和特殊功能 (如镶边或边缘电镀) 的设置。请注意,这些设置目前只影响作为 Gerber 作业文件一部分的电路板属性输出。

阻焊/锡膏部分允许全局调整电路板上焊盘的铜形状和阻焊/锡膏形状之间的间隙 (正或负)。这些值将添加到在单个封装或焊盘上设置的任何间隙覆盖。正间隙值将导致阻焊或锡膏开口的形状比铜形状大。负间距值将导致开口比铜形状小。

大多数商业 PCB 制造商都希望这些值为零,并在 CAM 过程中自行调整阻焊和粘贴开口。通常最好将这些值保留为默认值零,除非您自己制作 PCB,或者您的制造商有具体建议使用不同的值。

配置默认文本和图形设置

电路板设置对话框的文本和图形默认值部分可用于配置将用于放置在电路板上的新文本和图形形状的属性。

pcbnew board setup text and graphics

可以为对话框中显示的六种不同类别的图层配置线粗细、文字大小和文字外观。此外,可以为所有图层配置标注对象的特性。有关标注属性的更多详细信息,请参阅下面的标注部分。

可以在文本变量部分创建文本替换变量。这些变量允许您用变量名替换任何文本字符串。在变量替换语法 ${VARIABLENAME} 中使用变量名的任何地方都会发生这种替换。

例如,您可以创建一个名为 VERSION 的变量,并将文本替换设置为`1.0`。现在,在 PCB 上的任意文本对象中,输入 ${VERSION},KiCad将替换为 1.0。如果替换为 2.0,则每个包含 ${VERSION} 的文本对象都会自动更新。您还可以混合使用常规文本和变量。例如,您可以创建一个文本对象,文本 Version: ${VERSION} 将替换为 Version: 1.0

配置设计规则

设计规则控制交互式布线器的行为、覆铜的填充和设计规则检查器。设计规则可以随时修改,但我们建议您在电路板设计过程开始时建立所有已知的设计规则。

约束

基本设计规则在电路板设置对话框的约束部分中配置。本节中的约束适用于整个电路板,并应设置为您的电路板制造商推荐的值。此处设置的任何最小值都是绝对最小值 (_absolute_minimum),不能被更具体的设计规则覆盖。例如,如果您需要线路板部分上的铜间距为 0.2 mm,其余的为 0.3 mm,则必须在约束部分中输入 0.2 mm 作为最小铜间距,并使用网类或自定义规则来设置较大的 0.3 mm 间距。

pcbnew board setup constraints

除了设置最小间隙外,还可以在此处配置许多功能:

设置 描述

允许盲孔/埋孔

必须先启用此设置,然后才能使用布线器放置盲孔或埋孔。 盲孔是机械钻孔,从外层铜层之一开始,到内层之一结束。 埋孔是机械钻孔,在内部铜层开始和结束。

允许微孔

在使用布线器放置微孔之前,必须启用此设置。 微孔是典型的激光钻孔,将外层铜层连接到相邻的内层。 KiCad 支持单独的微孔尺寸限制,因为它们通常比机械钻孔的埋孔小。

由线段近似的圆弧/圆

在某些情况下,KiCad 必须使用一系列直线段来近似圆形,如圆弧和圆的形状。 此设置控制此近似所允许的最大误差:换句话说,这些线段之一上的点与圆弧或圆的真实形状之间的最大距离。 将其设置为比默认值 0.005 mm 更小的数字将产生更平滑的形状,但在较大的电路板上可能会非常慢。 默认值通常会导致由于制造公差而在制造的电路板中无法检测到的圆弧近似误差。

覆铜填充策略

KiCad 的覆铜填充算法进行了改进,获得了更好的结果和更快的性能。 新算法产生的结果与旧算法略有不同,因此此设置允许保留旧行为, 以防止在最新版本的 KiCad 中打开旧设计时产生不同的 Gerber 输出。 我们建议对所有新设计使用平滑多边形模式。

允许圆角超出覆铜轮廓

覆铜可以在覆铜属性对话框中添加圆角 (圆角)。 默认情况下,不允许在覆铜轮廓之外使用覆铜 (包括圆角)。 这实际上意味着,即使配置了圆角,也不会对覆铜轮廓的内角进行圆角处理。 通过启用此设置,覆铜轮廓的内角将被圆角,即使这会导致覆铜中的铜延伸到覆铜轮廓之外。

在布线长度计算中包括压层高度

默认情况下,压层的高度用于计算从一层到另一层通过过孔的布线的附加长度。 此计算依赖于正确配置的电路板压层高度。 在某些情况下,最好忽略过孔的高度,假设过孔没有增加长度,则只计算布线长度。 禁用此设置将从布线长度计算中排除过孔长度。

预定义大小

预定义尺寸部分允许您定义布线时要使用的布线和过孔尺寸。网络类可用于定义不同网络中的布线和过孔的默认尺寸 (见下文),但在本节中定义尺寸列表将允许您在布线时逐步执行这些尺寸。例如,您可能希望电路板上的默认布线宽度为 0.2 mm,但对于电流较大的某些部分使用 0.3 mm,对于空间有限的某些部分使用 0.15 mm。您可以在电路板设置对话框中定义这些布线宽度,然后在布线时在它们之间切换。

pcbnew board setup predefined sizes
网络类
TODO:写下这一节
自定义规则
TODO:写下这一节

有关详细信息,请参阅高级主题一章中的自定义设计规则

违规严重程度
TODO:写下这一节
正在导入设置

您可以从现有电路板导入部分或全部电路板设置。此技术可用于创建具有您想要在多个设计上使用的设置的 "模板" 电路板,然后将这些设置从模板电路板导入到每个新电路板中,而不是手动输入。

pcbnew board setup import settings

要导入设置,请单击从其他电路板导入设置…​ 按钮,然后点击您想要从中导入的 kicad_pcb 文件。选择要导入的设置,当前设置将被来自所选电路板的值覆盖。

编辑电路板

放置和绘制操作

放置和绘图工具位于右侧工具栏中。当工具被激活时,它将一直处于活动状态,直到选择了其他工具,或者使用 Esc 键取消该工具。取消任何其他工具时,选择工具始终处于激活状态。

某些工具栏按钮在调色板中有多个可用工具。这些工具由按钮右下角的小箭头表示:pcbnew palette buttons

要显示选项板,可以在工具上单击并按住鼠标按钮,或单击并拖动鼠标。当调色板关闭时,它将显示最近使用的工具。

cursor

选择工具 (默认工具)。

tool ratsnest

本地飞线工具:当线路板飞线被隐藏时,使用该工具选择封装将只显示所选封装的飞线。 再次选择相同的封装将隐藏其飞线。 即使本地飞线工具不再处于活动状态, 每个封装的本地飞线设置也将保持有效。

module

封装放置工具:点击线路板以打开封装选择器, 然后在选择封装后再次点击以确认其位置。

add tracks

ps diff pair

布线/布线差分对:这些工具激活交互式布线器,并允许放置布线和过孔。 下面将更详细地描述交互式布线器。

ps tune length

ps diff pair tune length

ps diff pair tune phase

调整长度:这些工具允许您在布线后调整单个布线的长度, 或差分对的长度或偏差。有关详细信息,请参阅布线部分。

add via

添加过孔:允许放置没有布线的过孔。

使用该工具放置在布线顶部的过孔将采用最近布线段的网络, 并将成为该布线的一部分 (如果连接到布线的焊盘被更新, 则过孔网络将被更新)。

放置在其他任何地方的过孔将承担该位置的铜区网络 (如果存在的话)。 如果铜区的网络发生变化,这些过孔不会自动采用新的网络。

add zone

添加填充覆铜:单击以设置覆铜的起点,然后在绘制覆铜轮廓的其余部分之前配置其属性。 下面将更详细地描述覆铜属性。

add keepout area

添加规则区域:规则区域 (以前称为禁止区域) 可以限制项目的放置和覆铜的填充, 还可以定义要应用特定自定义设计规则的命名区域。

add line

绘制线。

注意: 线是图形对象,与使用布线工具放置的布线不同。 图形对象不能分配给网络。

add arc

绘制圆弧:拾取圆弧的中心点,然后选择起点和终点。

add rectangle

绘制矩形:矩形可以填充,也可以勾勒出轮廓。

add circle

绘制圆:圆可以填充,也可以勾勒出轮廓。

add graphical polygon

绘制图形多边形。多边形可以填充我们的轮廓。

注意: 填充的图形多边形与填充的覆铜不同:图形多边形不能分配给网络, 也不会保持与其他项目的间距。

text

添加文本。

add aligned dimension

add orthogonal dimension

add center dimension

add leader

添加标注。下面将更详细地描述尺寸类型。

add pcb target

添加图层对齐标记。

delete

删除工具:单击对象即可将其删除。

set origin

设置钻孔/放置原点。用于制造输出。

grid select axis

设置栅格原点。

捕捉

移动、拖动和绘制电路板元素时,栅格、焊盘和其他元素可以具有捕捉点,具体取决于用户偏好设置中的设置。在复杂的设计中,捕捉点可能离得太近,这会使当前的工具操作变得困难。使用下表中的快捷键可以在移动鼠标时禁用栅格和对象捕捉。

快捷键 效果

Shift

关闭网格捕捉。

Alt

关闭对象捕捉。

编辑对象属性

所有对象都具有可在对话框中编辑的属性。使用快捷键 E 或从右击上下文菜单中选择属性来编辑所选项目的属性。只有在选定的所有项目都属于同一类型时,才能打开属性对话框。要一次编辑不同类型项目的属性,请参阅下面有关批量编辑工具的部分。

使用封装

TODO:编写本部分-涵盖封装属性、从库更新等

使用焊盘

TODO:编写本节 - 介绍焊盘属性

使用区域

TODO:写下这一节

图形对象

图形对象 (直线、圆弧、矩形、圆、多边形和文本)可以存在于任何图层上,但不能分配给网络。矩形、圆和多边形可以在其属性对话框中设置为填充或轮廓。线宽属性将控制轮廓的宽度,即使是填充形状也是如此。填充形状的线宽可以设置为 "0" 以禁用轮廓。

电路板轮廓 (边缘切割)

KiCad 使用 Edge.Cuts 层上的图形对象来定义线路板轮廓。轮廓必须是连续 (闭合) 的形状,但可以由不同类型的图形对象 (如直线和圆弧) 组成,也可以是单个对象 (如矩形或多边形)。如果没有定义线路板轮廓,或者线路板轮廓无效,则 3D 查看器和某些设计规则检查等某些功能将不起作用。

标注

TODO:写下这一节

布线

KiCad 具有交互式布线器,允许手动或引导 (半自动) 单根布线和差分对。该布线器还可以通过在拖动现有布线时重新布线现有布线,以及在拖动封装时重新布线连接到封装焊盘的布线来修改设计。对于具有严格时序要求的设计,布线器还允许通过插入蛇形调整形状来调整布线长度和差分对偏斜 (相位)。

默认情况下,布线器在放置布线时遵守配置的设计规则:新布线的尺寸 (宽度) 将取自设计规则,并且布线器在确定可以放置新布线和过孔的位置时将遵守设计规则中设置的铜间隙。如果需要,可以通过使用高亮冲突布线器模式并打开布线器设置中的允许 DRC 违规选项 (见下文) 来禁用此行为。

路由器有三种模式,可以随时选择。 布线器模式用于布线新布线,也用于使用拖动(热键 D )命令拖动现有布线。 这些模式是:

  • 高亮冲突:在此模式下,大部分布线器功能被关闭,布线完全手动。 布线时,冲突 (间隙违规) 将以绿色高亮,如果存在冲突,则新布线的布线无法修复,除非打开了允许 DRC 冲突选项。 在此模式下,一次最多可以放置两个布线段 (例如,一个水平线段和一个对角线段)。

  • 推挤:在此模式下,被布线的线段将绕过无法移动的障碍物 (例如,焊盘和锁定的布线/孔孔)和 推挤 障碍,这些障碍物可以移开。布线器在此模式下防止违反 DRC:如果无法布线到不违反 DRC 的光标位置,则不会创建新的布线。

  • 绕走:在此模式下,布线器的行为与推挤模式相同,只是不会移动障碍物。

使用哪种模式取决于个人喜好。对于大多数用户,我们建议使用推挤模式以获得最高效的布线体验,或者,如果您不希望布线器修改未被布线的线段,则建议使用绕走模式。请注意,推挤和绕走模式始终创建水平、垂直和 45 度 (H/V/45) 布线段。如果需要使用 H/V/45 以外的角度布线段,则必须使用高亮碰撞模式,并在交互布线器设置对话框中启用自由角度模式选项。

要布线,请从绘图工具栏中选择布线工具,或使用热键 X。单击起始位置以选择要布线的网络并开始布线。正在布线的网络将自动高亮,并且正在布线的线段周围的灰色轮廓将指示网络的允许间隙。通过更改首选项对话框的显示选项部分中的间隙轮廓设置,可以禁用间隙轮廓。

间隙轮廓显示从布线网络到 PCB 上任何其他铜线的最大间隙。 可以使用自定义设计规则为不同对象指定网络的不同间隙。 布线器将考虑这些间隙,但仅直观地显示最大间距值。

当布线器处于活动状态时,将从布线起点到编辑器光标绘制新的线段。这些线段是未固定临时 (unfixed temporary) 对象,它们显示当您使用左击或 Enter 键来固定布线 (fix the route) 时将创建哪些线段。非固定布线段以比固定布线段更亮的颜色显示。当您使用 Esc 键或通过选择另一个工具退出布线器时,将只保存固定布线段。完成布线操作(热键 End) 将固定所有布线并退出布线器。

在布线时,可以使用撤消最后一个布线段命令 (热键 Backspace) 取消固定最近固定的布线。您可以重复使用此命令以后退已固定的布线。

在早期版本的 KiCad 中,使用鼠标左键或 Enter 固定布线的线段将固定所有线段,直到 (但不包括) 在鼠标光标位置结束的线段。 在 KiCad 6 中,此行为现在是可选的,默认情况下,所有线段 (包括在鼠标光标位置结束的线段) 都将被固定。通过禁用交互式布线器设置对话框中的 "单击时固定所有线段" 选项,可以恢复旧的行为。

布线时,可以按住 Ctrl 键禁用网格捕捉,按住 Shift 键禁用对焊盘和过孔等对象的捕捉。

也可以通过更改首选项对话框的编辑选项部分中的磁吸点首选项来禁用对对象的捕捉。 我们建议您在一般情况下保持启用对象捕捉,这样就不会意外地在焊盘或过孔上略微偏离中心结束布线。

布线形态

在垂直(H) / 水平 (V) / 45 度模式下布线时,形态 是指一组两个线段如何连接单个 H/V/45 度线段无法到达的两个点。 在这种情况下,这些点将由一条水平或垂直线段和一条对角线 (45度) 线段连接。形态指的是这些线段的顺序:是水平/垂直线段还是对角线线段在前。

pcbnew posture a pcbnew posture b

KiCad 的布线器试图根据一系列因素自动选择最佳形态。一般说来,布线器会尝试最大限度地减少路线中的拐角数量,并尽可能避免 "坏" 拐角 (如锐角)。当从焊盘布线或布线到焊盘时,KiCad 将选择将路线与焊盘最长边缘对齐的形态。

在某些情况下,KiCad 无法正确猜测您想要的形态。要在布线时切换布线的形态,请使用切换布线形态命令 (热键 /)。

在没有明显的“最佳”形态的情况下(例如,从过孔开始布线时),KiCad 将使用鼠标光标的移动来选择形态。如果希望布线从直线 (水平或垂直) 线段开始,请在水平或垂直方向上将鼠标从起始位置移开。如果您希望布线以对角线开始,请沿对角线方向移动。一旦光标与布线起始位置相距足够远,形态就会被锁定,并且除非光标回到起始位置,否则不会再更改。可以在交互式布线器设置对话框中禁用从鼠标光标移动检测形态,如下所述。

如果使用切换布线形态命令覆盖 KiCad 选择的形态,则在当前布线操作的其余部分中,将禁用从鼠标移动自动检测形体。

布线转角模式

当以 H/V/45 模式布线时,KiCad 的布线器可以放置尖角或圆角的布线。要在尖角和圆角之间切换,请使用布线拐角模式命令 (热键 Ctrl+/)。使用圆角布线时,每个布线步骤将放置直线段、单个圆弧或同时放置直线段和圆弧。布线形态决定首先放置圆弧还是直线段。

选择所需布线后,还可以在布线后使用圆角布线命令对布线拐角进行圆角处理。

尚不支持使用圆弧拖动布线。当拖动布线或在推挤模式下由布线器移动布线时,圆弧将转换回锐角。

布线宽度

正在布线的线段的宽度通过以下三种方式之一确定:如果布线起点是现有布线的终点,并且启用了顶部工具栏上的 auto track width 按钮,则宽度将设置为现有线段的宽度。否则,如果顶部工具栏中的布线宽度下拉菜单设置为 "使用网络类宽度",则宽度将从正在布线的网络的网络类中获取 (或从为网络指定不同宽度的任何自定义设计规则中获取,例如在加粗区域内)。 最后,如果布线宽度下拉菜单设置为在电路板设置对话框中配置的预定义轨道尺寸之一,则将使用此宽度。

布线宽度永远不能低于在电路板设置对话框的约束部分中配置的最小布线宽度。如果添加的预定义宽度低于此最小约束,则将使用最小约束值。

KiCad 的布线器支持活动布线的单一布线宽度。换句话说,要更改布线中间的宽度,必须结束该布线,然后从上一条布线的末端重新启动一条新布线。要更改活动布线的宽度,请使用热键 WShift+W 逐步浏览在电路板设置对话框中配置的布线宽度。

放置过孔

在布线时,交换层将在当前 (非固定) 布线的末端插入过孔。放置过孔后,布线将在新层上继续。有几种方法可以选择新层并插入过孔:

  • 使用热键选择特定的图层,如 PgUp 选择 F.CuPgDn 选择 B.Cu

  • 通过使用 "下一层" 或 "上一层" 热键 (+-)。

  • 通过使用 "放置过孔" 热键 (V),它将切换到活动层对中的下一层。

  • 通过使用 "选择图层并通过通孔放置" 操作(热键 <),将打开一个对话框来选择目标层。

过孔的尺寸将从激活的过孔尺寸设置中获取,可通过顶部工具栏的下拉列表或增加过孔尺寸 (') 和减小过孔尺寸 (\) 热键访问。与布线宽度非常相似,当通孔大小设置为"使用网络类尺寸" 时,将使用 "电路板设置" 的 "网络类" 部分中配置的过孔大小 (除非被自定义设计规则覆盖)。

如果在电路板设置对话框的约束部分启用了微孔或盲孔/埋孔,则可以在布线时放置这些过孔。使用热键 Ctrl+V 放置微孔,使用热键 Alt+Shift+V 放置盲孔/埋孔。微孔只能被放置成使它们将外部铜层中的一个连接到相邻的层。盲孔/埋孔可以放置在任何层上。

布线器放置的过孔被视为已布线线段的一部分。这意味着过孔网络可以自动更新 (就像布线网络一样),例如,当从原理图更新 PCB 时更改了布线的网络名称。在某些情况下,这可能不是所需的,例如在创建邮戳过孔时。通过关闭过孔属性对话框中的 "通过网络自动更新" 复选框,可以为特定过孔禁用过孔网络的自动更新。使用添加独立过孔工具放置的过孔是在禁用此设置的情况下创建的。

差分对布线

KiCad 中的差分对定义为具有公用 基本名称 (base name) 和正负后缀的网络。KiCad 支持使用 +-PN 作为后缀。例如,网络 USB+USB- 形成差分对,网络 USB_PUSB_N 也是如此。在第一个示例中,基本名称为 USB,在第二个示例中为 USB_。后缀样式不能混合:网络 USB+USB_N 没有形成差分对。确保您在原理图中对差分对网络进行了相应的命名,以便允许在 PCB 编辑器中使用差分对布线器。

要布线差分对,请从绘图工具栏中选择布线差分对工具,或使用热键 6。单击焊盘、过孔或现有差分对布线的末端,开始布线。 您可以从差分对的正网络或负网络开始布线。

目前不可能在现有差分对布线的中间开始对差分对进行布线。

差分对布线器将尝试用设计规则中的间隙布线这对布线(差分对间隙可以在电路板设置对话框的网络类部分中配置,也可以通过使用自定义设计规则来配置)。如果布线的起始或结束位置与配置的间隙不同,布线器将创建一个较短的 "扇出" 部分,以最大限度地缩短差分对未耦合的布线长度。

当交换层或使用放置过孔 (V) 操作时,差分对布线器将创建两个相邻的过孔。这些过孔将被放置在尽可能靠近彼此的位置,同时遵守铜和孔到孔间隙的设计规则。

修改布线

布线后,可以通过移动或拖动进行修改,也可以删除并重新布线。选择单个布线段时,可以使用热键 U 将选择范围扩展到所有连接的布线段。第一次按 U 将用焊盘或过孔选择最近的连接点之间的布线段。第二次按 U 将再次扩展选择范围,以包括所有层上连接到所选布线的所有布线段。使用该技术选择布线可用于快速删除整个布线网络。

有两种不同的拖动命令可用于修改布线段。拖动 (45 度模式) 命令热键 D 用于通过布线器拖动布线。如果布线器模式设置为推挤,则使用此命令拖动将推挤附近的布线。如果布线器模式设置为绕走,则使用此命令拖动将绕过障碍物或停在障碍物处。拖动自由角度命令 热键 G 用于将布线段一分为二,并将新角点拖动到任何位置。拖动自由角度的行为类似于高亮碰撞布线器模式:不会避开或推挤障碍物,只会高亮。

目前还不能拖动包含圆弧的布线。在某些情况下,尝试拖动这些布线会导致圆弧被删除。可以通过选中特定圆弧并使用拖动命令 (D) 来调整其大小。使用此命令调整圆弧大小时,不执行 DRC 检查。

也可以在布线段上使用移动命令(热键 M)。此命令将拾取选定的布线段,忽略任何未选中的附加布线段或过孔。使用 "移动" 命令移动布线时,不执行 DRC 检查。

可以在移动封装的同时重新布线附加到封装的布线。为此,在选中封装的情况下使用 "拖动" 命令 (d)。在封装的焊盘之一结束的任何布线都将随封装一起拖动。此功能有一些限制:它仅在高亮碰撞模式下运行,因此附加到封装的布线不会绕过障碍物或将附近的布线推开。此外,只有在封装焊盘原点结束的布线才会被拖动。仅通过焊盘的布线或在焊盘上原点以外的位置结束的布线将不会被拖动。

可以使用编辑布线和过孔对话框修改布线的宽度和过孔的大小,而无需重新布线。有关详细信息,请参阅下面关于批量编辑工具的部分。

长度调整

长度调整工具可用于在布线后向布线添加蛇形调整形状。要调整布线的长度,请首先选择适当的长度调整工具:单布线调整工具 (热键 7) 将添加蛇形形状,使单个布线的长度达到目标值。差分对调整工具 (热键 8) 将对差分对执行相同的操作。差分对偏斜调整工具 (热键 9) 将增加差分对的较短成员的长度,以消除对正侧和负侧之间的偏斜(相位差)。

要选择长度调整工具的目标长度,请在激活长度调整工具后,从上下文菜单或使用热键 Ctrl+L 打开 "长度调整设置" 对话框:

pcbnew length tuning settings

此对话框还可用于配置曲折形状的大小、形状和间距。

配置目标长度后,单击要开始放置曲折形状的区域中的布线。沿布线移动鼠标光标,将添加曲折形状。光标旁边将出现一个状态窗口,显示轨道的当前长度和目标长度。再次单击以完成当前曲折的放置。如果需要,可以将多条弯道放置在同一布线上。

长度调整工具仅支持调整两个焊盘之间的点对点网络的长度。尚不支持调整具有不同拓扑的网络长度。

交互式布线设置

交互式布线器设置可通过路径菜单访问,或通过右键单击工具栏中的布线按钮来访问。这些设置控制布线和拖动现有布线时的布线行为。

pcbnew interactive router settings
设置 说明

模式

高亮碰撞: 禁用大多数布线功能,并允许手动放置布线和过孔, 同时突出显示 DRC 违规 (冲突)。

推挤: 移动其他布线和过孔,使其不挡路, 以避免违反 DRC 的规定。

绕走: 防止在可能导致 DRC 违规的位置放置布线和过孔, 允许您在现有的布线和过孔周围走动。

自由角度模式

允许以任何角度布线,而不是仅以 45 度增量布线。 仅当布线模式设置为突出显示高亮冲突时, 此选项才可用。

绕过障碍物

在推挤模式下,允许布线尝试在实心障碍物 (如焊盘) 后面移动碰撞布线。

移除多余的布线

自动删除在当前布线中创建的回路, 仅保留回路中最近布线的部分。

优化焊盘连接

启用此设置时,交互式布线器尝试在退出焊盘和过孔时避免锐角 和其他不需要的布线。

平滑拖动线段

拖动布线时,会尝试将布线段组合在一起, 以最大限度地减少方向更改。

允许违反 DRC 规则

在高亮碰撞模式下,允许放置违反 DRC 规则的布线和过孔。 在其他模式下不起作用。

优化正在拖动的布线

启用后,拖动布线段将导致 KiCad 优化屏幕上可见的其余布线。 优化过程去除了不必要的拐角,避免了锐角,通常会尝试找到布线的最短路径。 禁用时,不会对正在拖动的紧邻部分之外的布线执行任何优化。 在拖动布线时尝试优化布线。

使用鼠标路径设置布线形态

尝试根据鼠标路径从布线起点位置拾取布线形态。 如果鼠标从开始位置开始主要沿对角线移动,则形态将设置为对角线起点; 如果鼠标主要水平或垂直移动,则形态将设置为垂直起点。 当鼠标离开布线起始位置很远时,形态估计就会被锁定, 并且可以通过移回起始位置来解锁。

点击时固定所有线段

启用时,在布线时单击将固定已布线的所有布线段的位置, 包括在鼠标光标结束的线段。新的线段将从鼠标光标位置开始。 禁用时,最后一个线段 (在鼠标光标处结束的线段) 将不会固定在适当位置, 可以通过进一步的鼠标移动进行调整。

向前和向后批注

TODO:写下这一节

位置重新批注

TODO:写下这一节

锁定

大多数对象都可以通过其属性对话框、使用右键单击上下文菜单或使用切换锁定热键 (L) 来锁定。除非在选择筛选器中启用了 "锁定的项目" 复选框,否则无法选择锁定的对象。尝试移动锁定的项目将导致出现警告对话框:

pcbnew locked items dialog

在此对话框中选择“覆盖锁定”将允许移动锁定的项目。选择“确定”将允许您移动所选内容中任何未锁定的项目;将锁定的项目留在后面。选择“不再显示”将在接下来的会话中记住您的选择。

批量编辑工具

TODO:写下这一节

清理工具

TODO:写下这一节

检查电路板

测量工具

TODO:写下这一节

设计规则检查

TODO:写下这一节

间隙和约束解析

TODO:写下这一节

3D 查看器

TODO:写下这一节

网络检查

TODO:写下这一节

生成输出

制造输出

TODO:写下这一节

打印

TODO:写下这一节

正在导出文件

TODO:编写本节注意事项:将 IDF 导出器文档带到此处

封装和封装库

管理封装库

TODO:写下这一节

创建和编辑封装

TODO:写下这一节

自定义焊盘形状

封装属性

在这里提到网节点

封装向导

有关创建新的封装向导的更多信息,请参阅高级主题一章的脚本部分。

高级主题

配置和自定义

Pcbnew has a variety of preferences that can be configured through the Preferences dialog. Like all parts of KiCad, the preferences for Pcbnew are stored in the user configuration directory and are independent between KiCad minor versions to allow multiple versions to run side-by-side with independent preferences.

偏好设置对话框的第一部分 (通用、鼠标和触摸板以及快捷键) 在所有 KiCad 程序之间共享。KiCad 手册中“通用偏好设置”部分详细介绍了这些部分。请注意,尽管快捷键部分在所有程序之间共享,但有许多特定于 Pcbnew 的快捷键只有在 Pcbnew 运行时才会出现在列表中。

显示选项

pcbnew preferences display

Rendering Engine: Controls if Accelerated graphics or Fallback graphics are used.

网格样式: 控制如何绘制路线网格。

网格厚度: 控制网格线或网格点的粗细。

Min grid spacing: Controls the minimum distance, in pixels, between two grid lines. Grid lines that violate this minimum spacing will not be drawn, regardless of the current grid setting.

捕捉到网格: 控制何时将绘制和编辑操作捕捉到活动网格上的坐标。 “始终”将启用对齐,即使网格处于隐藏状态; “当网格显示时”将仅在网格可见时启用对齐。

按住 Shift 可以暂时禁用网格捕捉。

Cursor shape: Controls whether the editing cursor is drawn as a small crosshair or a full-screen crosshair (a set of lines covering the entire drawing canvas). The editing cursor shows where the next drawing or editing action will occur and will be snapped to a grid location if snapping is enabled.

Always show crosshairs: Controls whether the editing cursor is shown all the time or only when an editing or drawing tool is active.

Net names: Controls whether or not net name labels are drawn on copper objects. These labels are guides for editing only and do not appear in fabrication outputs.

显示焊盘编号:控制是否在封装焊盘上绘制焊盘编号标签。

显示焊盘 <无网络> 指示器: 控制是否用特殊标记指示没有 网络的焊盘。

布线间隙: 控制是否显示布线和过孔周围的间隙轮廓。 间隙轮廓显示为对象周围的细长形状,表示与其他对象之间的最小间隙, 如约束和设计规则所定义。

显示焊盘间隙: 控制是否显示焊盘周围的间隙轮廓。

交叉探测项的居中视图: 当 Eesschema 和 Pcbnew 都在运行时, 控制点击 Eesschema 中的元件或引脚是否会使 Pcbnew 视图在相应的封装或焊盘上居中。

缩放以适合交叉探测项: 控制是否缩放视图以显示交叉探测 封装或焊盘。

高亮显示交叉探测网络: 控制当在两个工具中激活高亮显示工具时, 是否在 Pcbnew 中高亮显示 Eesschema 中高亮显示的网络。

编辑选项

pcbnew preferences editing

新添加的封装的锁定焊盘: 控制封装的焊盘默认为锁定 还是解锁 (可编辑)。

Flip board items L/R: Controls the direction board items will be flipped when moving them between the top and bottom layers. When checked, items are flipped Left-to-Right (about the Vertical axis); when unchecked, items are flipped Top-to-Bottom (about the Horizontal axis).

Limit graphic lines to H, V, and 45 degrees: Controls whether lines drawn with the graphic drawing tools can take on any angle. Note that this only affects drawing new lines: lines can be edited to take on any angle.

Rotation angle: Controls how far the selected object(s) will be rotated each time the Rotate command is used.

吸附点: 此部分控制对象捕捉,也称为吸附点。启用时,对象捕捉优先于栅格捕捉。 对象捕捉仅适用于活动图层上的对象。 按住 Alt 可暂时关闭对象捕捉。

捕捉焊盘: 控制编辑光标何时捕捉焊盘原点。

捕捉到布线: 控制编辑光标何时捕捉到布线端点。

对齐图形: 控制编辑光标何时对齐图形形状点。

始终显示选定的飞线:启用后,即使全局飞线被隐藏, 选定封装外形的飞线也将始终显示。

用曲线显示飞线:控制飞线是直线绘制还是曲线绘制。

显示页面限制: 控制页面边界是否绘制为矩形。

Mouse drag track behavior: Controls the action that will occur when you drag a track segment with the mouse: "Move" will move the track segment independent of any others. "Drag (45 degree mode)" will invoke the push-and-shove router to drag the track, respecting design rules and keeping other track segments attached. "Drag (free angle)" will move the nearest corner of the track segment, highlighting collisions with other objects but not moving them out of the way.

颜色

pcbnew preferences colors

Pcbnew supports switching between different color themes to match your preferences. Kicad 6.0 comes with two built-in color themes: "KiCad Default" is a new theme designed to have good contrast and balance for most cases and is the default for new installations. "KiCad Classic" is the default theme from KiCad 5.1 and earlier versions. Neither of these built-in themes can be modified, but you can create new themes to customize the look of Pcbnew as well as install themes made by other users.

颜色主题存储在位于 KiCad 配置目录的 Colors 子目录中的 JSON 文件中。“打开主题文件夹”按钮将在您的系统文件管理器中打开此位置,使您可以轻松地管理已安装的主题。要安装新主题,请将其放在此文件夹中,然后重新启动 KiCad。如果文件是有效的颜色主题文件,则新主题将从颜色主题下拉列表中提供。

To create a new color theme, choose New Theme…​ from the drop-down list of color themes. Enter a name for your theme and then begin editing colors. The colors in the new theme will be copied from whatever theme was selected before you created the new theme.

要更改颜色,请双击或中键单击列表中的色样。“重置为默认值”按钮会将该颜色重置为“KiCad 默认”颜色主题中的相应条目。

颜色主题会自动保存;当您关闭偏好设置对话框时,所有更改都会立即反映出来。对话框右侧的窗口显示所选主题外观的预览。

操作插件

TODO:写下这一节

原点和轴

pcbnew preferences origin axes

显示原点: 决定在编辑画布中坐标显示使用哪个坐标原点。 页面原点固定在页面的角落。 用户可以移动钻取/放置文件原点和栅格原点。

X 轴: 控制 X 坐标向右还是向左增加。

Y 轴: 控制 Y 坐标是向上还是向下增加。

自定义设计规则

KiCad 的自定义设计规则系统允许创建比电路板设置对话框的构造页面中提供的通用规则更具体的设计规则。自定义设计规则有很多应用,但通常它们用于将某些规则应用于电路板的一部分,例如特定的网络或网络类、特定的区域或特定的封装。

自定义设计规则存储在一个扩展名为 kicad_dra 的单独文件中。当您开始向项目添加自定义规则时,会自动创建此文件。如果您在项目中使用自定义规则,请在备份或提交到版本控制系统时,确保将 kicad_dra 文件与 kicad_pcbkicad_pro 文件一起保存。

kicad_dra 文件由 KiCad 自动管理,不应使用外部文本编辑器进行编辑。 始终使用电路板设置对话框的自定义规则页面编辑自定义设计规则。

自定义规则编辑器

The custom rules editor is located in the Board Setup dialog and provides a text editor for entering custom rules, a syntax checker that will test your custom rules and note any errors, and a syntax help dialog that contains a quick reference to the custom rules language and some example rules.

最好在编辑自定义规则后使用 检查规则语法 按钮,以确保没有语法错误。自定义规则中的任何错误都将阻止设计规则检查器运行。

自定义规则语法

自定义设计规则语言基于 s 表达式,允许您创建使用内置约束无法实现的设计约束。每条设计规则通常包含一个定义匹配哪些对象的 条件,以及一个定义要应用于匹配对象的规则的 约束

该语言使用圆括号 (()) 来定义相关标记和值的子句。括号必须始终匹配:对于每个 ( 必须有匹配的 )。在子句中,标记和值之间用空格分隔。按照惯例,使用单个空格,但是可以在标记之间使用任意数量的空格字符。在文本字符串有效的地方,没有任何空格的字符串可以用 "' 引起来,也可以不加引号。包含空格的字符串必须始终用引号引起来。在需要嵌套引号的地方,可以使用 " 作为外引号字符,使用 ' 作为内引号字符 (反之亦然),从而实现单层嵌套。换行符不是必需的,但为清楚起见,通常在示例中使用。

在下面的语法描述中,< 尖括号 > 中的项表示必须存在的标记,[ 方括号 ] 中的项表示可选或仅有时需要的标记。

The Custom Rules file must start with a version header defining the version of the rules language. As of KiCad 6.0, the version is 1. The syntax of the version header is (version <number>). So in KiCad 6.0 the header should read:

(version 1)

在版本标题之后,您可以输入任意数量的规则。规则以相反的顺序计算,这意味着首先检查文件中的最后一个规则。一旦找到正在测试的给定集合对象的匹配规则,将不再检查其他规则。实际上,这意味着更具体的规则应该在文件的后面,以便在评估更一般的规则之前对其进行评估。

For example, if you create one rule that limits the minimum clearance between tracks in the net HV and tracks in any other net and a second rule that limits the minimum clearance for all objects inside a certain rule area, make sure the first rule appears later in the custom rules file than the second rule. Otherwise tracks in the HV net could have the wrong clearance if they fall inside the rule area.

Each rule must have a name and one or more constraint clause. The name can be any string and is used to refer to the rule in DRC reports. The constraint defines the behavior of the rule. Rules may also have a condition clause that determines which objects should have the rule applied and an optional layer clause, which specifies which board layers the rule applies to.

(rule <name>
    [(layer <layer_name>)]
    [(condition <expression>)]
    (constraint <constraint_type> [constraint_arguments]))

定制规则文件还可以包括描述规则的注释。注释由任何以 # 字符开头的行表示 (不包括空格)。

# Clearance for 400V nets to anything else
(rule HV
    (condition "A.NetClass == 'HV'")
    (constraint clearance (min 1.5mm)))
图层子句

层 (layer) 子句确定规则将对哪些层起作用。虽然对象层可以在下面介绍的 约束 (constraint) 子句中进行测试,但是使用 层 (layer) 子句效率更高。

层 (layer) 子句的值可以是任何线路板层名,也可以是与顶底铜层 ( F.CuB.Cu ) 匹配的快捷方式 外 (outer),以及与任何内部铜层匹配的快捷键 内 (inner)

如果省略 层 (layer) 子句,则该规则将适用于所有层。

下面是一些示例:

# Do not allow footprints on back layer (no condition clause means this rule always applies)
# 不允许在底层上留下封装 (无条件子句表示此规则始终适用)
(rule "Top side footprints only"
    (layer B.Cu)
    (constraint disallow footprint))

# This rule does the same thing, but is less efficient
# 此规则执行相同的操作,但效率较低
(rule "Top side footprints only"
    (condition "A.Layer == 'B.Cu'")
    (constraint disallow footprint))

# Larger clearance on outer layers (inner layer clearance set by board minimum clearance)
# 外层间隙较大 (内层间隙由电路板最小间隙设置)
(rule "clearance_outer"
    (layer outer)
    (constraint clearance (min 0.25mm)))
条件子句

The rule condition is an expression contained inside a text string (and therefore usually surrounded by quotes in order to allow whitespace for clarity). The expression is evaluated against each pair of objects that is being tested by the design rule checker. For example, when checking for clearance between copper objects, each copper object (track segment, pad, via, etc.) on each net is checked against other copper objects on other nets. If a custom rule exists where the expression matches the two given copper objects and the constraint defines a copper clearance, this custom rule could be used to determine the required clearance between the two objects.

被测对象在表达式语言中称为 AB。这两个对象的顺序并不重要,因为设计规则检查器将测试这两种可能的顺序。例如,您可以编写一条规则,假设 A 为布线,B 为过孔。 有一些表达式函数可以同时测试这两个对象;这些表达式函数使用 AB 作为对象名。

条件中的表达式必须解析为布尔值 ( 真 (truefalse )。如果表达式解析为 true,则规则应用于给定的对象。

每个被测对象都有可以比较的 属性,以及可以执行特定测试的 函数。属性和函数的使用语法分别为 <object>.<property><object>.<function>([arguments])。译者注: <对象>.<属性><对象>.<函数>([参数])

当您在文本编辑器 ( A.B.AB. ) 中键入 <对象 (object)>. 时,会出现一个自动完成列表。将打开包含所有可使用的对象属性的。

使用 布尔运算符 比较对象属性和函数,得到布尔表达式。布尔运算符基于 C/C++ 语法,并支持以下运算符:

==

等于

!=

不等于

>, >=

大于、大于或等于

<, <=

小于、小于或等于

&&

||

For example, A.NetClass == 'HV' will apply to any objects that are part of the "HV" netclass and A.NetClass != B.NetClass will apply to any objects that are in different netclasses. Parentheses can be used to clarify the order of operations in complex expressions but they are not required.

Some properties represent a physical measurement, such as a size, angle, length, position, etc. On these properties, unit suffixes can be used in the custom rules language to specify what units are being used. If no unit suffix is used, the internal representation of the property will be used instead (nanometers for distances and degrees for most angles). The following suffixes are supported:

mm

毫米

mil, th

千分之一英寸 (mils)

in, "

英寸

deg

rad

弧度

自定义设计规则中使用的单位独立于 PCB 编辑器中的显示单位。
约束

规则的 约束 子句定义了规则在条件匹配的对象上的行为。每个约束子句都有一个 约束类型 和一个或多个设置约束行为的参数。单个规则可以有多个约束子句,以便为符合相同规则条件的对象设置多个约束 (如 间隙 (clearance)布线宽度 (trace_width) )。

Many constraints take arguments that specify a physical measurement or quantity. These constraints support minimum, optimal, and maximum value specification (abbreviated "min/opt/max"). The minimum and maximum values are used for design rule checking: if the actual value is less than the minimum or is greater than the maximum value in the constraint, a DRC error is created. The optimal value is only used for some constraints, and informs KiCad of a "best" value to use by default. For example, the optimal diff_pair_gap is used by the router when placing new differential pairs. No errors will be created if the differential pair is later modified such that the gap between the pair is different from the optimal value, as long as the gap is between the minimum and maximum values (if these are specified). In all cases where a min/opt/max value is accepted, any or all of the minimum, optimal, and maximum value can be specified.

Min/opt/max values are specified as (min <value>), (opt <value>), and (max <value>). For example, a track width constraint may be written as (constraint track_width (min 0.5mm) (opt 0.5mm) (max 1.0mm)) or simply (constraint track_width (min 0.5mm)) if only the minimum width is to be constrained.

Constraint type Argument type Description

annular_width

min/opt/max

Checks the width of annular rings on vias.

clearance

min

Checks the clearance between copper objects of different nets. KiCad’s design rule system does not permit constraining clearance between objects on the same net at this time.

To allow copper objects to overlap (collide), create a clearance constraint with the min value less than zero (for example, -1).

courtyard_clearance

min

Checks the clearance between footprint courtyards and generates an error if any two courtyards are closer than the min distance. If a footprint does not have a courtyard shape, no errors will be generated from this constraint.

diff_pair_gap

min/opt/max

Checks the gap between coupled tracks in a differential pair. Coupled tracks are segments that are parallel to each other. Differential pair gap is not tested on uncoupled portions of a differential pair (for example, the fanout from a component).

diff_pair_uncoupled

max

Checks the distance that a differential pair track is routed uncoupled from the other polarity track in the pair (for example, where the pair fans out from a component, or becomes uncoupled to pass around another object such as a via).

disallow

track
via
micro_via
buried_via
pad
zone
text
graphic
hole
footprint

Specify one or more object types to disallow, separated by spaces. For example, (constraint disallow track) or (constraint disallow track via pad). If an object of this type matches the rule condition, a DRC error will be created. This constraint is essentially the same as a keepout rule area, but can be used to create more specific keepout restrictions.

edge_clearance

min/opt/max

Checks the clearance between objects and graphical items on the Edge.Cuts layer (the board outline, as well as any board cutouts or slots defined on that layer).

length

min/max

Checks the total routed length for the nets that match the rule condition and generates an error for each net that is below the min value (if specified) or above the max value (if specified) of the constraint.

hole

min/max

Checks the size (diameter) of a drilled hole in a pad or via. For oval holes, the smaller (minor) diameter will be tested against the min value (if specified) and the larger (major) diameter will be tested agains the max value (if specified).

hole_clearance

min

Checks the clearance between a drilled hole in a pad or via and copper objects on a different net. The clearance is measured from the diameter of the hole, not its center.

hole_to_hole

min

Checks the clearance between mechanically-drilled holes in pads and vias. The clearance is measured between the diameters of the holes, not between their centers. HDI vias (microvias, blind vias, and buried vias) are not tested by this constraint.

silk_clearance

min/opt/max

Checks the clearance between objects on silkscreen layers and other objects.

skew

max

Checks the total skew for the nets that match the rule condition, that is, the difference between the length of each net and the average of all the lengths of each net that is matched by the rule. If the absolute value of the difference between that average and the length of any one net is above the constraint max value, an error will be generated.

track_width

min/opt/max

Checks the width of track and arc segments. An error will be generated for each segment that has a width below the min value (if specified) or above the max value (if specified).

via_count

max

Counts the number of vias on every net matched by the rule condition. If that number exceeds the constraint max value on any matched net, an error will be generated for that net.

对象属性和函数参考

可以在自定义规则表达式中测试以下属性:

常见属性

这些属性适用于所有 PCB 对象。

Property Data type Description

Layer

string

The board layer on which the object exists. For objects that exist on more than one layer, this property will return the first layer (for example, F.Cu for most through-hole pads/vias).

Locked

boolean

True if the object is locked.

Parent

string

Returns the unique identifier of the parent object of this object.

Position_X

dimension

The position of the object’s origin in the X-axis. Note that the origin of an object is not always the same as the center of the object’s bounding box. For example, the origin of a footprint is the location of the (0, 0) coordinate of that footprint in the footprint editor, but the footprint may have been designed such that this location is not in the center of the courtyard shape.

Position_Y

dimension

The position of the object’s origin in the Y-axis. Note that KiCad always uses Y-coordinates that increase from the top to bottom of the screen internally, even if you have configured your settings to show the Y-coordinates increasing from bottom to top.

Type

string

One of "Footprint", "Pad", "Graphic Shape", "Board Text", "Footprint Text", "Zone", "Track", "Via", "Zone", or "Group".

连接的对象属性

这些属性适用于可以分配网的铜对象(焊盘、过孔、覆铜、布线)。

属性 数据类型 描述

Net

integer

铜对象的网络码。

请注意,不能依赖网络码来保持不变:如果您需要在规则中引用特定的网络,请使用`NetName`。 Net 可以用来比较两个性能更好的对象的网络, 例如 A.Net == B.NetA.NetName == B.NetName 快。

NetClass

string

铜对象的网络类的名称。

NetName

string

铜对象的网络名称。

封装属性
属性 数据类型 描述

Clearance_Override

dimension

为封装设置的铜间隙覆盖。

Orientation

double

封装的方向 (旋转) (单位:度)。

Reference

string

封装的位号。

Solderpaste_Margin_Override

dimension

为封装设置的焊膏边缘覆盖。

Solderpaste_Margin_Ratio_Override

dimension

为封装设置的焊膏余量比率覆盖。

Thermal_Relief_Gap

dimension

为封转设置的散热间隙。

Thermal_Relief_Width

dimension

为封装设置的散热连接宽度。

Value

string

封装的 "值" 字段的内容。

焊盘属性
属性 数据类型 描述

Clearance_Override

dimension

为焊盘设置的铜间隙覆盖。

Fabrication_Property

string

"无"、"BGA 焊盘"、"基准, 全局到电路板"、"基准, 本地到封装"、"测试点焊盘"、 "散热片焊盘"、"蜂窝状焊盘" 之一。

Hole_Size_X

dimension

焊盘在 X 轴上的通孔/槽的大小。

Hole_Size_Y

dimension

焊盘在 Y 轴上的通孔/槽的大小。

Orientation

double

焊盘的方向 (旋转) (单位:度)。

Pad_Number

string

焊盘的 "编号",可以是字符串 (例如,BGA 中的 "A1")。

Pad_To_Die_Length

dimension

焊盘的 "焊盘到芯片长度" 属性的值,它是在计算网络时添加到焊盘的网络的附加长度。

Pad_Type

string

"通孔"、"贴片"、"板边连接器" 或 "非导通孔,机械" 之一。

Pin_Name

string

焊盘的名称 (通常是原理图中相应接点的名称)。

Pin_Type

string

焊盘的电气类型 (通常取自原理图中相应的引脚)。 "输入"、"输出"、"双向"、"三态"、"无源"、"自由"、"未指定"、 "电源输入"、"电源输出"、"集电极开路"、"发射器开路" 或 "未连接" 之一。

Round_Radius_Ratio

double

对于圆形矩形焊盘,为半径与矩形大小的比率。

Shape

string

"圆形"、"矩形"、"椭圆形"、"梯形"、"圆角矩形"、"倒角矩形" 或 "自定义" 之一。

Size_X

dimension

焊盘在 X 轴上的大小。

Size_Y

dimension

焊盘在 Y 轴上的大小。

Soldermask_Margin_Override

dimension

为焊盘设置的阻焊边距覆盖。

Solderpaste_Margin_Override

dimension

为焊盘设置的焊膏边距覆盖。

Solderpaste_Margin_Ratio_Override

dimension

为焊盘设置的焊膏边距比率覆盖。

Thermal_Relief_Gap

dimension

为焊盘设置的散热间隙。

Thermal_Relief_Width

dimension

为焊盘设置的散热连接宽度。

布线和圆弧属性
属性 数据类型 描述

Origin_X

dimension

起点的 X 坐标。

Origin_Y

dimension

起点的 Y 坐标。

End_X

dimension

终点的 X 坐标。

End_Y

dimension

终点的 Y 坐标。

Width

dimension

布线或圆弧的宽度。

过孔属性
属性 数据类型 描述

Diameter

dimension

过孔焊盘的直径。

Drill

dimension

过孔成品通孔的直径。

Layer_Bottom

string

过孔压层中的最后一层。

Layer_Top

string

过孔压层中的第一层。

Via_Type

string

"通孔"、"盲孔/埋孔" 或 "微孔" 之一。

覆铜和规则区域属性

这些属性适用于铜区和非铜区,以及规则区(以前称为禁止布线区)。

属性 数据类型 描述

Clearance_Override

dimension

为覆铜设置的铜间隙覆盖。

Min_Width

dimension

覆铜中允许的填充区域的最小宽度。

Name

string

用户指定的名称 (默认情况下为空)。

Pad_Connections

string

"继承"、"无"、"焊盘散热孔"、"实心"、"导通的散热孔" 之一

Priority

int

覆铜的优先级别。

Thermal_Relief_Gap

dimension

为覆铜设置的散热间隙。

Thermal_Relief_Width

dimension

为覆铜设置的散热连接宽度。

图形形状属性

这些属性适用于图形线、圆弧、圆、矩形和多边形。

属性 数据类型 描述

End_X

dimension

终点的 X 坐标。

End_Y

dimension

终点的 Y 坐标。

Thickness

dimension

形状画笔的粗细。

文本属性

这些属性适用于文本对象(封装字段、自由文本标签等)。

属性 数据类型 描述

Bold

boolean

如果文本为粗体,则为 true

Height

dimension

字体中字符的高度。

Horizontal_Justification

string

水平文本对齐 (对齐):"向左对齐"、"居中对齐" 或 "向右对齐" 之一。

Italic

boolean

如果文本为斜体,则为 true

Mirrored

boolean

如果文本为镜像,则为 true

Text

string

文本对象的内容。

Thickness

dimension

字体笔划的粗细。

Width

dimension

字体中字符的宽度。

Vertical_Justification

string

垂直文本对齐方式:"向上对齐"、"居中对齐" 或 "向下对齐" 之一。

Visible

boolean

如果文本对象可见 (显示),则为 true

表达式函数

可以对自定义规则表达式中的对象调用以下函数:

函数 对象 描述

existsOnLayer('layer_id')

A or B

如果对象存在于给定的板层上,则返回 truelayer_id 是包含电路板层名称的字符串。

fromTo('x', 'y')

A or B

如果对象存在于给定焊盘之间的铜层路径上,则返回 truexy 是设计中焊盘的全称,如 'R1-Pad1'

inDiffPair('x')

A or B

如果对象是差分对的一部分,并且该对的基本名称与给定的参数 x 匹配,则返回 真。 例如,inDiffPair('USB_') 返回 USB_PUSB_N 网络中对象的 true* 可以作为通配符,所以 inDiffPair('USB*') 匹配 USB1_PUSB1_N。 因此,在具有名为 USB_P 的网络但没有名为 USB_N 的网络的电路板上,该函数返回 false

insideArea('x')

A or B

如果对象完全位于命名规则区域或覆铜内,则返回 true。 规则区域和覆铜名称可以在各自的属性对话框中设置。 请注意,如果布线段从规则区域的内部向外部交叉,则此函数将返回 false,因为该布线不完全在该区域内。 如果给定区域是填充铜区,则该函数测试给定对象是否在该区域的任何填充铜区内,而不是该对象是否在该区域的轮廓内。

insideCourtyard('x')

insideFrontCourtyard('x')

insideBackCourtyard('x')

A or B

如果对象完全位于给定封装位号的外框内,则返回 true。 第一个变量检查顶层外框或底层外框,如果对象在其中任何一个内,则返回 true;第二个和第三个变量检查特定的外框。 可以在位号中使用 * 通配符: insideCourtyard('R*') 将检查位号以 R 开头的所有封装位号。

isBlindBuriedVia()

A or B

如果对象是盲孔/埋孔,则返回 true

isCoupledDiffPair()

AB

如果正在测试的两个对象属于同一差分对,但极性相反,则返回 true。 例如,如果 A 在网络 USB+ 中,而 B 在网络 USB- 中,则返回 true

isMicroVia()

A or B

如果对象是微孔,则返回 true

isPlated()

A or B

如果对象是导通孔 (在焊盘或过孔中),则返回 true

memberOf('x')

A or B

如果对象是命名组合 x 的成员,则返回 true

自定义设计规则示例

(rule RF_width
	(layer outer)
	(condition "A.NetClass == 'RF'")
	(constraint track_width (min 0.35mm) (max 0.35mm)))

(rule "BGA neckdown"
	(constraint track_width (min 0.2mm) (opt 0.25mm))
	(constraint clearance (min 0.05mm) (opt 0.08mm))
	(condition "A.insideCourtyard('U3')"))

(rule "Distance between Vias of Different Nets"
	(constraint hole_to_hole (min 0.25mm))
	(condition "A.Type =='Via' && B.Type =='Via' && A.Net != B.Net"))

(rule "Distance between test points"
	(constraint courtyard_clearance (min 1.5mm))
	(condition "A.Reference =='TP*' && B.Reference == 'TP*"))

# This assumes that there is a cutout with 1mm thick lines
(rule "Clearance to cutout"
	(constraint clearance (min 0.8mm))
	(condition "A.Layer=='Edge.Cuts' && A.Thickness == 1.0mm"))

(rule "Max Drill Hole Size Mechanical"
	(constraint hole (max 6.3mm))
	(condition "A.Pad_Type == 'NPTH, mechanical'"))

(rule "Max Drill Hole Size PTH"
	(constraint hole (max 6.35mm))
	(condition "A.Pad_Type == 'Through-hole'"))

# Specify an optimal gap for a particular differential pair
(rule "Clock gap"
	(condition "A.inDiffPair('CLK') && AB.isCoupledDiffPair()")
	(constraint diff_pair_gap (opt 0.8mm)))

# Specify a larger clearance between differential pairs and anything else
(rule "Differential pair clearance"
	(condition "A.inDiffPair('*') && !AB.isCoupledDiffPair()")
	(constraint clearance (min 1.5mm)))

脚本

脚本允许您使用 Python 语言自动执行 KiCad 中的任务。可以通过 Python "操作插件" 向 KiCad 添加功能,这些插件可以添加到顶部工具栏。也可以编写与 KiCad 文件交互的独立脚本,例如,从电路板文件自动生成制造输出。

本手册涵盖了一般脚本编写概念。希望编写或修改脚本的用户还应使用 https://docs.kicad.org/doxygen-python/namespaces.html 上的 Doxygen 文档。

KiCad 6 或更新版本需要 Python 3 来支持脚本。Python 2 已不再被支持。

Python 脚本位置

TODO:使用每个平台的最终 6.0 脚本位置填写此内容

操作插件

TODO:编写本部分 (如何安装新的操作插件)

封装向导

封装向导是可以从封装编辑器访问的 Python 脚本的集合。 如果调用封装对话框,则选择一个给定的向导,该向导允许您查看渲染的封装,并且您可以编辑一些参数。

如果插件未正确分发到您的系统软件包,您可以在 KiCad 源代码树中的链接中找到最新版本:https://gitlab.com/kicad/code/kicad/tree/master/pcbnew/python/plugins[gitlab]。

使用脚本控制台

Pcbnew 附带一个内置的 Python 控制台,可用于检查电路板并与其交互。要启动控制台,请使用顶部工具栏中的 py script 图标。Pcbnew Python API 不会自动加载,需要在控制台输入 import pcbnew 即可加载。然后,命令 pcbnew.GetBoard() 将返回对 Pcbnew 中当前加载的电路板的引用,可以通过控制台查看和修改该电路板。

TODO:记录其他有用的 PyAlaMode 函数

编写外部脚本

TODO:写下这一节

编写操作插件

TODO:写下这一节

操作参考

下面是 Pcbnew 中每个可用 操作 的列表:一个可以分配给热键的命令。KiCad 手册中列出了在所有 KiCad 应用程序之间共享的快捷键,此处不包括这些快捷键。

PCB 编辑器

操作 默认快捷键 说明

向下对齐

将选定项目与下边对齐

与垂直中心对齐

将选定项目垂直居中对齐

与水平中心对齐

将选定项目与水平中心对齐

向左对齐

将选定项目与左边对齐

向右对齐

将选定项目与右边对齐

向上对齐

将选定项目与上边对齐

水平分布

沿水平轴分布选定项目

垂直分布

沿垂直轴分布选定项目

放置电路板外封装

执行电路板区域外元件的自动放置

放置选择的封装

执行选择的元件的自动放置

翻转电路板视图

从反面看板

草图图形项目

在轮廓模式下显示图形项

降低图层不透明度

{

使当前图层更透明

增加图层不透明度

}

使当前图层更透明

切换到铜 (B.Cu) 层

PgDn

切换到内层 1

切换到内层 10

切换到内层 11

切换到内层 12

切换到内层 13

切换到内层 14

切换到内层15

切换到内层 16

切换到内层 17

切换到内层 18

切换到内层 19

切换到内层 2

切换到内层 20

切换到内层 21

切换到内层22

切换到内层 23

切换到内层 24

切换到内层 25

切换到内层 26

切换到内层 27

切换到内层 28

切换到内层 29

切换到内层 3

切换到内层 30

切换到内层 4

切换到内层 5

切换到内层 6

切换到内层 7

切换到内层 8

切换到内层 9

切换到下一层

+

切换到上一层

-

切换图层

V

在活动层对中的层之间切换

切换到元件 (F.Cu) 层

PgUp

网络检查器

显示网络检查器

高亮飞线

显示所选项目的飞线

草图焊盘

在轮廓模式下显示焊盘

弯曲的飞线

用曲线显示飞线

修复电路板

运行各种诊断程序并尝试修复电路板

显示外观管理器

显示/隐藏外观管理器

显示焊盘编号

显示焊盘编号

脚本控制台

显示 Python 脚本控制台

显示飞线

显示电路板飞线

草图文本项

在行模式下显示封装文本

草图布线

K

在轮廓模式下显示布线

草图过孔

在轮廓模式下显示过孔

线框区域

仅显示区域边界

填充区

显示区域的填充区域

草图区域

在轮廓模式下显示分区的实心区域

切换区域显示

A

在显示填充区域、线框区域和草图区域之间循环

自动缩放以适应

更改封装时缩放以适应

转换为圆弧

将选定的线段转换为圆弧

转换为规则区域

从所选内容创建规则区域

转换为线

从所选内容创建图形线

转换为多边形

从所选内容创建图形多边形

转换为布线

将选定的图形线转换为布线

转换为区域

从所选内容创建铜区

设计规则检查

显示设计规则检查器窗口

在封装编辑器中打开

Ctrl+E

在封装编辑器中打开选定的封装

附加电路板…​

打开另一个电路板并将其内容附加到此电路板上

电路板设置…​

编辑电路板设置,包括层、设计规则和各种默认设置。

清除网络高亮

~

清除任何现有网络高亮

钻孔/放置文件原点

放置钻孔文件和元件放置文件的原点

Specctra DSN…​

导出 Specctra DSN 布线信息

BOM…​

从电路板创建 BOM 表

IPC-D-356 网表文件…​

生成 IPC-D-356 网表文件

钻孔文件 (.drl)…​

生成 Excellon 钻孔文件

Gerbers (.gbr)…​

为制造生成 Gerbers

元件放置 (.pos)…​

为贴片和插件生成元件放置文件

封装报告 (.rpt)…​

从当前电路板创建所有封装的报告

组合

将所选项目组合,以便将它们作为单个项目处理

进入组合

进入要编辑项目的组合

离开组合

离开当前组合

隐藏网络

隐藏所选网络的飞线

高亮网络

`

高亮网络中的所有铜项

高亮网络

高亮网络中的所有铜项

网表…​

读取网表并更新电路板连接

Specctra 会话…​

导入布线的 Specctra session (*.ses) 文件

锁定

防止项目在画布上移动和/或调整大小

添加封装

O

添加封装

添加图层对齐目标

添加图层对齐目标

删除项目

从组合中删除项目

切换到原理图编辑器

在 Eesschema 中打开原理图

显示网络

显示所选网络的飞线

切换上次网络高亮

在最后两个高亮的网络之间切换

切换锁定

L

锁定或解锁选定项目

切换网络高光

Ctrl+`

切换网络高亮

将布线宽度切换到上一个

Shift+W

将布线宽度更改为上一个的预定义大小

将布线宽度切换到下一个

W

将布线宽度更改为下一个的预定义大小

解组

取消对任何选定组的组合

解锁

允许在画布上移动和/或调整项目大小

减小过孔尺寸

\

将过孔尺寸更改为上一个的预定义尺寸

增大过孔尺寸

'

将通孔尺寸更改为下一个预定义尺寸

将区域复制到图层上…​

将分区轮廓复制到不同的图层上

合并区域

合并区域

更改封装…​

从库中分配不同的封装

更改封装…​

从库中分配不同的封装

清除图形…​

清除多余项目等。

清除布线和过孔…​

清除多余项目、短路项目等。

编辑文本和图形属性…​

全局编辑文本和图形属性

编辑布线和过孔属性…​

全局编辑布线和过孔属性

全局删除…​

从电路板中删除布线、封装和图形项目

移除未使用的焊盘…​

移除或恢复通孔焊盘和过孔上未连接的内层

交换层…​

将布线或图形从一个图层移动到另一个图层

更新封装…​

更新封装以包括库中的任何更改

从库中更新封装…​

更新封装以包括库中的任何更改

间隙解析…​

显示两个选定对象之间活动层的间隙解析

约束解析…​

显示选定对象的约束解析

显示电路板统计信息

显示电路板统计信息

添加对齐标注

Ctrl+Shift+H

添加对齐的线性标注

绘制圆弧

Ctrl+Shift+A

绘制圆弧

切换圆弧方式

/

切换圆弧方式

添加中心标注

添加中心标注

绘制圆

Ctrl+Shift+C

绘制圆

关闭轮廓

关闭正在进行的轮廓

减小线宽

Ctrl+-

减小线宽

删除最后一点

Back

删除添加到当前项目的最后一个点

绘制图形多边形

Ctrl+Shift+P

绘制图形多边形

增大线宽

Ctrl++

增大线宽

添加引线

添加引线标注

绘制线

Ctrl+Shift+L

绘制线

将线限制在 45 度

将图形线限制为垂直、水平和 45 度

添加正交标注

添加正交标注

放置导入的图形

Ctrl+Shift+F

绘制矩形

绘制矩形

添加规则区域

Ctrl+Shift+K

添加规则区域 (禁止布线区)

放置封装锚定

Ctrl+Shift+N

设置封装的坐标原点 (锚点)

添加相似区域

Ctrl+Shift+.

使用与现有分区相同的设置添加分区

添加文本

Ctrl+Shift+T

添加文本项

添加过孔

Ctrl+Shift+V

添加独立过孔

添加填充区域

Ctrl+Shift+Z

添加填充区域

添加区域裁剪

Shift+C

添加现有分区的剪切区域

获取并移动封装

T

通过位号选择封装,并将其放置在光标下以进行移动

更改布线宽度

更新选定的布线和过孔尺寸

创建阵列…​

Ctrl+T

创建阵列

删除整条布线

Shift+Del

删除选定项目和铜层连接

重复和递增

Ctrl+Shift+D

复制所选项目,递增焊盘编号

弧形布线

添加与所选直线轨迹线段相切的圆弧

更改侧面/翻转

F

将所选项目翻转到电路板的反面

镜像

镜像选择项

精确移动…​

Ctrl+M

按精确的数量移动所选项目

属性…​

E

显示项目属性对话框

逆时针旋转

R

逆时针旋转所选项目

顺时针旋转

Shift+R

顺时针旋转所选项目

带位号复制

将选定项目复制到具有指定起点的剪贴板

移动

M

移动选定项目

随位号移动

移动具有指定起点的选定项目

自动完成布线

F

自动完成当前布线。

分割布线

将布线段拆分为在光标位置连接的两个段。

自定义布线/过孔尺寸…​

Q

显示用于更改布线宽度和过孔大小的对话框。

差分对交互布线

6

差分对交互布线

差分对标注…​

打开差分对标注设置

拖动 (45 度模式)

D

拖动布线段,同时将连接的布线保持在 45 度。

拖动 (自由角度)

G

拖动布线中最近的节点而不限制布线角度。

完成布线

End

停止当前布线。

布线高亮模式

将布线切换到高亮模式

分割布线

将布线段分割为在光标位置连接的两个段。

放置盲孔或埋孔

Alt+Shift+V

在当前布线的末端添加盲孔或埋孔。

放置微孔

Ctrl+V

在当前布线的末端添加微孔。

放置通孔

V

在当前布线的末端添加通孔。

选择图层并放置盲孔/埋孔…​

Alt+<

选择一个层,然后在当前布线的末端添加盲孔或埋孔。

选择图层并放置通孔…​

<

选择一个层,然后在当前布线的末端添加通孔。

设置层对…​

更改布线的活动层对

交互式布线设置…​

Ctrl+Shift+,

打开交互式布线设置

布线推挤模式

将布线切换到推挤模式

单轨交互式布线

X

交互式布线

切换布线形态

/

切换当前交互式布线的形态。

改变拐角类型

Ctrl+/

切换当前交互式布线的拐角类型。

撤消最后一段布线

Back

停止当前布线。

布线绕走模式

将布线切换到绕走模式

取消选择网络中的所有布线

取消选择属于同一网的所有布线和过孔。

过滤选中项…​

按类型从选区删除项目

选择/扩展连接

U

选择连接或将现有选择扩展到连接点、焊盘或整个连接

选择网中的所有布线

选择所有属于同一网络的布线与过孔。

图框

选择原理图图框中的所有封装和布线

同一层次图框中的项目

选择同一原理图中的所有封装和布线

减小幅度

4

将弯曲幅度降低一级。

增大幅度

3

将弯曲幅度增加一级。

结束布线

End

当前转折处停止布线。

长度优化设置…​

Ctrl+L

设置当前布线项长度调整参数。

减小间距

2

将弯曲间距降低一级。

增大间距

1

将弯曲间距增加一级。

新建布线

X

开始新的布线。

调整差分对布线长度

8

调整差分对布线歪斜

9

调整单轨布线长度

7

添加微波多边形

从顶点列表创建微波多边形形状

添加微波间隙

为微波应用创建指定长度的高频设计间隙

添加微波线

为微波应用创建指定长度的高频设计线

添加微波短截线 (Stub)

为微波应用创建指定长度的高频设计短截线 (Stub)

添加微波弧形短截线 (Stub)

为微波应用创建指定尺寸的高频设计短截线 (弧线)

封装检查器

显示封装检查器窗口

复制封装

创建封装…​

使用封装向导创建一个新的封装

剪切封装

从库中删除封装

编辑封装

在编辑器画布上显示选定的轮廓线

导出封装…​

封装属性…​

编辑封装属性

导入封装…​

新建封装…​

Ctrl+N

创建一个新的空封装

粘贴封装

显示封装树形工作区

切换封装树形工作区可见性

将默认焊盘属性粘贴到选定项

将先前复制的属性替换为当前焊盘属性

将焊盘属性复制到默认值

复制当前焊盘属性

将焊盘属性推送到其他焊盘…​

复制当前焊盘属性到其他焊盘

默认焊盘属性…​

编辑创建新焊盘时使用的焊盘属性

焊盘重新编号…​

按所需顺序单击它们重新编号

将焊盘编辑为图形形状

Ctrl+E

取消自定义形状焊盘的分组,以便作为单个图形形状进行编辑

添加焊盘

添加焊盘

完成焊盘编辑

Ctrl+E

将所有接触图形形状重新组合到已编辑的焊盘中

创建拐角

Ins

创建拐角

移除拐角

移除拐角

相対位置…​

Shift+P

根据所选项目相对于另一个项目的精确数量定位所选项目

位置重新批注…​

按位置顺序重新批注 PCB

填充

填充区域

填充所有

B

填充所有区域

取消填充

取消填充区域

取消填充所有

Ctrl+B

取消填充所有区域

3D 查看器

操作 默认快捷键 说明

添加基板

在电路板下面添加一块基板 (慢)

抗锯齿

在最终渲染中以最高质量渲染 (慢)

切换表贴(SMD) 3D 模型

S

切换表贴元件的 3D 模型

切换直插 3D 模型

T

切换直插元件的 3D 模型

切换虚拟 3D 模型

V

切换虚拟元件的 3D 模型

翻转电路板

翻转电路板视图

主视图

Home

主视图

CAD 颜色样式

根据材质的漫反射颜色使用 CAD 颜色样式

仅使用漫反射

仅使用 3D 模型文件中的漫反射颜色属性

使用所有属性

使用每个 3D 模型文件中的所有材质属性

下移电路板

Down

下移电路板

左移电路板

Left

左移电路板

右移电路板

Right

右移电路板

上移电路板

Up

上移电路板

不显示 3D 网格

不显示 3D 网格

中心轴旋转

Space

中心轴旋转 (点击鼠标中键)

后期处理

在最终渲染中,应用屏幕空间环境光遮蔽和全局光照反射 (慢)

过程纹理

将过程纹理应用于材质 (慢)

渲染阴影

渲染阴影

重置视图

R

重置视图

沿 Z 轴旋转 45 度

Tab

沿 X 轴顺时针旋转

沿 X 轴顺时针旋转

沿 X 轴逆时针旋转

沿 X 轴逆时针旋转

沿 Y 轴顺时针旋转

沿 Y 轴顺时针旋转

沿 Y 轴逆时针旋转

沿 Y 轴逆时针旋转

沿 Z 轴顺时针旋转

沿 Z 轴顺时针旋转

沿 Z 轴逆时针旋转

沿 Z 轴逆时针旋转

3D 网格 10mm

3D 网格 10 mm

3D 网格 1 mm

3D 网格 1 mm

3D 网格 2.5 mm

3D 网格 2.5 mm

3D 网格 5 mm

3D 网格 5 mm

显示 3D 轴线

显示 3D 轴线

显示模型边框

显示模型边框

反射

在最终渲染中渲染具有反射属性的材质 (慢)

折射

在最终渲染中渲染具有折射属性的材质 (慢)

切换胶粘层显示

切换胶粘层的显示

切换电路板显示

切换电路板显示

切换注释和绘图层显示

切换注释和绘图层的显示

切换 ECO 层显示

切换 ECO 层的显示

切换正交投影

启用/禁用正交投影

切换真实模式

切换真实模式

切换丝印层显示

切换丝印层的显示

切换阻焊层显示

切换阻焊层的显示

切换锡膏层显示

切换锡膏层的显示

切换区域显示

切换区域显示

后视图

Shift+Y

后视图

底视图

Shift+Z

底视图

正视图

Y

正视图

左视图

Shift+X

左视图

右视图

X

右视图

顶视图

Z

顶视图