KiCad PCB EDA Suite
menubar_footprint_editor.cpp
Go to the documentation of this file.
1/*
2 * This program source code file is part of KiCad, a free EDA CAD application.
3 *
4 * Copyright (C) 2015 Jean-Pierre Charras, jp.charras at wanadoo.fr
5 * Copyright (C) 2015 SoftPLC Corporation, Dick Hollenbeck <[email protected]>
6 * Copyright (C) 2015 Wayne Stambaugh <[email protected]>
7 * Copyright (C) 1992-2022 KiCad Developers, see AUTHORS.txt for contributors.
8*
9 * This program is free software; you can redistribute it and/or
10 * modify it under the terms of the GNU General Public License
11 * as published by the Free Software Foundation; either version 2
12 * of the License, or (at your option) any later version.
13 *
14 * This program is distributed in the hope that it will be useful,
15 * but WITHOUT ANY WARRANTY; without even the implied warranty of
16 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 * GNU General Public License for more details.
18 *
19 * You should have received a copy of the GNU General Public License
20 * along with this program; if not, you may find one here:
21 * http://www.gnu.org/licenses/old-licenses/gpl-2.0.html
22 * or you may search the http://www.gnu.org website for the version 2 license,
23 * or you may write to the Free Software Foundation, Inc.,
24 * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
25 */
26
28#include "pcbnew_id.h"
29#include <bitmaps.h>
30#include <menus_helpers.h>
31#include <tool/actions.h>
32#include <tool/action_menu.h>
33#include <tool/tool_manager.h>
34#include <tools/pcb_actions.h>
36#include <widgets/wx_menubar.h>
37
38
40{
42 // wxWidgets handles the Mac Application menu behind the scenes, but that means
43 // we always have to start from scratch with a new wxMenuBar.
44 wxMenuBar* oldMenuBar = GetMenuBar();
45 WX_MENUBAR* menuBar = new WX_MENUBAR();
46
47 //-- File menu ----------------------------------------------------------
48 //
49 ACTION_MENU* fileMenu = new ACTION_MENU( false, selTool );
50
51 fileMenu->Add( ACTIONS::newLibrary );
52 fileMenu->Add( ACTIONS::addLibrary );
53 fileMenu->Add( PCB_ACTIONS::newFootprint );
55
56 fileMenu->AppendSeparator();
57
58 fileMenu->Add( ACTIONS::save );
59 fileMenu->Add( ACTIONS::saveAs );
60 fileMenu->Add( ACTIONS::revert );
61
62 fileMenu->AppendSeparator();
63
64 ACTION_MENU* submenuImport = new ACTION_MENU( false, selTool );
65 submenuImport->SetTitle( _( "Import" ) );
66 submenuImport->SetIcon( BITMAPS::import );
67
68 submenuImport->Add( PCB_ACTIONS::importFootprint, ACTION_MENU::NORMAL, _( "Footprint..." ) );
69 submenuImport->Add( PCB_ACTIONS::placeImportedGraphics, ACTION_MENU::NORMAL, _( "Graphics..." ) );
70
71 fileMenu->Add( submenuImport );
72
73 ACTION_MENU* submenuExport = new ACTION_MENU( false, selTool );
74 submenuExport->SetTitle( _( "Export" ) );
75 submenuExport->SetIcon( BITMAPS::export_file );
76
77 submenuExport->Add( PCB_ACTIONS::exportFootprint, ACTION_MENU::NORMAL, _( "Footprint..." ) );
78 submenuExport->Add( _( "View as &PNG..." ),
79 _( "Create a PNG file from the current view" ),
82
83 fileMenu->Add( submenuExport );
84
85 fileMenu->AppendSeparator();
87
88 fileMenu->AppendSeparator();
89 fileMenu->Add( ACTIONS::print );
90
91 fileMenu->AppendSeparator();
92 fileMenu->AddClose( _( "Footprint Editor" ) );
93
94
95 //-- Edit menu -------------------------------------------------------
96 //
97 ACTION_MENU* editMenu = new ACTION_MENU( false, selTool );
98
99 editMenu->Add( ACTIONS::undo );
100 editMenu->Add( ACTIONS::redo );
101
102 editMenu->AppendSeparator();
103 editMenu->Add( ACTIONS::cut );
104 editMenu->Add( ACTIONS::copy );
105 editMenu->Add( ACTIONS::paste );
106 editMenu->Add( ACTIONS::doDelete );
107 editMenu->Add( ACTIONS::duplicate );
108
109 editMenu->AppendSeparator();
110 editMenu->Add( ACTIONS::selectAll );
111
112 editMenu->AppendSeparator();
115
116
117 //-- View menu -------------------------------------------------------
118 //
119 ACTION_MENU* viewMenu = new ACTION_MENU( false, selTool );
120
122 viewMenu->Add( ACTIONS::show3DViewer );
123
124 viewMenu->AppendSeparator();
125 viewMenu->Add( ACTIONS::zoomInCenter );
126 viewMenu->Add( ACTIONS::zoomOutCenter );
127 viewMenu->Add( ACTIONS::zoomFitScreen );
128 viewMenu->Add( ACTIONS::zoomTool );
129 viewMenu->Add( ACTIONS::zoomRedraw );
130
131 viewMenu->AppendSeparator();
133 viewMenu->Add( ACTIONS::gridProperties );
135
136 // Units submenu
137 ACTION_MENU* unitsSubMenu = new ACTION_MENU( false, selTool );
138 unitsSubMenu->SetTitle( _( "&Units" ) );
139 unitsSubMenu->SetIcon( BITMAPS::unit_mm );
141 unitsSubMenu->Add( ACTIONS::milsUnits, ACTION_MENU::CHECK );
143 viewMenu->Add( unitsSubMenu );
144
146
147 viewMenu->AppendSeparator();
148 // Drawing Mode Submenu
149 ACTION_MENU* drawingModeSubMenu = new ACTION_MENU( false, selTool );
150 drawingModeSubMenu->SetTitle( _( "&Drawing Mode" ) );
151 drawingModeSubMenu->SetIcon( BITMAPS::add_zone );
152
153 drawingModeSubMenu->Add( PCB_ACTIONS::padDisplayMode, ACTION_MENU::CHECK );
155 drawingModeSubMenu->Add( PCB_ACTIONS::textOutlines, ACTION_MENU::CHECK );
156 viewMenu->Add( drawingModeSubMenu );
157
158 // Contrast Mode Submenu
159 ACTION_MENU* contrastModeSubMenu = new ACTION_MENU( false, selTool );
160 contrastModeSubMenu->SetTitle( _( "&Contrast Mode" ) );
161 contrastModeSubMenu->SetIcon( BITMAPS::contrast_mode );
162
163 contrastModeSubMenu->Add( ACTIONS::highContrastMode, ACTION_MENU::CHECK );
164 contrastModeSubMenu->Add( PCB_ACTIONS::layerAlphaDec );
165 contrastModeSubMenu->Add( PCB_ACTIONS::layerAlphaInc );
166 viewMenu->Add( contrastModeSubMenu );
167
169
170 viewMenu->AppendSeparator();
173
174
175 //-- Place menu -------------------------------------------------------
176 //
177 ACTION_MENU* placeMenu = new ACTION_MENU( false, selTool );
178
179 placeMenu->Add( PCB_ACTIONS::placePad );
180 placeMenu->Add( PCB_ACTIONS::drawRuleArea );
181
182 placeMenu->AppendSeparator();
183 placeMenu->Add( PCB_ACTIONS::drawLine );
184 placeMenu->Add( PCB_ACTIONS::drawArc );
185 placeMenu->Add( PCB_ACTIONS::drawRectangle );
186 placeMenu->Add( PCB_ACTIONS::drawCircle );
187 placeMenu->Add( PCB_ACTIONS::drawPolygon );
188 placeMenu->Add( PCB_ACTIONS::placeImage );
189 placeMenu->Add( PCB_ACTIONS::placeText );
190 placeMenu->Add( PCB_ACTIONS::drawTextBox );
191
192 placeMenu->AppendSeparator();
197 placeMenu->Add( PCB_ACTIONS::drawLeader );
198
199 placeMenu->AppendSeparator();
200 placeMenu->Add( PCB_ACTIONS::setAnchor );
201 placeMenu->Add( ACTIONS::gridSetOrigin );
202
203
204 //-- Inspect menu ------------------------------------------------------
205 //
206 ACTION_MENU* inspectMenu = new ACTION_MENU( false, selTool );
207
208 inspectMenu->Add( ACTIONS::measureTool );
209
210 inspectMenu->AppendSeparator();
211 inspectMenu->Add( PCB_ACTIONS::checkFootprint );
212
213
214 //-- Tools menu --------------------------------------------------------
215 //
216 ACTION_MENU* toolsMenu = new ACTION_MENU( false, selTool );
217
218 toolsMenu->Add( _( "&Load Footprint from PCB..." ),
219 _( "Load a footprint from the current board into the editor" ),
222
223 toolsMenu->Add( _( "&Insert Footprint on PCB" ),
224 _( "Insert footprint onto current board" ),
227
228 toolsMenu->AppendSeparator();
229 toolsMenu->Add( PCB_ACTIONS::cleanupGraphics );
230 toolsMenu->Add( PCB_ACTIONS::repairFootprint );
231
232
233 //-- Preferences menu -------------------------------------------------
234 //
235 ACTION_MENU* prefsMenu = new ACTION_MENU( false, selTool );
236
237 prefsMenu->Add( ACTIONS::configurePaths );
239
240 // We can't use ACTIONS::showPreferences yet because wxWidgets moves this on
241 // Mac, and it needs the wxID_PREFERENCES id to find it.
242 prefsMenu->Add( _( "Preferences..." ) + wxT( "\tCtrl+," ),
243 _( "Show preferences for all open tools" ),
244 wxID_PREFERENCES,
246
247 prefsMenu->AppendSeparator();
248 AddMenuLanguageList( prefsMenu, selTool );
249
250 //--MenuBar -----------------------------------------------------------
251 //
252 menuBar->Append( fileMenu, _( "&File" ) );
253 menuBar->Append( editMenu, _( "&Edit" ) );
254 menuBar->Append( viewMenu, _( "&View" ) );
255 menuBar->Append( placeMenu, _( "&Place" ) );
256 menuBar->Append( inspectMenu, _( "&Inspect" ) );
257 menuBar->Append( toolsMenu, _( "&Tools" ) );
258 menuBar->Append( prefsMenu, _( "P&references" ) );
259 AddStandardHelpMenu( menuBar );
260
261 SetMenuBar( menuBar );
262 delete oldMenuBar;
263}
@ insert_module_board
@ contrast_mode
@ load_module_board
static TOOL_ACTION gridProperties
Definition: actions.h:144
static TOOL_ACTION toggleGrid
Definition: actions.h:143
static TOOL_ACTION paste
Definition: actions.h:69
static TOOL_ACTION zoomRedraw
Definition: actions.h:92
static TOOL_ACTION millimetersUnits
Definition: actions.h:149
static TOOL_ACTION revert
Definition: actions.h:55
static TOOL_ACTION show3DViewer
Definition: actions.h:162
static TOOL_ACTION zoomOutCenter
Definition: actions.h:96
static TOOL_ACTION togglePolarCoords
Definition: actions.h:152
static TOOL_ACTION saveAs
Definition: actions.h:52
static TOOL_ACTION addLibrary
Definition: actions.h:49
static TOOL_ACTION copy
Definition: actions.h:68
static TOOL_ACTION milsUnits
Definition: actions.h:148
static TOOL_ACTION showFootprintLibTable
Definition: actions.h:181
static TOOL_ACTION undo
Definition: actions.h:65
static TOOL_ACTION duplicate
Definition: actions.h:72
static TOOL_ACTION inchesUnits
Definition: actions.h:147
static TOOL_ACTION highContrastMode
Definition: actions.h:105
static TOOL_ACTION toggleCursorStyle
Definition: actions.h:104
static TOOL_ACTION measureTool
Definition: actions.h:157
static TOOL_ACTION doDelete
Definition: actions.h:73
static TOOL_ACTION save
Definition: actions.h:51
static TOOL_ACTION zoomFitScreen
Definition: actions.h:98
static TOOL_ACTION redo
Definition: actions.h:66
static TOOL_ACTION zoomTool
Definition: actions.h:101
static TOOL_ACTION print
Definition: actions.h:57
static TOOL_ACTION zoomInCenter
Definition: actions.h:95
static TOOL_ACTION newLibrary
Definition: actions.h:48
static TOOL_ACTION cut
Definition: actions.h:67
static TOOL_ACTION gridSetOrigin
Definition: actions.h:140
static TOOL_ACTION configurePaths
Definition: actions.h:179
static TOOL_ACTION showFootprintBrowser
Definition: actions.h:165
static TOOL_ACTION selectAll
Definition: actions.h:71
Defines the structure of a menu based on ACTIONs.
Definition: action_menu.h:49
static constexpr bool CHECK
Definition: action_menu.h:189
void AddClose(const wxString &aAppname="")
Add a standard close item to the menu with the accelerator key CTRL-W.
void SetTitle(const wxString &aTitle) override
Set title for the menu.
Definition: action_menu.cpp:87
static constexpr bool NORMAL
Definition: action_menu.h:188
void SetIcon(BITMAPS aIcon)
Assign an icon for the entry.
Definition: action_menu.cpp:73
wxMenuItem * Add(const wxString &aLabel, int aId, BITMAPS aIcon)
Add a wxWidgets-style entry to the menu.
void AddStandardHelpMenu(wxMenuBar *aMenuBar)
Adds the standard KiCad help menu to the menubar.
void doReCreateMenuBar() override
(Re)Create the menubar for the Footprint Editor frame
static TOOL_ACTION drawRuleArea
Definition: pcb_actions.h:185
static TOOL_ACTION placeText
Definition: pcb_actions.h:176
static TOOL_ACTION drawOrthogonalDimension
Definition: pcb_actions.h:181
static TOOL_ACTION drawRectangle
Definition: pcb_actions.h:172
static TOOL_ACTION setAnchor
Definition: pcb_actions.h:192
static TOOL_ACTION padDisplayMode
Definition: pcb_actions.h:280
static TOOL_ACTION showLayersManager
Definition: pcb_actions.h:389
static TOOL_ACTION drawCircle
Definition: pcb_actions.h:173
static TOOL_ACTION placeImage
Definition: pcb_actions.h:175
static TOOL_ACTION createFootprint
Definition: pcb_actions.h:403
static TOOL_ACTION exportFootprint
Definition: pcb_actions.h:418
static TOOL_ACTION showFootprintTree
Definition: pcb_actions.h:395
static TOOL_ACTION drawTextBox
Definition: pcb_actions.h:177
static TOOL_ACTION layerAlphaDec
Definition: pcb_actions.h:325
static TOOL_ACTION drawPolygon
Definition: pcb_actions.h:171
static TOOL_ACTION placePad
Activation of the drawing tool (placing a PAD)
Definition: pcb_actions.h:426
static TOOL_ACTION drawRadialDimension
Definition: pcb_actions.h:180
static TOOL_ACTION editTextAndGraphics
Definition: pcb_actions.h:360
static TOOL_ACTION drawLeader
Definition: pcb_actions.h:182
static TOOL_ACTION layerAlphaInc
Definition: pcb_actions.h:324
static TOOL_ACTION newFootprint
Definition: pcb_actions.h:400
static TOOL_ACTION defaultPadProperties
Definition: pcb_actions.h:421
static TOOL_ACTION importFootprint
Definition: pcb_actions.h:417
static TOOL_ACTION placeImportedGraphics
Definition: pcb_actions.h:191
static TOOL_ACTION drawArc
Definition: pcb_actions.h:174
static TOOL_ACTION graphicsOutlines
Display footprint graphics as outlines.
Definition: pcb_actions.h:438
static TOOL_ACTION drawCenterDimension
Definition: pcb_actions.h:179
static TOOL_ACTION footprintProperties
Definition: pcb_actions.h:420
static TOOL_ACTION flipBoard
Definition: pcb_actions.h:330
static TOOL_ACTION textOutlines
Display texts as lines.
Definition: pcb_actions.h:441
static TOOL_ACTION checkFootprint
Definition: pcb_actions.h:423
static TOOL_ACTION repairFootprint
Definition: pcb_actions.h:491
static TOOL_ACTION drawLine
Definition: pcb_actions.h:170
static TOOL_ACTION cleanupGraphics
Definition: pcb_actions.h:363
static TOOL_ACTION drawAlignedDimension
Definition: pcb_actions.h:178
The selection tool: currently supports:
TOOL_MANAGER * m_toolManager
Definition: tools_holder.h:170
Wrapper around a wxMenuBar object that prevents the accelerator table from being used.
Definition: wx_menubar.h:46
#define _(s)
void AddMenuLanguageList(ACTION_MENU *aMasterMenu, TOOL_INTERACTIVE *aControlTool)
Function AddMenuLanguageList creates a menu list for language choice, and add it as submenu to Master...
Macros and inline functions to create menus items in menubars or popup menus.
@ ID_FPEDIT_SAVE_PNG
Definition: pcbnew_id.h:98
@ ID_ADD_FOOTPRINT_TO_BOARD
Definition: pcbnew_id.h:116
@ ID_LOAD_FOOTPRINT_FROM_BOARD
Definition: pcbnew_id.h:117