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Bab 1

Mengenal KiCad

KiCad adalah perangkat lunak sumber-terbuka (open-source) untuk membuat diagram skematik elektronika dan desain papan
PCB (Printed Circuit Board). KiCad terdiri dari serangkaian perangkat lunak yang masing-masing berdiri sendiri:

Nama program Keterangan Ekstensi berkas
KiCad Manajer proyek *.pro
Eeschema Editor skematik dan komponen *.sch, *.lib, *.net
Pcbnew Editor papan sirkuit dan footprint *.kicad_pcb, *.kicad_mo
GerbView Penampil berkas Gerber dan drill *.g\*, *.drl, etc.
Bitmap2Component Konverter gambar bitmap menjadi

komponen atau footprint
*.lib, *.kicad_mod, *.
kicad_wks

PCB Calculator Kalkulator untuk komponen, lebar
jalur, spasi elektrikal, kode warna, dan
sebagainya

Tidak ada

Pl Editor Editor tata letak halaman *.kicad_wks

Catatan
Daftar ekstensi berkas di atas bukanlah daftar yang lengkap dan hanya menampilkan sebagian dari tipe berkas yang didukung
oleh KiCad. Daftar di atas berguna sebagai pemahaman dasar mengenai berkas mana yang digunakan oleh masing-masing
aplikasi KiCad.

KiCad sudah cukup matang untuk digunakan dalam pengembangan dan perawatan papan elektronika yang kompleks.

KiCad tidak memiliki batas ukuran papan PCB, dan dapat dengan mudah menangani hingga 32 lapisan (layer) tembaga, 14
lapisan teknis, dan 4 lapisan pelengkap. KiCad mampu menghasilkan semua berkas yang dibutuhkan untuk membangun papan
PCB, berkas Gerber untuk photo-plotter, berkas drilling, berkas lokasi komponen, dan berkas-berkas lainnya.

Sebagai aplikasi sumber-terbuka (berlisensi GPL), KiCad adalah peralatan yang ideal bagi pengguna yang berorientasi proyek
dalam pembuatan perangkat keras elektronika dengan citarasa open-source.

Anda bisa menemukan KiCad di Internet melalui tautan berikut:

http://www.kicad-pcb.org/

1.1 Mengunduh dan Menginstal KiCad

KiCad dapat berjalan di sistem operasi GNU/Linux, Apple macOS dan Windows. Anda bisa mendapatkan petunjuk dan tautan
untuk mengunduh KiCad versi terbaru di:

http://www.kicad-pcb.org/download/

http://www.kicad-pcb.org/
http://www.kicad-pcb.org/download/


Mari Mengenal KiCad 2 / 38

Penting
KiCad versi stabil dirilis secara periodik berdasarkan Kebijakan Rilis Stabil KiCad. Fitur-fitur baru akan ditambahkan
secara berkala ke dalam development branch. Jika Anda ingin memanfaatkan fitur-fitur baru, dan bersedia membantu
untuk melakukan pengujian fitur-fitur tersebut, silakan mengunduh paket nightly build untuk platform Anda. Paket
nightly build mungkin akan membawa kutu, misalnya kerusakan berkas, hasil pembuatan berkas Gerber yang tidak
sesuai, dsb., tetapi Tim Pengembang KiCad akan selalu berusaha untuk menjaga development branch agar tetap
dapat dipergunakan oleh pengguna KiCad selama pengembangan fitur baru.

1.1.1 GNU/Linux

Rilis stabil KiCad dapat ditemukan pada sebagian besar manajer paket distribusi GNU/Linux dengan nama kicad dan kicad-doc.
Jika distribusi yang Anda gunakan tidak menyediakan versi stabil yang terbaru, ikuti petunjuk instalasi versi unstable, dan pilih
serta instal versi stabil yang terbaru.

Di Ubuntu, cara termudah untuk menginstal KiCad versi unstable nightly build adalah melalui PPA dan Aptitude. Ketik perintah
berikut di Terminal:

sudo add-apt-repository ppa:js-reynaud/ppa-kicad
sudo aptitude update && sudo aptitude safe-upgrade
sudo aptitude install kicad kicad-doc-en

Di Debian, cara termudah untuk menginstal KiCad versi backports adalah sebagai berikut:

# Set up Debian Backports
echo -e "
# stretch-backports
deb http://ftp.us.debian.org/debian/ stretch-backports main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch-backports main contrib non-free
" | sudo tee -a /etc/apt/sources.list > /dev/null

# Run an Update & Install KiCad
sudo apt-get update
sudo apt-get install -t stretch-backports kicad

Di Fedora, cara termudah untuk menginstal KiCad versi unstable nightly build adalah melalui copr. Untuk menginstal KiCad
melalui copr, ketik perintah berikut:

sudo dnf copr enable @kicad/kicad
sudo dnf install kicad

Sebagai alternatif, Anda juga bisa mengunduh dan menginstal KiCad versi pre-compiled, atau mengunduh kode sumber secara
langsung, kemudian melakukan kompilasi dan menginstal KiCad.

1.1.2 Apple macOS

Versi stabil KiCad untuk macOS dapat diunduh di: http://downloads.kicad-pcb.org/osx/stable/

KiCad versi unstable nightly development build untuk macOS dapat diunduh di: http://downloads.kicad-pcb.org/osx/

1.1.3 Windows

Versi stabil KiCad untuk Windows dapat diunduh di: http://downloads.kicad-pcb.org/windows/stable/

KiCad versi nightly development build untuk Windows dapat diunduh di: http://downloads.kicad-pcb.org/windows/

http://ci.kicad-pcb.org/job/kicad-doxygen/ws/Documentation/doxygen/html/md_Documentation_development_stable-release-policy.html
http://downloads.kicad-pcb.org/osx/stable/
http://downloads.kicad-pcb.org/osx/
http://downloads.kicad-pcb.org/windows/stable/
http://downloads.kicad-pcb.org/windows/
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1.2 Dukungan

Jika Anda memiliki ide, komentar atau pertanyaan, atau jika Anda memerlukan bantuan:

• Kunjungi forum KiCad

• Bergabunglah dengan kanal IRC #kicad di Freenode

• Lihat tutorial KiCad

https://forum.kicad.info/
http://webchat.freenode.net/?channels=kicad
http://www.kicad-pcb.org/help/tutorials/
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Bab 2

Alur Kerja KiCad

KiCad memiliki beberapa kemiripan dengan perangkat lunak desain PCB lainnya, namun KiCad memiliki karakteristik tersendiri
dengan alur kerja yang unik, dimana komponen skematik dan footprint adalah dua hal yang terpisah. Kita dapat menentukan
footprint untuk komponen-komponen yang kita gunakan hanya jika kita sudah membuat sebuah skematik.

2.1 Gambaran Umum

Alur kerja KiCad terdiri dari dua langkah utama: menggambar skematik, kemudian mendesain tata letak papan PCB. Kedua tugas
tersebut memerlukan pustaka komponen skematik dan footprint PCB. KiCad menyediakan berbagai komponen dan footprint, dan
juga menyediakan peralatan untuk membuat sendiri komponen dan footprint yang baru.

Pada gambar di bawah ini, Anda akan melihat sebuah diagram alir yang menggambarkan alur kerja KiCad. Diagram ini men-
jelaskan langkah apa yang perlu diambil, dan bagaimana urutan langkahnya. Untuk memudahkan, disertakan pula gambar ikon
yang sesuai.
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Untuk informasi lebih lanjut mengenai cara pembuatan komponen, silakan baca Membuat Simbol Skematik di KiCad. Dan untuk
informasi mengenai bagaimana cara membuat footprint, lihat Membuat Footprint Komponen.

Quicklib dapat Anda gunakan untuk membuat berbagai komponen untuk pustaka KiCad secara cepat, dengan menggunakan
antarmuka berbasis web. Untuk informasi lebih lanjut mengenai Quicklib, lihat Membuat Komponen Skematik dengan Quicklib.

2.2 Anotasi Maju (Forward Annotation) dan Anotasi Mundur (Backward Annota-
tion)

Jika skematik telah selesai digambar, langkah berikutnya adalah mentransfer gambar tersebut menjadi PCB. Terkadang, kita perlu
menambahkan komponen baru, suatu komponen perlu diubah ke ukuran yang berbeda, net perlu diganti nama, dan sebagainya.
Hal ini dapat dilakukan dengan dua cara: Forward Annotation dan Backward Annotation.

Forward Annotation adalah sebuah proses untuk mengirimkan informasi skematik ke layout PCB yang sesuai. Ini adalah sebuah
fitur dasar yang sangat penting, karena Anda harus melakukannya setidaknya satu kali untuk mulai mengimpor skematik menjadi
PCB. Setelah itu, forward annotation akan mengirimkan perubahan skematik secara bertahap ke PCB. Penjelasan detail mengenai
Forward Annotation akan kita diskusikan pada bagian Forward Annotation.

Backward Annotation adalah proses mengirimkan perubahan layout PCB kembali ke gambar skematik yang sesuai. Dua penye-
bab umum sehingga kita perlu melakukan Backward Annotation adalah adanya pertukaran gate dan pertukaran pin. Pada situasi
tersebut, ada gate atau pin yang secara fungsi adalah sama, namun pada saat mendesain layout PCB, ada alasan tertentu yang
mengharuskan kita memilih gate atau pin yang benar-benar tepat. Ketika pilihan sudah ditetapkan pada layout PCB, perubahan
ini akan dikembalikan ke gambar skematik.

http://kicad.rohrbacher.net/quicklib.php
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Bab 3

Menggunakan KiCad

3.1 Tombol Pintas (Shortcut)

KiCad mempunyai dua jenis tombol pintas yang saling berhubungan tetapi berbeda satu sama lain, yaitu tombol akselerator dan
tombol cepat (hotkey). Keduanya digunakan untuk mempercepat pekerjaan kita di KiCad dengan menggunakan papan ketik
untuk mengubah perintah, alih-alih menggunakan tetikus.

3.1.1 Tombol Akselerator

Tombol akselerator memiliki efek yang sama seperti saat kita melakukan klik pada sebuah menu atau ikon di bilah alat: Anda
akan masuk ke sebuah mode perintah, tetapi perintah tersebut tidak akan dijalankan hingga Anda melakukan klik-kiri tetikus.
Gunakan tombol akselerator jika Anda ingin masuk ke dalam sebuah mode perintah namun tidak ingin perintah tersebut segera
dijalankan.

Tombol akselerator ditampilkan pada sisi kanan semua daftar menu:

3.1.2 Tombol Cepat (Hotkey)

Tombol cepat (hotkey) sama dengan tombol akselerator ditambah klik-kiri tetikus. Tombol cepat akan menjalankan suatu per-
intah secara langsung pada lokasi kursor Anda saat ini. Gunakan tombol cepat untuk mengubah perintah secara cepat tanpa
menginterupsi alur kerja Anda.

Untuk melihat daftar tombol cepat yang tersedia di KiCad, silakan buka menu Help→ List Hotkeys atau tekan tombol Ctrl+F1:
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Anda bisa mengedit tombol yang digunakan sebagai tombol cepat, serta melakukan impor atau ekspor, melalui menu Preferences
→ Hotkey Options.

Catatan
Pada dokumen ini, tombol cepat ditampilkan dengan tanda kurung seperti ini: [a]. Jika Anda melihat [a], tekan tombol "a" pada
papan ketik Anda.

3.1.3 Contoh

Perhatikan contoh sederhana untuk menambahkan sebuah wire (kawat) pada skematik.

Untuk menggunakan tombol akselerator, tekan "Shift + W" untuk menjalankan perintah "Add wire" (perhatikan bahwa kursor
akan berubah). Lalu, klik-kiri pada lokasi awal wire yang diinginkan untuk memulai menggambar wire.

Dengan tombol cepat, tekan [w] dan wire akan langsung muncul dari lokasi kursor saat ini.
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Bab 4

Menggambar Skematik Elektronika

Pada bagian ini, kita akan belajar bagaimana cara menggambar sebuah skematik elektronika dengan menggunakan KiCad.

4.1 Menggunakan Eeschema

1. Pada sistem operasi Windows, jalankan kicad.exe. Pada sistem operasi Linux, ketik kicad pada Terminal. Anda sekarang
berada di tampilan utama manajer proyek KiCad. Dari sini Anda memiliki akses ke delapan buah peralatan: Eeschema,
Schematic Library Editor, Pcbnew, PCB Footprint Editor, GerbView, Bitmap2Component, PCB Calculator dan Pl Editor.
Perhatikan diagram alur kerja untuk mengetahui bagaimana kedelapan peralatan utama tersebut digunakan.

2. Buatlah sebuah proyek baru. Buka menu File → New Project → New Project. Berilah nama berkas proyek Anda
tutorial1. Berkas proyek akan secara otomatis mendapatkan ekstensi ".pro". Tampilan kotak dialog pembuatan proyek
baru ini berbeda-beda tergantung sistem operasi yang digunakan, namun Anda akan menemukan sebuah pilihan untuk
membuat direktori baru. Berikan tanda centang pada pilihan tersebut, kecuali Anda sudah memiliki direktori yang akan
digunakan untuk menyimpan semua berkas proyek.

3. Mari kita mulai dengan membuat sebuah skematik. Bukalah editor skematik Eeschema . Eeschema berada di tombol
pertama dari kiri.

4. Klik pada ikon Page Settings pada bilah alat bagian atas. Aturlah ukuran kertas (A4, 8.5x11, dsb.) dan masukkan
judul Tutorial1 pada kotak Title. Anda juga bisa menambahkan informasi yang lebih lengkap jika diperlukan. Klik OK.
Informasi ini akan mengisi sudut kanan bawah lembar skematik. Gunakan roda tetikus untuk melakukan perbesaran
tampilan. Simpan keseluruhan skematik Anda melalui menu File→ Save

5. Sekarang kita akan meletakkan komponen pertama kita. Klik pada ikon Place Symbol pada bilah alat sebelah kanan.
Anda juga bisa menekan tombol cepat Add Symbol [a].
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6. Klik lembar skematik Anda. Jendela Choose Symbol akan muncul di layar. Kita akan meletakkan sebuah resistor. Carilah
komponen ini dengan mengetikkan R (dari Resistor) pada kotak Filter. Anda akan menemukan Resistor yang berada di
dalam grup Device. Device adalah nama pustaka di mana komponen tersebut berada, yang merupakan pustaka yang cukup
umum dan berguna.

7. Lakukan klik-ganda pada R. Jendela Choose Symbol akan tertutup. Letakkan komponen pada lembar skematik dengan
melakukan klik di lokasi yang Anda inginkan.

8. Klik pada ikon kaca pembesar untuk melakukan perbesaran tampilan komponen. Anda juga bisa menggunakan roda tetikus
untuk memperbesar atau memperkecil tampilan. Tekan roda tetikus (atau tombol tengah tetikus) untuk menggeser lembar
skematik secara horisontal maupun vertikal.

9. Cobalah untuk meletakkan kursor di atas komponen R dan tekan [r]. Perintah tersebut akan memutar komponen. Anda
tidak perlu melakukan klik pada komponen yang akan diputar.

Catatan
Terkadang, jika kursor juga berada di atas sesuatu yang lain, akan muncul sebuah menu. Anda akan sering melihat
menu Clarify Selection di KiCad; yang memungkinkan kita bekerja pada obyek yang berada di atas yang lain. Jika menu
ini muncul, beritahu KiCad bahwa Anda ingin melakukan aksi pada Symbol . . . R. . . .

10. Klik-kanan pada bagian tengah komponen dan pilih Properties→ Edit Value. Anda bisa mendapatkan hasil yang sama
dengan meletakkan kursor di atas komponen dan menekan [v]. Alternatif lainnya, gunakan [e] untuk menampilkan jendela
Properties yang lebih bersifat umum. Perhatikan bagaimana menu klik-kanan berikut ini menampilkan tombol cepat untuk
semua perintah yang tersedia.
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11. Jendela Edit Value Field akan muncul. Ganti nilai saat ini R dengan 1 k. Klik OK.

Catatan
Jangan mengubah nilai Field Reference (R?) karena nilai ini nanti akan berubah secara otomatis. Nilai di atas resistor
sekarang akan berubah menjadi 1 k.

12. Untuk meletakkan resistor berikutnya, klik di mana Anda ingin meletakkannya. Jendela pemilihan simbol akan muncul
kembali.

13. Resistor yang tadi Anda pilih sekarang ada di dalam daftar histori, dan ditampilkan sebagai R. Klik OK dan letakkan
komponen tersebut.
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14. Jika Anda melakukan kesalahan dan ingin menghapus sebuah komponen, klik-kanan pada komponen tersebut dan klik
Delete. Perintah ini akan menghapus komponen dari skematik. Alternatif lainnya, Anda bisa meletakkan kursor di atas
komponen yang ingin dihapus, dan tekan [Delete].

15. Anda juga bisa menyalin sebuah komponen yang sudah ada di lembar skematik Anda, dengan cara meletakkan kursor di
atas komponen dan menekan [c]. Klik di mana Anda ingin meletakkan salinan komponen tersebut.

16. Klik kanan pada resistor kedua. Pilih Drag. Atur ulang posisi komponen dan klik-kiri untuk meletakkannya. Fungsi yang
sama dapat dilakukan dengan meletakkan kursor di atas komponen dan menekan [g]. Tombol [r] akan memutar komponen,
serta [x] dan [y] akan membalik komponen berdasarkan sumbu x atau y.

Catatan
Klik-kanan → Move atau [m] juga dapat Anda gunakan untuk memindahkan apapun, tetapi akan lebih baik untuk
digunakan hanya pada label komponen dan komponen yang belum terhubung. Kita akan akan membahasnya nanti.

17. Edit resistor kedua dengan meletakkan kursor di atasnya dan menekan [v]. Ganti nilai R dengan 100. Anda bisa memba-
talkannya dengan menekan Ctrl+Z.

18. Ubah ukuran grid. Anda mungkin sudah memperhatikan bahwa pada lembar skematik, semua komponen akan menempel
pada grid yang berukuran besar. Anda bisa dengan mudah mengubah ukuran grid dengan Klik-kanan→ Grid. Secara
umum, lembar skematik direkomendasikan untuk menggunakan grid dengan ukuran 50.0 mils.

19. Kita akan menambahkan sebuah komponen dari pustaka yang mungkin belum dikonfigurasi pada proyek default. Pilih
menu Preferences→Manage Symbol Libraries. Pada jendela Symbol Libraries Anda akan menemukan dua buah tab:
Global Libraries dan Project Specific Libraries. Setiap tab memiliki sebuah berkas sym-lib-table. Agar sebuah pustaka
(berkas .lib) tersedia untuk digunakan, pustaka tersebut harus ada di salah satu berkas sym-lib-table. Jika Anda memiliki
sebuah berkas pustaka tetapi belum tersedia, Anda bisa menambahkan pustaka tersebut ke salah satu berkas sym-lib-table.
Untuk latihan, kita akan menambahkan sebuah pustaka yang sebenarnya telah tersedia.

20. Pilih tabel Project Specific Libraries. Klik pada tombol Browse Libraries di bawah tabel. Anda harus menemukan
di mana pustaka resmi KiCad terinstal di komputer Anda. Carilah direktori library yang berisi ratusan berkas .
dcm dan .lib. Biasanya, direktori ini berada di C:\Program Files (x86)\KiCad\share\ (Windows) dan
/usr/share/kicad/library/ (Linux). Setelah Anda menemukan direktori tersebut, pilih dan tambahkan pustaka
MCU_Microchip_PIC12.lib. Pustaka tersebut akan ditambahkan ke baris paling bawah pada tabel. Sekarang, klik nama
pustaka tersebut dan ubah menjadi microchip_pic12mcu. Tutup jendela Symbol Libraries dengan klik OK.
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21. Ulangi langkah penambahan komponen, namun kali ini kita tidak memilih pustaka Device. Pilihlah pustaka micro-
chip_pic12mcu dan ambil komponen PIC12C508A-ISN.

22. Letakkan kursor di atas komponen mikrokontroler. Perhatikan bahwa [x] dan [y] akan membalik komponen tersebut.
Kembalikan komponen tersebut ke orientasi awal.

23. Ulangi langkah penambahan komponen, kali ini pilih pustaka Device dan ambil komponen LED.

24. Atur semua komponen pada lembar skematik Anda seperti di bawah ini.

25. Sekarang kita akan membuat komponen skematik MYCONN3 untuk konektor 3-pin. Anda bisa langsung melompat ke
bagian yang berjudul Membuat Simbol Skematik di KiCad untuk belajar membuat komponen ini dari awal, kemudian
kembali ke bagian ini untuk melanjutkan latihan kita.

26. Sekarang Anda bisa meletakkan komponen yang baru saja Anda buat. Tekan [a] dan ambil komponen MYCONN3 dari
pustaka myLib.

27. Penunjuk nama komponen J? akan muncul di bawah label MYCONN3. Jika Anda ingin mengubah posisinya, klik kanan
pada J? dan klik Move Field (atau tekan [m]). Anda mungkin perlu memperbesar tampilan sebelum/sambil menjalankan
perintah ini. Gambar di bawah menunjukkan pemindahan posisi J?. Label dapat dipindahkan posisinya sesuai keinginan
Anda.

28. Sekarang waktunya meletakkan simbol power dan ground. Klik pada tombol Place power port pada bilah alat
sebelah kanan. Anda juga bisa menekan [p]. Pada jendela pemilihan komponen, gulir ke bawah dan pilih VCC dari
pustaka power. Klik OK.
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29. Klik di atas pin resistor 1 k untuk meletakkan part VCC. Klik pada area di atas VDD pada mikrokontroler. Pada grup
History pada kotak dialog Component Selection, pilih VCC dan letakkan di sebelah pin VDD. Ulangi langkah penambahan
komponen sekali lagi dan letakkan komponen VCC di atas pin VCC pada MYCONN3. Pindahkan referensi dan nilai jika
diperlukan.

30. Ulangi langkah penambahan pin, namun kali ini pilih GND. Letakkan GND di bawah pin GND MYCONN3. Tambahkan
juga simbol GND di sebelah kiri pin VSS mikrokontroler. Lembar skematik Anda akan menjadi seperti berikut ini:

31. Selanjutnya, kita akan menghubungkan semua komponen dengan wire. Klik pada ikon Place wire pada bilah alat
sebelah kanan.

Catatan
Pastikan Anda tidak memilih Place bus, yang tombolnya berada tepat di bawah tombol Place wire, namun memiliki garis
yang lebih tebal. Bagian Koneksi Bus di KiCad akan membahas mengenai penggunaan bus.

32. Klik pada lingkaran kecil di ujung pin 7 mikrokontroler, dan klik pada lingkaran kecil di ujung pin 1 LED. Pada saat
menggambar wire, klik sekali untuk berbelok. Anda juga bisa memperbesar tampilan sambil melakukan penyambungan
koneksi antar komponen.

Catatan
Jika Anda ingin mengubah posisi komponen yang sudah tersambung, gunakan [g] (geser/grab) dan jangan menggunak-
an [m] (pindah/move). Menggeser akan menjaga komponen tetap tersambung dengan wire. Ulangi langkah 24 jika Anda
lupa bagaimana cara memindahkan komponen.
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33. Ulangi proses ini dan hubungkan semua komponen lainnya dengan wire seperti gambar di bawah ini. Untuk mengakhiri
wire, lakukan klik-ganda. Saat menghubungkan simbol VCC dan GND, wire harus menyentuh bagian bawah simbol VCC
dan bagian atas simbol GND. Lihat gambar berikut.

34. Sekarang kita mencoba cara lain untuk membuat sambungan dengan menggunakan label. Pilih alat pemberi label dengan

klik ikon Place net label pada bilah alat sebelah kanan. Anda juga bisa menekan [l].

35. Klik pada tengah wire yang terhubung ke pin 6 mikrokontroler. Beri nama label INPUT. Label ini masih merupakan item
yang berdiri sendiri yang bisa dipindah, diputar, maupun dihapus. Jangkar berupa kotak kecil pada label harus tepat berada
pada wire atau pin untuk label tersebut.
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36. Lakukan langkah yang sama pada wire di sebelah kanan resistor 100 ohm. Berikan nama label INPUT pada wire tersebut.
Kedua label tersebut, karena memiliki nama yang sama, akan membuat sambungan yang tidak terlihat antara pin 6 PIC
dan resistor 100 ohm. Teknik ini akan berguna untuk menghubungkan wire pada desain yang kompleks, dimana penam-
bahan garis wire akan membuat skematik menjadi terlihat berantakan. Untuk meletakkan sebuah label, Anda tidak harus
menggambar wire, Anda juga bisa memberikan label pada sebuah pin.

37. Label juga bisa digunakan untuk sekadar memberi nama pada wire sebagai keterangan untuk wire tersebut. Letakkan
sebuah label pada pin 7 PIC. Masukkan nama uCtoLED. Berikan nama LEDtoR untuk wire yang menghubungkan resistor
dan LED, dan berikan nama INPUTtoR untuk wire yang menghubungkan MYCONN3 dan resistor.

38. Anda tidak perlu memberikan label pada jalur VCC dan GND karena label pada jalur tersebut sudah terwakili oleh obyek
dimana jalur tersebut terhubung.

39. Di bawah ini, Anda bisa melihat bagaimana seharusnya hasil akhir proyek kita.

40. Mari kita lanjutkan dengan wire yang belum terhubung. Setiap pin atau wire yang tidak terhubung akan menghasilkan per-
ingatan ketika dilakukan pemeriksaan oleh KiCad. Untuk menghindari peringatan tersebut, Anda bisa memberi informasi
kepada program bahwa Anda sengaja membiarkan wire tidak terhubung, atau menandai secara manual setiap pin atau wire
yang belum terhubung.

41. Klik pada ikon Place no connection flag pada bilah alat sebelah kanan. Klik pada pin 2, 3, 4, dan 5. Akan muncul
tanda X yang menunjukkan bahwa tidak adanya koneksi wire adalah disengaja.



Mari Mengenal KiCad 17 / 38

42. Beberapa komponen memiliki pin power yang tidak terlihat. Anda dapat memunculkan pin tersebut dengan klik ikon Show

hidden pins pada bilah alat sebelah kiri. Pin power yang tersembunyi akan terhubung secara otomatis jika Anda
menggunakan penamaan VCC dan GND. Secara umum, Anda sebaiknya tidak membuat pin power yang tersembunyi.

43. Sekarang kita perlu menambahkan sebuah Power Flag yang akan memberitahu KiCad bahwa ada suatu catu daya untuk
rangkaian yang kita buat. Tekan [a] dan cari PWR_FLAG yang berada di pustaka power. Letakkan dua buah PWR_FLAG
pada skematik. Hubungkan ke pin GND dan VCC seperti ditunjukkan pada gambar di bawah ini.

Catatan
Langkah di atas akan menghindarkan kita dari pesan peringatan pada saat pemeriksaan skematik: Pin connected to
some other pins but no pin to drive it.

44. Terkadang kita perlu menambahkan komentar di sana-sini. Untuk menambahkan komentar pada skematik, gunakan ikon

Place text pada bilah alat sebelah kanan.

45. Semua komponen perlu memiliki penamaan yang unik. Saat ini beberapa komponen kita masih memiliki nama R? atau

J?. Pemberian nama dapat dilakukan secara otomatis dengan klik ikon Annotate schematic symbols pada bilah alat
bagian atas.

46. Pada jendela Annotate Schematic, pilih Use the entire schematic dan klik pada tombol Annotate. Klik Close. Perhatikan
bahwa semua tanda ? telah berganti menjadi angka-angka. Sekarang setiap komponen telah memiliki penamaan yang
unik. Pada contoh kita, setiap komponen telah memiliki nama R1, R2, U1, D1 dan J1.

47. Sekarang kita akan memeriksa apakah ada kesalahan pada skematik kita. Klik pada ikon Perform electrical rules check

pada bilah alat bagian atas. Klik tombol Run. Akan tampil sebuah laporan yang menginformasikan setiap kesalahan
atau peringatan seperti wire yang belum terhubung. Anda harus memiliki 0 Error dan 0 Warning. Jika terdapat pesan
kesalahan atau peringatan, sebuah tanda panah kecil berwarna hijau akan tampil di skematik pada posisi di mana kesalahan
atau peringatan tersebut berada. Berilah tanda centang pada Create ERC file report dan tekan tombol Run sekali lagi untuk
mendapatkan informasi yang lebih lengkap mengenai kesalahan tersebut.

Catatan
Jika Anda menemukan peringatan "No default editor found, you must choose it", cobalah mengubah pengaturan path ke
c:\windows\notepad.exe (Windows) atau /usr/bin/gedit (Linux).

48. Kita sudah menyelesaikan pembuatan skematik. Sekarang kita bisa membuat berkas Netlist dimana kita akan menambahk-

an footprint untuk tiap-tiap komponen. Klik pada ikon Generate netlist pada bilah alat bagian atas. Klik pada tombol
Generate Netlist dan simpan dengan nama berkas default.

Catatan
Pada versi KiCad sebelumnya, berkas Netlist diperlukan. Pada versi terbaru Anda bisa mengabaikannya, dan sebagai
gantinya, gunakan Tools→ Update PCB from Schematic. Namun sebelumnya Anda perlu menentukan footprint yang
akan digunakan oleh simbol.
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49. Setelah membuat berkas Netlist, klik ikon Run Cvpcb pada bilah alat bagian atas. Abaikan dan klik OK jika muncul
pesan kesalahan mengenai adanya berkas yang tidak tersedia.

Catatan
Ada beberapa cara lain untuk menambahkan footprint ke simbol.

• Klik kanan pada simbol → Properties → Edit Footprint Klik-ganda pada simbol, atau klik kanan pada simbol →
Properties→ Edit Properties→ Footprint

• Tools→ Edit Symbol Fields Centang opsi Show footprint previews in symbol chooser di bagian pengaturan Eesche-
ma dan pilih footprint saat Anda memilih sebuah simbol baru

50. Cvpcb akan menghubungkan semua komponen yang ada di skematik Anda dengan footprint pada pustaka KiCad. Kolom
di bagian tengah menunjukkan semua komponen yang digunakan di skematik. Pilih D1. Pada kolom di sebelah kanan,
terdapat semua footprint yang tersedia. Gulir ke bawah dan klik-ganda LED_THT:LED-D5.0mm.

51. Bisa jadi kolom di sebelah kanan hanya menampilkan beberapa pilihan footprint saja. Hal ini karena KiCad mencoba

untuk memberikan saran pemilihan footprint yang sesuai dengan komponen yang Anda gunakan. Klik pada ikon ,

dan untuk mengaktifkan dan menonaktifkan filter tersebut.

52. Untuk U1 pilih footprint Package_DIP:DIP-8_W7.62mm. Untuk J1 pilih footprint Connectors:Banana_Jack_3Pin. Untuk
R1 dan R2 pilih footprint Resistor_THT:R_Axial_DIN0207_L6.3mm_D2.5mm_P2.54mm_Vertical.

53. Jika Anda ingin mengetahui bentuk dari footprint yang Anda pilih, Anda bisa klik ikon View selected footprint untuk
melihat tampilan footprint yang dipilih.

54. Anda telah selesai. Anda bisa menyimpan skematik dengan klik File→ Save Schematic atau melalui tombol Apply, Save
Schematic & Continue.

55. Anda bisa menutup Cvpcb dan kembali ke editor skematik Eeschema. Jika Anda tidak menyimpannya di Cvpcb, simpanlah
sekarang dengan klik File→ Save. Buatlah netlist sekali lagi. Berkas netlist Anda sekarang telah diperbarui dengan semua
footprint. Ingat bahwa jika Anda tidak menemukan footprint yang Anda perlukan untuk komponen yang digunakan, Anda
harus membuat footprint Anda sendiri. Hal ini akan dijelaskan pada bagian lain dokumen ini.

Catatan
Sekarang setiap simbol telah memiliki sebuah footprint. Sebagai pengganti Netlist dan dua langkah berikutnya, Anda
bisa menggunakan Tools → Update PCB from Schematic. Pcbnew akan terbuka dengan kotak dialog Update PCB
from Schematic. Klik Update PCB. Lalu Anda bisa mengikuti instruksi pada bagian Pcbnew di tutorial ini.

56. Berpindahlah ke manajer proyek KiCad. Anda bisa melihat berkas netlist pada daftar berkas.

57. Berkas netlist menjelaskan semua komponen dan koneksi pinnya. Berkas netlist sebenarnya adalah berkas teks yang dapat
dengan mudah dilihat, diedit, atau dimanipulasi dengan bantuan skrip.

Catatan
Berkas pustaka (*.lib) juga sebenarnya merupakan berkas teks yang mudah untuk diedit dan dimanipulasi dengan ban-
tuan skrip.

58. Untuk membuat daftar komponen (Bill Of Materials / BOM), bukalah editor skematik Eeschema dan klik pada ikon Ge-

nerate bill of materials pada bilah alat bagian atas. Secara default, tidak ada plugin yang aktif. Tambahkan plugin
dengan klik tombol Add Plugin. Pilih berkas *.xsl yang akan Anda gunakan. Pada latihan ini, kita pilih bom2csv.xsl.
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Catatan
Linux:
Jika di sistem Anda tidak tersedia xsltproc, Anda bisa mengunduh dan menginstalnya dengan perintah:

sudo apt-get install xsltproc

untuk distro turunan Debian seperti Ubuntu, atau

sudo yum install xsltproc

untuk distro turunan RedHat. Jika Anda menggunakan distro Linux lain, gunakan manajer paket distro Anda untuk
menginstal paket xsltproc.
Berkas-berkas xsl berada di : /usr/lib/kicad/plugins/.
Apple OS X:
Jika di sistem Anda tidak tersedia xsltproc, Anda bisa menginstal peralatan Apple Xcode dari situs Apple yang menyer-
takan xsltproc, atau unduh dan instal dengan perintah:

brew install libxslt

Berkas-berkas xsl berada di: /Library/Application Support/kicad/plugins/.
Windows:
xsltproc.exe dan berkas-berkas xsl terdapat pada <KiCad install directory>\bin dan <KiCad install dire-
ctory>\bin\scripting\plugins.
Semua platform:
Anda bisa mendapatkan bom2csv.xsl versi terbaru melalui:
https://gitlab.com/kicad/code/kicad/raw/master/eeschema/plugins/xsl_scripts/bom2csv.xsl

KiCad akan membuat perintah secara otomatis, sebagai contoh:

xsltproc -o "%O" "/home/<user>/kicad/eeschema/plugins/bom2csv.xsl" "%I"

Anda mungkin ingin menambahkan ekstensi, maka ubahlah perintah ini menjadi:

xsltproc -o "%O.csv" "/home/<user>/kicad/eeschema/plugins/bom2csv.xsl" "%I"

Tekan tombol Help untuk informasi lebih lanjut.

59. Sekarang tekan Generate. Hasilnya berupa berkas (dengan nama yang sama dengan proyek Anda) yang disimpan di dalam
folder proyek Anda. Buka berkas *.csv dengan LibreOffice Calc atau Excel. Akan tampil sebuah jendela impor, tekan OK.

Anda sekarang siap untuk melanjutkan langkah ke pembuatan tata letak PCB, yang akan kita bahas pada bagian berikutnya.
Namun sebelum kita lanjutkan, marilah kita lihat bagaimana cara menghubungkan pin-pin komponen menggunakan jalur bus.

4.2 Koneksi Bus di KiCad

Terkadang Anda mungkin ingin menghubungkan pin-pin sekuensial pada komponen A dengan pin-pin sekuensial pada komponen
B. Pada kasus ini, Anda memiliki dua opsi: menggunakan metode pelabelan seperti yang sudah kita praktekkan sebelumnya, atau
menggunakan koneksi bus. Mari kita lihat bagaimana cara melakukannya.

1. Misalkan Anda memiliki tiga buah konektor 4-pin yang ingin Anda hubungkan secara bersama-sama dari pin ke pin.
Gunakan pelabelan (tekan [l]) untuk memberi label pin 4 dari part P4. Beri nama label a1. Sekarang tekan [Insert] agar
label ini ditambahkan secara otomatis ke pin di bawah pin 4 (PIN 3). Perhatikan bahwa label akan secara otomatis diberi
nama a2.

2. Tekan [Insert] dua kali lagi. Tombol ini digunakan untuk perintah Repeat last item (ulangi langkah terakhir), dan ini adalah
perintah yang sangat berguna yang akan memudahkan pekerjaan Anda.

https://gitlab.com/kicad/code/kicad/raw/master/eeschema/plugins/xsl_scripts/bom2csv.xsl
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3. Ulangi langkah pelabelan yang sama pada dua konektor yang lain, yaitu CONN_2 dan CONN_3, dan Anda telah selesai.
Jika Anda melanjutkan dan membuat PCB, Anda akan melihat bahwa ketiga konektor saling terhubung satu sama lain.
Gambar 2 menampilkan hasil dari apa yang kita bahas ini. Agar tampak lebih menarik, kita juga bisa menambahkan

serangkaian Place wire to bus entry menggunakan ikon dan jalur bus menggunakan ikon , seperti ditunjukkan
pada Gambar 3. Namun perlu diingat bahwa hal ini tidak akan memberi efek apapun pada PCB.

4. Anda juga perlu tahu bahwa wire pendek yang terhubung ke pin-pin pada Gambar 2 bukanlah suatu keharusan. Pada
kenyataannya, kita juga bisa melabeli pin-pin tersebut secara langsung, tanpa harus menggunakan wire.

5. Mari kita menuju langkah selanjutnya. Misalkan Anda memiliki konektor keempat dengan nama CONN_4, dan entah
mengapa, pelabelannya sedikit berbeda dengan konektor lainnya (b1, b2, b3, b4). Sekarang kita ingin menghubungkan
dari pin ke pin antara Bus a dengan Bus b. Kita ingin melakukannya tanpa menggunakan pelabelan pin (walaupun hal itu
dimungkinkan untuk dilakukan), namun kita akan menggunakan pelabelan pada jalur bus, dengan satu label per bus.

6. Hubungkan dan beri label CONN_4 menggunakan metode pelabelan seperti yang dijelaskan sebelumnya. Beri nama

pin b1, b2, b3, dan b4. Hubungkan pin ke serangkaian Wire to bus entry menggunakan ikon dan ke jalur bus

menggunakan ikon . Lihat Gambar 4.

7. Berikan label (tekan [l]) pada bus CONN_4 dan namai dengan b[1..4].

8. Berikan label (tekan [l]) pada bus sebelumnya dan namai dengan a[1..4].

9. Apa yang bisa kita lakukan sekarang adalah menghubungkan bus a[1..4] dengan bus b[1..4] menggunakan jalur bus dengan

tombol .

10. Dengan menghubungkan kedua bus tersebut, pin a1 akan secara otomatis terhubung ke pin b1, a2 akan terhubung ke b2
dan seterusnya. Gambar 4 menunjukkan tampilan hasil akhirnya.

Catatan
Opsi Repeat last item yang dapat diakses melalui [Insert] dapat digunakan untuk mengulangi penambahan item. Sebagai
contoh, wire pendek yang terhubung pada semua pin di Gambar 2, Gambar 3 dan Gambar 4, ditambahkan dengan
menggunakan opsi ini.

11. Opsi Repeat last item yang dapat diakses melalui [Insert] juga dapat digunakan untuk meletakkan beberapa rangkaian Wire

to bus entry dengan menggunakan ikon .
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Bab 5

Menggambar PCB

Sekarang tiba waktunya kita gunakan berkas Netlist untuk membuat tata letak PCB. Alat yang kita gunakan adalah Pcbnew.

Catatan
Jika Anda menggunakan Update PCB from Schematic dari Eeschema, maka Anda tidak memerlukan netlist dan langkah 5.
Sekarang Anda bisa meletakkan footprint ke papan PCB sebagaimana langkah 6 dan 7, lalu masukkan informasi lembar kerja
dan aturan desain dengan langkah 2. . . 4.

5.1 Menggunakan Pcbnew

1. Dari halaman manajer proyek KiCad, klik pada ikon Pcb layout editor . Anda juga bisa menggunakan tombol pada
bilah alat bagian atas dari Eeschema. Jendela Pcbnew akan terbuka. Jika Anda mendapatkan pesan kesalahan bahwa
berkas *.kicad_pcb tidak ditemukan dan meminta Anda untuk membuatnya, klik Yes.

2. Mulailah dengan memasukkan beberapa informasi skematik. Klik pada ikon Page settings pada bilah alat bagian
atas. Atur ukuran kertas pada pilihan Paper size (A4, 8.5x11, dsb.) dan pada kotak Title, masukkan judul Tutorial1.

3. Sebaiknya kita mulai dengan mengatur clearance (jarak minimum antar item) dan minimum track width (lebar jalur
minimum) sesuai dengan yang dibutuhkan oleh manufaktur PCB yang akan Anda gunakan. Secara umum Anda dapat
mengatur jarak minimum 0.25 dan lebar jalur minimum 0.25. Klik menu Setup → Design Rules. Klik tab Net Classes
Editor jika tab tersebut belum tampil. Ubah nilai Clearance pada bagian atas jendela menjadi 0.25 dan nilai Track Width
menjadi 0.25 seperti ditunjukkan pada gambar di bawah ini. Satuan untuk ukuran di sini adalah mm.

4. Klik pada tab Global Design Rules dan atur Minimum track width menjadi 0.25. Klik tombol OK untuk menyimpan
perubahan Anda, dan tutup jendela Design Rules Editor.
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5. Sekarang kita akan mengimpor berkas Netlist yang sudah dibuat. Klik pada ikon Read netlist pada bilah alat bagian
atas. Berkas Netlist tutorial1.net harus dipilih pada kotak Netlist file jika berkas tersebut dibuat dari Eeschema. Klik pada
Read Current Netlist, lalu klik tombol Close.

6. Sekarang semua komponen akan tampak. Komponen-komponen tersebut akan mengikuti kursor.

7. Pindahkan semua komponen ke tengah lembar kerja. Jika diperlukan, Anda bisa memperbesar atau memperkecil tampilan
sembari memindahkan komponen. Klik untuk meletakkan komponen.

8. Semua komponen terhubung melalui sekelompok wire tipis yang disebut ratsnest. Pastikan bahwa tombol Show/hide board

ratsnest ditekan. Dengan cara ini, Anda bisa melihat ratsnest menghubungkan semua komponen.

9. Anda bisa memindahkan setiap komponen dengan meletakkan kursor di atas komponen tersebut dan tekan [g]. Klik di
mana Anda ingin meletakkannya. Anda juga bisa memilih sebuah komponen dengan klik dan kemudian menggesernya.
Tekan [r] untuk memutar komponen. Pindahkan semua komponen sehingga hanya ada sedikit wire yang bersilangan.

10. Perhatikan bahwa pin pada resistor 100 ohm terhubung dengan pin 6 pada komponen PIC. Ini adalah hasil dari metode
pelabelan yang digunakan untuk menghubungkan pin. Terkadang penggunaan label lebih disukai daripada wire karena
pelabelan akan membuat skematik menjadi lebih rapi.

11. Sekarang kita akan menetapkan sisi tepi dari PCB. Pilih lapisan Edge.Cuts dari menu drop-down pada bilah alat bagian

atas. Klik pada ikon Add graphic lines pada bilah alat sebelah kanan. Tandai dengan mengitari sisi-sisi tepi papan
PCB, klik pada setiap sudutnya, dan ingat untuk menambahkan sedikit celah antara sisi tepi hijau dengan sisi tepi PCB.

12. Selanjutnya, hubungkan semua wire kecuali GND, karena kita akan menghubungkan semua koneksi GND secara bersa-
maan dengan menggunaan ground plane pada lapisan tembaga bagian bawah (disebut B.Cu) pada papan PCB.

13. Sekarang kita harus memilih lapisan tembaga yang akan kita kerjakan. Pilih F.Cu (PgUp) pada menu drop-down pada
bilah alat bagian atas. Lapisan ini adalah lapisan tembaga bagian atas.
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14. Jika Anda memutuskan, misalnya, untuk menggunakan PCB 4 lapis, buka Design Rules→ Layers Setup dan ubah nilai
Copper Layers menjadi 4. Pada tabel Layers Anda bisa menamai setiap lapisan dan menentukan apa kegunaan dari lapisan
tersebut. Ingat bahwa sudah disediakan beberapa preset yang berguna, yang dapat dipilih melalui menu Preset Layer
Groupings.

15. Klik pada ikon Route tracks pada bilah alat sebelah kanan. Klik pada pin 1 komponen J1 dan tarik sebuah jalur ke
pad R2. Klik-ganda untuk mengakhiri jalur tersebut. Lebar jalur ini secara default adalah 0.250 mm. Anda bisa mengubah
lebar jalur melalui menu drop-down pada bilah alat bagian atas. Secara default, Anda hanya memiliki satu pilihan ukuran
lebar jalur yang disediakan.

16. Jika Anda ingin menambahkan pilihan ukuran lebar jalur, buka Setup→ Design Rules→ tab Global Design Rules dan
pada bagian bawah kanan jendela ini, tambahkan pilihan ukuran lebar jalur yang Anda inginkan. Anda kemudian bisa
memilih ukuran lebar jalur ini dari menu drop-down saat membuat layout PCB. Lihat contoh di bawah ini (dalam satuan
inci).
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17. Sebagai alternatif, Anda bisa menambahkan Net Class dimana Anda bisa menentukan sejumlah opsi. Buka Setup →
Design Rules→ Net Classes Editor dan tambahkan sebuah class baru dengan nama power. Ubah lebar jalur dari 8 mil
(0.0080) ke 24 mil (0.0240). Lalu, tambahkan semuanya kecuali ground ke class power (pilih default di sebelah kiri dan
power di sebelah kanan, dan klik tombol panah).

18. Jika Anda ingin mengubah ukuran grid, lakukan Klik-kanan→Grid. Pastikan memilih ukuran grid yang sesuai sebelum
atau sesudah mengatur tata letak komponen dan menghubungkannya satu sama lain dengan menggunakan jalur.

19. Ulangi proses ini sampai semua wire tersambung, kecuali pin 3 komponen J1. Papan PCB Anda akan terlihat seperti
contoh di bawah ini.

20. Sekarang mari kita buat jalur pada lapisan tembaga sisi yang lain dari PCB. Pilih B.Cu pada menu drop-down di bilah alat

bagian atas. Klik pada ikon Route tracks . Gambarlah sebuah jalur antara pin 3 komponen J1 dan pin 8 komponen U1.
Hal ini sebenarnya tidak diperlukan karena kita bisa melakukannya dengan ground plane. Perhatikan bagaimana warna
jalur yang akan kita gambar telah berubah.

21. Membuat jalur dari pin A ke pin B dengan berpindah lapisan. Dimungkinkan untuk berpindah ke lapisan tembaga
yang lain saat Anda membuat jalur, melalui perantaraan via. Saat membuat jalur pada lapisan tembaga bagian atas, klik
kanan dan pilih Place Via atau tekan [v]. Anda akan berpindah ke lapisan tembaga bagian bawah di mana Anda bisa
menyelesaikan jalur yang sedang dibuat.
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22. Apabila Anda ingin memeriksa suatu jalur atau sambungan, klik pada ikon Highlight net icon pada bilah alat sebelah
kanan. Klik pada pin 3 komponen J1. Jalur dan semua pad yang terhubung ke pin tersebut akan disorot.

23. Sekarang kita akan membuat sebuah ground plane yang akan terhubung ke semua pin GND. Klik pada ikon Add filled

zones pada bilah alat sebelah kanan. Kita akan membuat sebuah persegi yang melingkupi keseluruhan papan PCB
kita, maka klik di lokasi salah satu sudut yang Anda inginkan. Pada kotak dialog yang muncul, atur Default pad connection
ke Thermal relief dan Outline slope ke H,V and 45 deg only dan klik OK.

24. Tandai dengan mengitari garis luar papan PCB dengan klik pada setiap sudut secara melingkar. Selesaikan persegi yang
dibuat dengan klik lagi pada sudut yang pertama kali dibuat. Klik-kanan di dalam area persegi yang telah Anda buat, dan
klik Zones→ Fill or Refill All Zones. Papan PCB kita akan terisi dengan warna hijau seperti gambar berikut:

25. Jalankan Design Rule Check dengan klik ikon Perform design rules check pada bilah alat bagian atas. Klik Start
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DRC. Pastikan tidak ada pesan kesalahan yang muncul. Klik pada List Unconnected. Pastikan tidak ada jalur yang belum
terhubung. Klik OK untuk menutup kotak dialog DRC.

26. Simpan berkas Anda dengan klik File→ Save. Untuk melihat hasil akhir PCB Anda dalam bentuk 3 dimensi, klik View
→ 3D Viewer.

27. Seret kursor untuk memutar PCB.

28. Desain papan PCB Anda telah selesai. Untuk mengirimkannya ke manufaktur, Anda perlu membuat berkas Gerber.

5.2 Membuat Berkas Gerber

Setelah PCB Anda selesai, Anda bisa membuat berkas Gerber untuk tiap lapisan dan mengirimkannya ke manufaktur PCB yang
akan memproduksi papan PCB Anda.

1. Dari KiCad, buka Pcbnew.

2. Klik pada File → Plot. Pilih Gerber pada Plot format dan pilih folder di mana Anda akan menyimpan seluruh berkas
Gerber tersebut. Lanjutkan dengan klik pada tombol Plot.

3. Untuk membuat berkas drill, dari Pcbnew bukalah File→ Plot. Gunakan pengaturan default.

4. Berikut adalah lapisan yang harus Anda pilih untuk membuat PCB 2-lapis secara umum:

Lapisan Nama Lapisan KiCad Eksetensi Default Gerber "Use Protel filename
extensions" aktif

Lapisan Bawah B.Cu .GBR .GBL
Lapisan Atas F.Cu .GBR .GTL
Overlay Atas F.SilkS .GBR .GTO
Solder Resist Bawah B.Mask .GBR .GBS
Solder Resist Atas F.Mask .GBR .GTS
Sisi tepi PCB Edge.Cuts .GBR .GM1
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5.3 Menggunakan GerbView

1. Untuk melihat semua berkas Gerber Anda, buka manajer proyek KiCad dan klik pada ikon GerbView. Pada menu drop-

down atau pada Layers Manager, pilih Graphic layer 1. Klik File→ Load Gerber file(s) atau klik pada ikon . Buka
semua berkas Gerber Anda. Perhatikan bagaimana masing-masing berkas ditampilkan di atas berkas lainnya.

2. Buka berkas drill melalui menu File→ Open Excellon Drill File(s).

3. Gunakan Layers Manager di sebelah kanan untuk memilih lapisan yang ingin ditampilkan. Periksa dengan teliti setiap
lapisan sebelum mengirimkannya ke manufaktur untuk diproduksi.

4. Tampilannya bekerja mirip seperti Pcbnew. Klik-kanan pada tampilan, dan klik Grid untuk mengubah grid.

5.4 Melakukan Routing Otomatis dengan FreeRouter

Melakukan routing sebuah PCB secara manual bisa Anda lakukan dengan cepat dan menyenangkan, namun untuk PCB yang
memiliki banyak komponen, Anda mungkin ingin menggunakan autorouter. Ingat bahwa Anda harus terlebih dahulu melakukan
routing jalur-jalur yang penting secara manual, baru kemudian melanjutkan sisanya dengan autorouter. Autorouter hanya akan
mengerjakan jalur-jalur yang belum di-routing. Autorouter yang akan kita gunakan di sini adalah FreeRouting.

Catatan
FreeRouting adalah aplikasi java sumber-terbuka. Saat ini, FreeRouting memiliki beberapa salinan yang kurang lebih identik
yang dapat Anda temukan di Internet dengan melakukan pencarian "freerouting". FreeRouting bisa ditemukan dalam bentuk
kode sumber saja, atau dalam bentuk paket java.

1. Dari Pcbnew, klik File→ Export→ Specctra DSN dan simpan berkas secara lokal. Jalankan FreeRouter dan klik pada
tombol Open Your Own Design, buka berkas dsn Anda.

2. FreeRouter memiliki beberapa fitur yang tidak dimiliki oleh KiCad, baik untuk routing secara manual maupun otomatis.
FreeRouter bekerja dengan dua langkah utama: pertama, melakukan routing PCB, dan kemudian melakukan optimasi.
Optimasi penuh bisa membutuhkan waktu yang lama, namun Anda bisa menghentikan prosesnya jika diperlukan.

3. Anda bisa memulai proses autorouting dengan klik pada tombol Autorouter pada bilah alat bagian atas. Bilah alat bagian
bawah menampilkan informasi mengenai proses routing yang sedang berjalan. Jika jumlah Pass sudah di atas 30, papan
PCB Anda mungkin tidak bisa di-autorouting dengan router ini. Sebarlah komponen Anda dan atur jaraknya, atau putarlah
beberapa komponen dan cobalah kembali melakukan autorouting. Tujuan dari memutar dan memindahkan komponen
adalah untuk mengurangi jumlah jalur yang saling bersilang pada ratsnest.

4. Untuk menghentikan autorouting, lakukan klik, dan secara otomatis proses optimasi akan dimulai. Klik berikutnya akan
menghentikan proses optimasi. Anda sebaiknya menunggu agar FreeRouter menyelesaikan tugasnya, kecuali Anda benar-
benar perlu untuk menghentikan prosesnya.

5. Klik menu File → Export Specctra Session File dan simpan berkas PCB dengan ekstensi .ses. Anda tidak perlu me-
nyimpan berkas rule FreeRouter.

6. Kembali ke Pcbnew. Anda bisa mengimpor papan PCB yang telah di-routing dengan klik pada File→ Import→ Spectra
Session, kemudian pilih berkas .ses Anda.

Jika ada jalur routing yang tidak Anda sukai, Anda bisa menghapusnya dan melakukan routing ulang. Gunakan [Delete] untuk

menghapus, dan lakukan routing ulang menggunakan ikon Route tracks pada bilah alat sebelah kanan.
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Bab 6

Anotasi Maju (Forward Annotation) pada KiCad

Jika Anda telah menyelesaikan pembuatan skematik, footprint, tata letak papan PCB, dan berkas Gerber, maka Anda telah siap
untuk mengirimkan semua berkas ke manufaktur PCB untuk mewujudkan papan PCB Anda.

Alur kerja yang linier ini terkadang tidak selalu bisa searah. Sebagai contoh, ketika Anda harus memodifikasi atau mengubah
ukuran papan PCB setelah Anda atau orang lain menyelesaikan alur kerja ini, mungkin Anda perlu memindahkan beberapa
komponen, menggantinya dengan komponen yang lain, mengubah footprint, dan sebagainya. Selama proses modifikasi ini, apa
yang tidak Anda inginkan adalah melakukan routing ulang dari awal untuk keseluruhan papan PCB. Yang perlu Anda lakukan
adalah:

1. Kita asumsikan bahwa Anda ingin mengubah suatu konektor CON1 menjadi CON2.

2. Anda telah memiliki sebuah skematik yang lengkap dan PCB yang telah di-routing.

3. Dari KiCad, buka Eeschema, lakukan modifikasi dengan menghapus komponen CON1 dan menambahkan CON2. Simpan

proyek skematik Anda dengan ikon dan klik pada ikon Netlist generation pada bilah alat bagian atas.

4. Klik pada Netlist dan kemudian simpan dengan nama berkas default. Anda akan menimpa berkas yang lama.

5. Sekarang pilih footprint untuk komponen CON2. Klik pada ikon Run Cvpcb pada bilah alat bagian atas. Pilih
footprint untuk komponen CON2. Komponen yang lain masih menggunakan footprint yang lama. Tutup Cvpcb.

6. Kembali ke editor skematik, simpan proyek Anda dengan klik File→ Save Whole Schematic Project. Tutup editor skema-
tik.

7. Dari manajer proyek KiCad klik pada ikon Pcbnew. Jendela Pcbnew akan terbuka.

8. Papan PCB yang lama, yang sudah di-routing, akan terbuka. Sekarang kita lakukan impor berkas Netlist yang baru. Klik

pada ikon Read Netlist pada bilah alat bagian atas.

9. Klik pada tombol Browse Netlist Files, pilih berkas Netlist pada kotak dialog pemilihan berkas, dan klik Read Current
Netlist. Kemudian klik tombol Close.

10. Anda bisa melihat tata letak PCB dengan semua komponen sebelumnya yang telah di-routing. Pada sudut kiri atas, Anda
bisa melihat semua komponen yang belum di-routing, yang dalam latihan kita adalah komponen CON2. Pilih CON2
dengan klik komponen tersebut. Pindahkan komponen ke tengah papan PCB.

11. Letakkan CON2 dan lakukan routing. Jika sudah selesai, simpan dan lanjutkan dengan pembuatan berkas Gerber seperti
biasa.

Proses yang dijelaskan di sini dapat dengan mudah diulang sebanyak yang Anda butuhkan. Di samping metode Anotasi Maju
(Forward Annotation) seperti yang dijelaskan di atas, ada juga metode yang disebut dengan Anotasi Mundur (Backward Annota-
tion). Dengan metode ini, Anda bisa membuat modifikasi pada papan PCB yang telah di-routing melalui Pcbnew, dan melakukan
pembaruan hasil modifikasi tersebut pada berkas skematik dan Netlist. Akan tetapi metode Backward Annotation ini agak sulit
digunakan, sehingga tidak dijelaskan di sini.
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Bab 7

Membuat Simbol Skematik di KiCad

Terkadang sebuah simbol skematik yang Anda inginkan tidak tersedia di pustaka KiCad. Ini adalah hal yang biasa terjadi,
sehingga Anda tidak perlu khawatir. Pada bagian ini, kita akan melihat bagaimana sebuah simbol skematik dapat dibuat dengan
cepat di KiCad. Meskipun demikian, perlu diingat bahwa Anda juga bisa mencari komponen KiCad di Internet.

Di KiCad, sebuah simbol tersusun dari teks yang dimulai dengan DEF dan diakhiri dengan ENDDEF. Satu atau lebih simbol
umumnya disimpan di dalam sebuah berkas pustaka dengan ekstensi .lib. Jika Anda ingin menambahkan simbol ke sebuah berkas
pustaka, Anda bisa dengan mudah menggunakan perintah cut dan paste pada editor teks.

7.1 Menggunakan Component Library Editor

1. Kita bisa menggunakan Component Library Editor (bagian dari Eeschema) untuk membuat komponen baru. Di dalam
folder proyek kita, yakni tutorial1, kita akan membuat sebuah folder bernama library. Di dalamnya kita akan menyimpan
berkas pustaka kita, yaitu myLib.lib, setelah kita selesai membuat komponen yang baru.

2. Sekarang kita bisa mulai membuat komponen baru. Dari KiCad, buka Eeschema, klik pada ikon Library Editor

dan klik pada ikon New component . Jendela Component Properties akan muncul. Beri nama komponen yang baru
MYCONN3, ketik J pada Default reference designator, dan ketik 1 pada Number of units per package. Klik OK. Jika
muncul pesan peringatan, klik Yes. Saat ini komponen yang kita buat hanya terdiri dari label saja. Mari kita tambahkan

beberapa pin. Klik pada ikon Add Pins pada bilah alat sebelah kanan. Untuk meletakkan pin, klik kiri di tengah
halaman, tepat di bawah label MYCONN3.

3. Pada jendela Pin Properties, berikan nama pin VCC, ubah nomor pin menjadi 1, dan Electrical type menjadi Power input,
kemudian klik OK.
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4. Letakkan pin dengan klik pada lokasi yang Anda inginkan, tepat di bawah label MYCONN3.

5. Ulangi langkah peletakan pin, namun kali ini ubah Pin name menjadi INPUT, Pin number menjadi 2, dan Electrical Type
dipilih Passive.

6. Ulangi langkah peletakan pin, namun kali ini Pin name diisi GND, Pin number diisi 3, dan Electrical Type dipilih Passive.
Atur peletakan pin sehingga berurutan dari atas ke bawah. Label komponen MYCONN3 harus berada di tengah halaman
(pada pertemuan garis biru).

7. Sekarang, gambarlah garis luar komponen. Klik pada ikon Add rectangle . Kita ingin menggambar sebuah persegi
tepat di samping pin-pin kita, seperti ditunjukkan pada gambar di bawah ini. Klik di mana Anda ingin meletakkan sudut
kiri atas persegi (jangan menahan tombol tetikus). Klik lagi di mana Anda ingin meletakkan sudut kanan bawah persegi.

8. Jika Anda ingin mengisi persegi dengan warna kuning, atur nilai Fill colour menjadi yellow 4 pada Preferences→ Select
color scheme, lalu pilih persegi pada layar editor dengan [e], pilih Fill background.

9. Simpan komponen ke dalam pustaka Anda, myLib.lib. Klik pada ikon New Libray , buka folder tutorial1/library/ dan
simpan berkas pustaka yang baru dengan nama berkas myLib.lib.
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10. Buka Preferences → Component Libraries dan tambahkan tutorial1/library/ ke dalam User defined search path dan
myLib.lib ke dalam Component library files.

11. Klik pada ikon Select working library . Pada jendela Select Library, klik myLib dan klik OK. Perhatikan pada judul
jendela yang mengindikasikan pustaka yang sedang digunakan, yaitu myLib.

12. Klik pada ikon Update current component in current library pada bilah alat bagian atas. Simpan semua perubahan

dengan klik pada ikon Save current loaded library on disk pada bilah alat bagian atas. Klik Yes jika ada pesan kon-
firmasi yang muncul. Komponen skematik kita yang baru telah selesai dan telah tersedia pada pustaka yang diindikasikan
di bilah judul jendela.

13. Sekarang Anda bisa menutup jendela Component Library Editor. Anda akan kembali ke jendela editor skematik. Kompo-
nen yang baru akan dapat diakses dari pustaka myLib.

14. Berkas pustaka file.lib apapun akan dapat Anda gunakan dengan menambahkannya ke path pustaka. Dari Eeschema, buka
Preferences→ Library dan tambahkan path ke dalam User defined search path serta file.lib ke dalam Component library
files.

7.2 Ekspor, Impor, dan Modifikasi Komponen pada Pustaka

Terkadang kita tidak perlu membuat komponen dari awal, akan tetapi lebih mudah untuk memulai dari komponen yang sudah
ada dan memodifikasinya. Pada bagian ini, kita akan melihat bagaimana mengekspor sebuah komponen dari pustaka standar
KiCad (device) ke pustaka yang telah Anda buat (myOwnLib.lib) dan kemudian melakukan modifikasi.

1. Dari KiCad, buka Eeschema, klik pada ikon Library Editor , klik pada ikon Select working library dan pilih pus-

taka device. Klik pada ikon Load component to edit from the current lib dan lakukan impor komponen RELAY_2RT.

2. Klik pada ikon Export component , buka folder library/ dan simpan berkas pustaka yang baru dengan nama myO-
wnLib.lib.

3. Anda bisa mengaktifkan pustaka myOwnLib.lib agar bisa Anda gunakan, dengan menambahkannya ke path. Dari Ee-
schema, buka Preferences → Component Libraries dan tambahkan library/ ke dalam User defined search path dan
myOwnLib.lib ke dalam Component library files. Tutup jendela.

4. Klik pada ikon Select working library . Pada jendela Select Library, klik myOwnLib dan klik OK. Perhatikan bahwa
judul jendela mengindikasikan pustaka yang sedang kita gunakan, yaitu myOwnLib.

5. Klik pada ikon Load component to edit from the current lib dan lakukan impor komponen RELAY_2RT.

6. Sekarang Anda bisa melakukan modifikasi komponen sesuai keinginan Anda. Arahkan kursor ke atas label RELAY_2RT,
tekan [e] dan beri nama MY_RELAY_2RT.

7. Klik pada ikon Update current component in current library pada bilah alat bagian atas. Simpan perubahan yang

Anda lakukan dengan klik ikon Save current loaded library on disk pada bilah alat bagian atas.
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7.3 Membuat Komponen Skematik dengan QuickLib

Bagian ini akan menjelaskan cara alternatif untuk membuat komponen skematik MYCONN3 (lihat MYCONN3 di atas) dengan
menggunakan peralatan quicklib yang berbasis Internet.

1. Bukalah halaman web quicklib: http://kicad.rohrbacher.net/quicklib.php

2. Isilah halaman tersebut dengan informasi berikut: Component name: MYCONN3 Reference Prefix: J Pin Layout Style:
SIL Pin Count, N: 3

3. Klik pada ikon Assign Pins. Isilah halaman dengan informasi berikut ini: Pin 1: VCC, Pin 2: input, Pin 3: GND. Type:
Passive untuk semua pin.

4. Klik pada ikon Preview it, dan jika telah sesuai dengan keinginan Anda, klik Build Library Component. Unduh berkas
hasilnya, dan ubah namanya menjadi tutorial1/library/myQuickLib.lib. Anda telah selesai!

5. Lihat hasilnya dengan menggunakan KiCad. Dari manajer proyek KiCad, buka Eeschema, klik pada ikon Library Editor

, klik pada ikon Import Component , buka tutorial1/library/ dan pilih myQuickLib.lib.

6. Anda bisa menggunakan komponen dan keseluruhan pustaka myQuickLib.lib dengan menambahkannya ke path pustaka
KiCad. Dari Eeschema, buka Preferences→ Component Libraries dan tambahkan library ke dalam User defined search
path, serta myQuickLib.lib ke dalam Component library files.

Metode pembuatan komponen pustaka ini akan sangat efektif jika Anda ingin membuat komponen dengan jumlah pin yang
banyak.

7.4 Membuat Komponen Skematik dengan Jumlah Pin yang Banyak

Pada bagian yang berjudul Membuat Komponen Skematik dengan QuickLib, kita melihat bagaimana membuat sebuah komponen
skematik dengan menggunakan peralatan berbasis web quicklib. Bagaimanapun, terkadang Anda perlu membuat komponen
skematik dengan jumlah pin yang banyak (hingga ratusan pin). Di KiCad, hal ini cukup mudah dilakukan.

1. Misalkan Anda membutuhkan komponen skematik dengan pin berjumlah 50 buah. Praktik yang umum dilakukan adalah
membuat beberapa gambar dengan jumlah pin yang tidak terlalu banyak, sebagai contoh dua gambar yang masing-masing
memiliki 25 pin. Penggambaran komponen seperti ini akan memudahkan saat membuat koneksi pin.

2. Cara yang paling mudah untuk membuat komponen kita adalah dengan menggunakan quicklib untuk membuat dua buah
komponen dengan jumlah pin sebanyak 25 buah, secara terpisah. Kemudian melakukan penomoran ulang pin-pin tersebut
dengan skrip Python, dan terakhir menggabungkan kedua komponen tersebut dengan menggunakan copy-paste untuk
menjadikan keduanya menyatu ke dalam satu komponen DEF dan ENDDEF.

3. Contoh skrip Python sederhana di bawah ini bisa digunakan dengan berkas in.txt dan out.txt untuk melakukan penomoran
ulang baris: X PIN1 1 -750 600 300 R 50 50 1 1 I menjadi X PIN26 26 -750 600 300 R 50 50
1 1 I hal ini dilakukan untuk semua baris pada berkas in.txt.

http://kicad.rohrbacher.net/quicklib.php
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Skrip sederhana

#!/usr/bin/env python
’’’ skrip sederhana untuk memanipulasi penomoran pin-pin komponen KiCad’’’
import sys, re
try:

fin=open(sys.argv[1],’r’)
fout=open(sys.argv[2],’w’)

except:
print "oh, wrong use of this app, try:", sys.argv[0], "in.txt out.txt"
sys.exit()

for ln in fin.readlines():
obj=re.search("(X PIN)(\d*)(\s)(\d*)(\s.*)",ln)

if obj:
num = int(obj.group(2))+25
ln=obj.group(1) + str(num) + obj.group(3) + str(num) + obj.group(5) +’\n’
fout.write(ln)

fin.close(); fout.close()
#
# untuk informasi lebih lanjut mengenai sintaks regular expression dan pembuatan komponen ←↩

KiCad:
# http://gskinner.com/RegExr/
# http://kicad.rohrbacher.net/quicklib.php

1. Saat menggabungkan dua komponen menjadi satu, sangat penting untuk menggunakan Library Editor dari Eeschema
untuk memindahkan komponen yang pertama sehingga komponen yang kedua tidak berada di atas komponen pertama. Di
bawah ini, Anda akan menemukan berkas final.lib dan tampilannya di Eeschema.

Isi berkas *.lib

EESchema-LIBRARY Version 2.3
#encoding utf-8
# COMP
DEF COMP U 0 40 Y Y 1 F N
F0 "U" -1800 -100 50 H V C CNN
F1 "COMP" -1800 100 50 H V C CNN
DRAW
S -2250 -800 -1350 800 0 0 0 N
S -450 -800 450 800 0 0 0 N
X PIN1 1 -2550 600 300 R 50 50 1 1 I

...

X PIN49 49 750 -500 300 L 50 50 1 1 I
ENDDRAW
ENDDEF
#Akhir Library
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1. Skrip Python yang ditampilkan di sini sangat berguna untuk memanipulasi baik nomor pin maupun label pin. Namun perlu
diperhatikan bahwa kemampuan skrip ini didapatkan dari sintaks Regular Expression yang rumit namun sangat berguna:
http://gskinner.com/RegExr/.
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Bab 8

Membuat Footprint Komponen

Tidak seperti perangkat lunak EDA lainnya, yang memiliki satu tipe pustaka yang berisi simbol skematik dan variasi footprint,
berkas .lib pada KiCad hanya berisi simbol skematik, sedangkan footprint disimpan pada berkas .kicad_mod. Cvpcb digunakan
untuk melakukan pemetaan footprint ke simbol.

Seperti halnya berkas .lib, berkas pustaka .kicad_mod adalah berkas teks yang bisa berisi satu atau beberapa bagian.

KiCad telah menyediakan sejumlah pustaka footprint, namun kadang Anda mungkin membutuhkan footprint yang tidak tersedia
di pustaka KiCad. Berikut adalah langkah untuk membuat sebuah footprint PCB yang baru di KiCad:

8.1 Menggunakan Footprint Editor

1. Dari manajer proyek KiCad, buka Pcbnew. Klik pada ikon Open Footprint Editor pada bilah alat bagian atas.
Footprint Editor akan terbuka.

2. Kita akan menyimpan footprint yang baru MYCONN3 ke dalam pustaka footprint myfootprint. Buat sebuah folder myfo-
otprint.pretty di dalam folder proyek tutorial1/. Klik Preferences → Footprint Libraries Manager dan tekan tombol
Append Library. Pada tabel, masukkan "myfootprint" pada Nickname, masukkan "${KIPRJMOD}/myfootprint.pretty"
pada Library Path dan masukkan "KiCad" pada Plugin Type. Tekan OK untuk menutup jendela PCB Library Tables. Klik

pada ikon Select active library pada bilah alat bagian atas. Pilih pustaka myfootprint.

3. Klik pada ikon New Footprint pada bilah alat bagian atas. Ketik MYCONN3 pada footprint name. Di tengah layar,
akan muncul label MYCONN3. Di bawah label, Anda akan menemukan label REF*. Klik kanan pada MYCONN3 dan
pindahkan ke atas REF*. Klik kanan pada REF*__, pilih Edit Text dan ganti namanya dengan SMD. Ubahlah pilihan
Display menjadi Invisible.

4. Pilih ikon Add Pads pada bilah alat sebelah kanan. Klik pada lembar kerja untuk meletakkan pad. Klik kanan pada
pad yang baru dibuat, dan klik Edit Pad. Anda juga bisa menekan [e].
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5. Ubah nilai Pad Num menjadi 1, Pad Shape bernilai Rect, Pad Type bernilai SMD, Shape Size X bernilai 0.4, dan Shape Size
Y bernilai 0.8. Klik OK. Klik lagi ikon Add Pads dan letakkan dua buah pad.

6. Jika Anda ingin mengubah ukuran grid, lakukan Klik kanan→ Grid Select. Pastikan untuk memilih ukuran grid yang
tepat sebelum meletakkan komponen.

7. Pindahkan label MYCONN3 dan label SMD ke luar sehingga tampak seperti gambar.

8. Saat meletakkan pad, terkadang kita perlu mengukur jarak relatif. Letakkan kursor di mana Anda ingin meletakkan titik
koordinat relatif (0,0), dan tekan tombol spasi. Saat menggeser kursor, Anda akan melihat indikasi relatif dari posisi kursor
pada bagian bawah halaman. Tekan tombol spasi untuk mengatur titik koordinat awal relatif yang baru.

9. Sekarang tambahkan kontur footprint. Klik pada tombol Add graphic line or polygon pada bilah alat sebelah kanan.
Gambarlah garis luar konektor yang mengelilingi komponen.

10. Klik pada ikon Save Footprint in Active Library pada bilah alat bagian atas, dan gunakan nama default MYCONN3.
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Bab 9

Catatan Tentang Portabilitas Berkas Proyek Ki-
Cad

Berkas apa saja yang perlu Anda kirimkan ke orang lain agar ia bisa membuka dan menggunakan proyek KiCad Anda?

Saat Anda memiliki sebuah proyek KiCad yang akan Anda bagikan ke orang lain, Anda perlu memastikan bahwa berkas skematik
.sch, berkas papan PCB .kicad_pcb, berkas proyek .pro dan berkas Netlist .net, dikirimkan bersama dengan berkas komponen
skematik .lib dan berkas footprint .kicad_mod. Hanya dengan cara ini, orang yang menerima berkas Anda akan bebas untuk
memodifikasi skematik dan papan PCB yang Anda buat.

Untuk berkas skematik KiCad, diperlukan adanya berkas .lib yang berisi simbol-simbol. Berkas pustaka tersebut harus dimuat
pada preferensi Eeschema. Sedangkan untuk berkas papan PCB (berkas .kicad_pcb), footprint dapat disimpan di dalam berkas
.kicad_pcb. Anda bisa mengirimkan kepada orang lain sebuah berkas .kicad_pcb saja, dan ia akan bisa melihat dan mengedit
papan PCB Anda. Bagaimanapun, saat mereka ingin memuat komponen dari Netlist, berkas footprint (berkas .kicad_mod) harus
tersedia dan dimuat di preferensi Pcbnew, seperti halnya skematik. Penting juga untuk memuat berkas .kicad_mod di preferensi
Pcbnew agar footprint dapat ditampilkan di Cvpcb.

Jika seseorang mengirimi Anda berkas .kicad_pcb, dan ada footprint pada berkas itu yang ingin Anda gunakan pada papan PCB
yang lain, Anda bisa membuka Footprint Editor, memuat footprint dari papan PCB yang sedang dibuka, dan menyimpan atau
mengekspor ke pustaka footprint yang lain. Anda juga bisa mengekspor semua footprint dari berkas .kicad_pcb melalui Pcbnew
→ File→Archive→ Footprints→Create footprint archive, yang akan membuat berkas .kicad_mod yang baru dengan semua
footprint yang digunakan pada papan PCB.

Pada intinya, jika PCB adalah satu-satunya hal yang ingin Anda distribusikan, maka berkas .kicad_pcb saja sudah cukup. Namun,
jika Anda ingin memberikan kemampuan penuh kepada orang lain untuk menggunakan dan memodifikasi skematik, komponen
dan PCB Anda, sangat direkomendasikan untuk membuat berkas zip dan mengirimkan direktori proyek berikut ini:

tutorial1/
|-- tutorial1.pro
|-- tutorial1.sch
|-- tutorial1.kicad_pcb
|-- tutorial1.net
|-- library/
| |-- myLib.lib
| |-- myOwnLib.lib
| \-- myQuickLib.lib
|
|-- myfootprint.pretty/
| \-- MYCONN3.kicad_mod
|
\-- gerber/

|-- ...
\-- ...
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Lebih Lanjut Tentang Dokumentasi KiCad

Dokumen ini adalah panduan ringkas untuk sebagian besar fitur di KiCad. Untuk instruksi yang lebih detail, bacalah berkas
bantuan yang bisa diakses melalui tiap-tiap modul KiCad. Klik Help→Manual.

KiCad telah menyertakan sejumlah manual dalam berbagai bahasa untuk keempat komponen perangkat lunak yang ada di KiCad.

Versi Bahasa Inggris dari buku manual KiCad didistribusikan bersama dengan perangkat lunak KiCad.

Sebagai tambahan bagi buku manual, KiCad didistribusikan dengan tutorial ini, yang telah diterjemahkan ke dalam berbagai
bahasa. Semua versi yang berbeda dari tutorial ini didistribusikan secara cuma-cuma dengan semua versi terbaru KiCad. Tutorial
ini, bersama dengan buku manual, telah disertakan bersama versi KiCad yang Anda gunakan.

Sebagai contoh, pada sistem operasi Linux, lokasi yang umum untuk menemukan dokumentasi KiCad adalah pada direktori
berikut, bergantung pada distribusi yang Anda gunakan:

/usr/share/doc/kicad/help/en/
/usr/local/share/doc/kicad/help/en

Pada sistem operasi Windows, Anda bisa menemukannya di:

<direktori instalasi>/share/doc/kicad/help/en

Pada OS X:

/Library/Application Support/kicad/help/en

10.1 Dokumentasi KiCad di Internet

Dokumentasi KiCad versi terbaru tersedia dalam berbagai bahasa di http://docs.kicad-pcb.org

http://docs.kicad-pcb.org
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