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Kapitel 1. Vorstellung von KiCad



KiCad ist ein Open Source Softwaretool zum Erstellen von elektronischen Schaltplänen und PCB Layouts. Durch seine einheitliche Schnittstellentechnik verbindet KiCad elegant die einzelnen folgenden eigenständigen Software Tools:
	Programmname	Beschreibung	Datei Erweiterung
	KiCad
	Projekt Manager
	*.pro

	Eeschema
	Schaltplan Editor (Schaltplan und Bauteile)
	*.sch, *.lib, *.net

	Pcbnew
	Leiterplatten Editor
	*.kicad_pcb, *.kicad_mod

	GerbView
	Betrachter Gerber- und Bohrdateien
	*.g*, *.drl, etc.

	Bitmap2Component
	Konvertiert Bitmapgrafiken in Bauteile oder Footprints
	*.lib, *.kicad_mod, *.kicad_wks

	PCB Calculator
	Kalkulator für Bauteile, Leiterbahnbreite, Elektrische Abstände, Farbcodes, und mehr
	Keine

	Pl Editor
	Seiten Layout Editor
	*.kicad_wks



Anmerkung
Die Liste der Datei Erweiterungen ist nicht komplett und beinhaltet nur eine Teilmenge der Dateien mit denen KiCad arbeitet. Diese ist jedoch hilfreich für ein Basiswissen welche Dateien in den einzelnen KiCad Applikationen benutzt werden.

KiCad kann als ausreichend ausgereift betrachtet werden um erfolgreich auch komplexe elektronische Schaltungen und Leiterplatten entwickeln und managen zu können.
KiCad hat keine Beschränkungen bei der Platinengröße und es kann bis zu 32 Kupferlagen, bis zu 14 technische Lagen und bis zu vier Hilfslagen einfach kontrollieren. KiCad kann alle Dateien erstellen die nötig sind für gedruckte Schaltungen, ebenso Gerber Dateien für Foto Plotter, Bohrdateien, Bauteilplatzierungsdateien und noch vieles mehr.
Durch die Open Source Ausrichtung (GPL lizenzensiert) repräsentiert KiCad sich als das ideale Tool für fortschrittlich ausgerichtete Projekte die elektronische Hardware erstellen.
Im Internet ist KiCad beheimatet unter:
http://www.kicad.org/

1.1. Herunterladen und Installieren von KiCad



KiCad ist lauffähig auf GNU/Linux, Apple Mac OS und Windows. Sie finden die aktuellsten Anleitungen und Download Links unter:
http://www.kicad.org/download/
Wichtig
Stabile Veröffentlichungen von KiCad erscheinen periodisch nach den KiCad Stable Veröffentlichungsregeln. Neue Features werden kontinuierlich im Entwicklungsbranch hinzugefügt. Wenn Sie die Möglichkeiten dieser neuen Funktionen nutzen wollen oder helfen wollen beim Testen dieser, laden Sie sich bitte die aktuellste Entwicklungsversion (Nightly Builds) für Ihre Plattform herunter. Entwicklungsversionen können neue Fehler enthalten, aber es ist dem KiCad Development Team ein Anliegen den aktuellen Entwicklungsbranch bestmöglich benutzbar zu halten während dem Hinzufügen neuer Funktionen.

1.1.1. Installation unter GNU/Linux



Stabile KiCad Veröffentlichungen können in den meisten Paketverwaltungen der jeweiligen Distribution gefunden werden, meistens unter den Namen kicad und kicad-doc. Wenn Ihre Distribution nicht die aktuelle stabile Version bereit hält dann folgen Sie den Anweisungen für die Entwicklerversion und wählen die letzte stabile Version.
Zum Beispiel in Ubuntu ist der übliche Weg eine Entwicklerversionen zu installieren via zusätzlichem PPA und dem Paketmanager Aptitude. Dazu sind folgende Eingaben in einem Terminal nötig:
sudo add-apt-repository ppa:js-reynaud/ppa-kicad
sudo aptitude update && sudo aptitude safe-upgrade
sudo aptitude install kicad kicad-doc-de
Unter Debian ist der einfachste Weg, den Backports Build zu installieren folgender:
# Set up Debian Backports
echo -e "
# stretch-backports
deb http://ftp.us.debian.org/debian/ stretch-backports main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch-backports main contrib non-free
" | sudo tee -a /etc/apt/sources.list > /dev/null

#Führe ein Update aus und installiere Kicad
sudo apt-get update
sudo apt-get install -t stretch-backports kicad
In Fedora benutzen Sie ebenfalls den Paketmanager copr um einfach eine Entwicklerversionen zu installieren. Um KiCad durch copr zu installieren bitte folgende Eingaben in einem Terminal tätigen:
sudo dnf copr enable @kicad/kicad
sudo dnf install kicad
Sie können alternativ vorkompilierte Versionen von KiCad herunterladen und installieren. Oder Sie laden den Source Code herunter und kompilieren und installieren KiCad selbst.

1.1.2. Installation unter Apple Mac OS



Stable builds of KiCad for macOS can be found at: https://downloads.kicad.org/kicad/macos/explore/stable
Unstable nightly development builds can be found at: https://downloads.kicad.org/kicad/macos/explore/nightlies

1.1.3. Installation unter Windows



Stable builds of KiCad for Windows can be found at: https://downloads.kicad.org/kicad/windows/explore/stable
For Windows you can find nightly development builds at: https://downloads.kicad.org/kicad/windows/explore/nightlies


1.2. Support



Wenn Sie Ideen, Anmerkungen oder Fragen haben, oder einfach nur Hilfe benötigen:
	
Visit the Forum

	
Join users on IRC or Discord

	
Watch Tutorials




Kapitel 2. KiCad Arbeitsablauf



Ungeachtet der Ähnlichkeiten mit anderen PCB Software Tools charakterisiert sich KiCad durch einen interessanten Arbeitsablauf in dem Bauteilkomponenten und Footprints zwei verschiedene Einheiten bilden. Erst nach dem Erstellen eines Schaltplanes werden den Bauteilen Footprints zugewiesen.

2.1. Übersicht



Der Arbeitsablauf in KiCad beinhaltet zwei Hauptvorgänge: Erstellen des Schaltplanes und Anlegen der Platine. Dazu sind zwei Arten Bibliotheken, die Bauteilbibliotheken und die Bibliotheken der Footprints, nötig. KiCad beinhaltet zahlreiche dieser Bibliotheken. Und wenn diese nicht ausreichend sind, KiCad besitzt ebenso die nötigen Tools um neue Bibliotheken zu erstellen.
In der nach folgenden Grafik sehen Sie ein Flussdiagramm welches den KiCad Arbeitsablauf darstellt. Das Bild erklärt die Schritte und deren Reihenfolge die nötig sind beim Arbeiten mit KiCad. Wenn möglich wird das zugehöre Icon des Menüpunktes mit dargestellt.
[image: KiCad Flowchart]

For more information about creating a component, read Making schematic symbols. And for information about how to create a new footprint, see Making component footprints.
Quicklib ist ein Werkzeug welches es Ihnen erlaubt KiCad Bauteile über ein Webinterface schnell zu erstellen. Für weitere Informationen über Quicklib sei auf die Sektion Erstellen von Schaltplansymbolen mit quicklib in diesem Dokument verwiesen.

2.2. Vorwärts und Rückwärts Annotation



Ist ein elektronischer Schaltplan komplett gezeichnet dann ist der nächste Schritt diesen in eine Platine (PCB, Printed Cicruit Board) umzuwandeln. Oft müssen dann noch zusätzliche Komponenten hinzugefügt, Bauteile in deren Größe oder Bauform geändert oder Bauteile verschoben, Netze umbenannt werden. Dies kann auf zwei Arten erfolgen: Vorwärts Annotation und Rückwärts Annotation.
Bei der Vorwärts Annotation werden Veränderungen am Schaltplan in inkrementeller Form an das zugehörige PCB Layout geschickt. Dies ist ein wichtiges Feature da Sie nicht wirklich die Platine jedes mal neu entwerfen wollen sobald Sie eine Veränderung am Schaltplan durchführen. Vorwärts Annotation ist in der Sektion Vorwärts Annotation in KiCad erläutert.
Rückwärts Annotation ist der Prozess eine PCB Layout Veränderung zurück zum entsprechenden Schaltplan zu schicken. Zwei dieser typischen Anwendungsfälle für eine Rückwärts Annotation sind das Tauschen von Gattern oder das Tauschen von Pinanschlüssen. In solchen Situationen werden Gatter oder Pinbelegungen die funktional gleich sind getauscht da eine andere Zu- oder Anordnung dieser Elemente auf der PCB das Layouten vereinfacht. Diese Änderung am PCB Design werden nach der Fertigstellung wieder zurück an den Schaltplan übertragen.

Kapitel 3. Benutzung von KiCad




3.1. Schnellzugriff auf Befehle per Tastatur



KiCad besitzt zwei unterschiedliche Typen Schnellzugriffstasten: Tastaturkürzel und Tastaturbefehle. Beide Typen werden benutzt um die Arbeit mit KiCad zu beschleunigen indem die Tastatur zum Zugriff auf Befehle benutzt wird anstatt der Maus.
3.1.1. Tastaturkürzel



Tastaturkürzel haben die gleiche Auswirkung wie ein Anklicken eines Icons in einem Menü oder einer Toolbar: Das Kommando wird aber erst wenn die linke Maustaste betätigt ausgeführt. Benutzen Sie ein Tastaturkürzel wenn Sie ein Kommando aufrufen wollen aber keine direkte Ausführung wünschen.
Tastaturkürzel werden in allen geöffneten Menüs auf der rechten Seite gezeigt.
[image: Tastaturkürzel]


3.1.2. Tastaturbefehle



Tastaturbefehle sind vergleichbar zu Tastaturkürzeln plus zusätzlich dem Klick auf der linken Maustaste. Die Benutzung eines Tastaturbefehls führt die hinterlegte Aktion an der augenblicklichen Cursorposition aus. Benutzen Sie Tastaturbefehle um Kommandos direkt auszuführen ohne den Workflow zu unterbrechen.
Sie können eine Liste der möglichen Tastaturbefehle in jedem KiCad Werkzeug einsehen indem Sie Hilfe → Tastaturbefehle auflisten aufrufen oder wenn Sie einfach Ctrl+F1 eingeben:
[image: Tastaturbefehle]

You can edit the assignment of hotkeys, and import or export them, from the Preferences → Hotkeys Options menu.
Anmerkung
In diesem Dokument sind Tastaturbefehle mit eckigen Klammern eingefasst wie zum Beispiel [a]. Wenn Sie im hier Dokument [a] sehen dann betätigen Sie das Zeichen "a" auf der Tastatur.


3.1.3. Beispiel



Betrachten wir das einfache Beispiel eines Hinzufügen einer elektrischen Verbindung in einem Schaltplan.
Wenn Sie ein Tastaturkürzel für das Kommando "Elektrische Verbindung" benutzen wollen betätigen Sie z.B. "Umschalt+W", beachten Sie wie der Cursor sich ändert. Als nächstes klicken Sie an der Stelle mit der linken Maustaste an der der Startpunkt der Verbindung liegen soll.
Im Gegensatz dazu der Tastaturbefehl, wenn Sie [w] betätigen wird die Elektrische Verbindung umgehend an der Cursorposition gestartet an dem sich die Maus aktuell befindet.


Kapitel 4. Elektronische Schaltpläne zeichnen



In diesem Abschnitt werden Sie lernen wie man einen elektronischen Schaltplan mit KiCad zeichnet.

4.1. Benutzung von Eeschema



	
Unter Windows starten Sie kicad.exe. In einem Linuxsystem rufen Sie KiCad per Menü auf, oder Sie führen Sie kicad in einem Terminal aus. Daraufhin befinden Sie sich nun im Hauptfenster vom KiCad Projektmanager. Von hier aus haben Sie Zugriff auf die acht eigenständigen Softwaretools: Eeschema, Bauteileditor, Pcbnew, PCB Footprint Editor, GerbView, Bitmap2Component, PCB Kalkulator und Pl Editor. Es sei nochmal auf das Schema des KiCad Arbeitsablauf verwiesen um zu verstehen wie die Tools benutzt werden.

[image: Kicad Hauptfenster]


	
Create a new project: File → New → Project. Name the project file tutorial1. The project file will automatically take the extension ".pro". The exact appearance of the dialog depends on the used platform, but there should be a checkbox for creating a new directory. Let it stay checked unless you already have a dedicated directory. All your project files will be saved there.

	
Lassen Sie uns nun einen Schaltplan erstellen. Starten Sie den Schaltplaneditor Eeschema [image: Eeschema]. Es ist der erste Button auf der linken Seite.

	
Click on the Page Settings icon [image: Sheet settings icon] on the top toolbar. Set the appropriate paper size (A4,8.5x11 etc.) and enter the Title as Tutorial1. You will see that more information can be entered here if necessary. Click OK. This information will populate the schematic sheet at the bottom right corner. Use the mouse wheel to zoom in. Save the whole schematic: File → Save

	
We will now place our first component. Click on the Place symbol icon [image: Add component Icon] in the right toolbar. You may also press the Add Symbol hotkey [a].

	
Click on the middle of your schematic sheet. A Choose Symbol window will appear on the screen. We’re going to place a resistor. Search / filter on the R of Resistor. You may notice the Device heading above the Resistor. This Device heading is the name of the library where the component is located, which is quite a generic and useful library.

[image: Wähle ein Symbol]


	
Double click on it. This will close the Choose Symbol window. Place the component in the schematic sheet by clicking where you want it to be.

	
Klicken Sie auf das Lupensymbol um in das Bauteil hinein zu zoomen. Alternativ benutzen Sie das Mausrad um hinein oder heraus zu zoomen. Drücken und halten Sie das Mausrad fest während Sie die Maus bewegen um dann das Arbeitsblatt horizontal und vertikal zu verschieben.

	
Bewegen Sie den Mauszeiger über das Bauteil R und betätigen die Taste [r]. Das Bauteil sollte rotierten. Sie müssen nicht auf das Bauteil klicken um dieses zu rotieren.

Anmerkung
Sometimes, if your mouse is also over something else, a menu will appear. You will see the Clarify Selection menu often in KiCad; it allows working on objects that are on top of each other. In this case, tell KiCad you want to perform the action on the Symbol …R… if the menu appears.


	
Right click in the middle of the component and select Properties → Edit Value. You can achieve the same result by hovering over the component and pressing [v]. Alternatively, [e] will take you to the more general Properties window. Notice how the right-click menu below shows the hotkeys for all available actions.

[image: Anzeigen des Komponetenmenus]


	
The Edit Value Field window will appear. Replace the current value R with 1 k. Click OK.

Anmerkung
Do not change the Reference field (R?), this will be done automatically later on. The value above the resistor should now be 1 k.

[image: Resistor Value]


	
To place another resistor, simply click where you want the resistor to appear. The symbol selection window will appear again.

	
Der Widerstand der zuvor ausgewählt worden ist wird nun in der Historie als R angezeigt. Betätigen Sie OK und platzieren das Bauteil.

[image: Component history]


	
In case you make a mistake and want to delete a component, right click on the component and click Delete. This will remove the component from the schematic. Alternatively, you can hover over the component you want to delete and press [Delete].

	
Ein schon vorhandenes Bauteil im Schaltplan kann einfach dupliziert werden in dem man den Cursor über das zu kopierende Bauteil bewegt und dann den Buchstaben [c] betätigt. Klicken Sie mit linken Maustaste an der Stelle wo das zu duplizierende Bauteil eingefügt werden soll.

	
Right click on the second resistor. Select Drag. Reposition the component and left click to drop. The same functionality can be achieved by hovering over the component and by pressing [g]. [r] will rotate the component while [x] and [y] will flip it about its x- or y-axis.

Anmerkung
Right-Click → Move or [m] is also a valuable option
for moving anything around, but it is better to use this only for component
labels and components yet to be connected. We will see later on why this is the case.


	
Bewegen Sie den Mauscursor über den zweiten Widerstand und betätigen Sie die Taste [v]. Ändern Sie R zu 100. Sie können jede Veränderung mit der Kombination Strg+z rückgängig machen.

	
Change the grid size. You have probably noticed that on the schematic sheet all components are snapped onto a large pitch grid. You can easily change the size of the grid by Right-Click → Grid. In general, it is recommended to use a grid of 50.0 mils for the schematic sheet.

	
We are going to add a component from a library that may not be configured in the default project. In the menu, choose Preferences → Manage Symbol Libraries. In the Symbol Libraries window you can see two tabs: Global Libraries and Project Specific Libraries. Each one has one sym-lib-table file. For a library (.lib file) to be available it must be in one of those sym-lib-table files. If you have a library file in your file system and it’s not yet available, you can add it to either one of the sym-lib-table files. For practice we will now add a library which already is available.

	
Select the Project Specific table. Click the file browser button below the table. You need to find where the official KiCad libraries are installed on your computer. Look for a library directory containing a hundred of .dcm and .lib files. Try in C:\Program Files (x86)\KiCad\share\ (Windows) and /usr/share/kicad/library/ (Linux). When you have found the directory, choose and add the MCU_Microchip_PIC12.lib library and close the window. It will be added to the end of of the list. Now click its nickname and change it to microchip_pic12mcu. Close the Symbol Libraries window with OK.

	
Repeat the add-component steps, however this time select the microchip_pic12mcu library instead of the Device library and pick the PIC12C508A-ISN component.

	
Hover the mouse over the microcontroller component. Notice that [x] and [y] again flip the component. Keep the symbol mirrored around the Y axis so that the pins G0 and G1 point to right.

	
Repeat the add-component steps, this time choosing the Device library and picking the LED component from it.

	
Alle Bauteile in Deinem Schaltplan sollten in etwa wie folgend organisiert sein.

[image: gsik_tutorial1_010_png]


	
We now need to create the schematic component MYCONN3 for our 3-pin connector. You can jump to the section titled Make Schematic Symbols in KiCad to learn how to make this component from scratch and then return to this section to continue with the board.

	
Sie können nun das eben erstellte Bauteil einfügen. Betätigen Sie die Taste [a] und wählen das Bauteil MYCONN3 aus der myLib Bibliothek.

	
Die Bauteil Kennung J? erscheint unter dem MYCONN3 Label. Wenn Sie dessen Position verändern wollen führen Sie einen Rechtsklick auf J? aus und wählen Referenz verschieben (oder benutzen äquivalent die Taste [m]). Es ist möglich das Sie zuvor/während dessen in das Bauteil hinein zoomen müssen. Verschieben Sie J? wie unten zu sehen. Labels können jederzeit und immer wieder verschoben werden.

[image: gsik_myconn3_s_png]


	
It is time to place the power and ground symbols. Click on the Place power port button [image: add_power_png] on the right toolbar. Alternatively, press [p]. In the component selection window, scroll down and select VCC from the power library. Click OK.

	
Click above the pin of the 1 k resistor to place the VCC part. Click on the area above the microcontroller VDD. In the Component Selection history section select VCC and place it next to the VDD pin. Repeat the add process again and place a VCC part above the VCC pin of MYCONN3. Move references and values out of the way if needed.

	
Repeat the add-pin steps but this time select the GND part. Place a GND part under the GND pin of MYCONN3. Place another GND symbol on the left of the VSS pin of the microcontroller. Your schematic should now look something like this:

[image: gsik_tutorial1_020_png]


	
Als nächstes werden wir alle Bauteile verbinden. Klicken Sie auf das Icon Elektr. Verbindung hinzufügen [image: Elektr. Verbindung hinzufügen] in der rechten Toolbar.

Anmerkung
Be careful not to pick Place bus, which appears directly beneath this button but has thicker lines. The section Bus Connections in KiCad will explain how to use a bus section.


	
Click on the little circle at the end of pin 7 of the microcontroller and then click on the little circle on pin 1 of the LED. Click once when you are drawing the wire to create a corner. You can zoom in while you are placing the connection.

Anmerkung
Wenn Sie verbundene Bauteile um positionieren wollen ist es wichtig das Sie die Taste [g] (Bauteil ziehen) benutzen und nicht die Taste [m] (Bauteil verschieben). Die Option Bauteil ziehen hält die Bauteile verbunden. Betrachten Sie noch einmal den Schritt 24 wenn Sie vergessen haben wie Bauteile verschoben werden.

[image: gsik_tutorial1_030_png]


	
Wiederholen Sie diese Schritte und verbinden Sie alle Bauteile wie in der Grafik ersichtlich. Um eine Verbindung abzubrechen klicken Sie einfach doppelt. Wenn Sie die Symbole VCC und GND verbinden sollte die Verbindung vom unteren Ende des VCC Symbols ausgehen, respektive das obere Ende beim GND Symbol. Betrachten Sie den folgenden Screenshot.

[image: gsik_tutorial1_040_png]


	
We will now consider an alternative way of making a connection using labels. Pick a net labelling tool by clicking on the Place net label icon [image: add_line_label_png] on the right toolbar. You can also use [l].

	
Click in the middle of the wire connected to pin 6 of the microcontroller. Name this label INPUT. The label is still an independent item which you can for example move, rotate and delete. The small anchor rectangle of the label must be exactly on a wire or a pin for the label to take effect.

	
Wiederholen Sie die Prozedur und platzieren ein weiteres Label an der Verbindung auf der rechten Seite des 100 Ohm Widerstandes. Benennen Sie das Label ebenfalls INPUT. Diese zwei Label (mit dem gleichen Namen) verbinden den Pin 6 vom Mikrocontroller mit dem 100 Ohm Widerstand virtuell (unsichtbar). Dies ist eine hilfreiche Technik um in komplexen Schaltungen, wo zahlreiche Verbindungslinien die Unübersichtlichkeit stark erhöhen würden, die Arbeit nicht unnötig anstrengend zu machen. Labels können nicht nur Verbindungen zugeordnet werden, es ist ebenfalls möglich einzelnen Pins ein Label zuzuweisen.

	
Labels können ebenfalls benutzt werden mit dem Zweck einfach Informationen bei zusteuern. Erstellen Sie ein Label am Pin 7 vom PIC (Mikrocontroller). Benennen Sie die Verbindung zwischen dem Widerstand und der LED als LEDtoR und die Verbindung zwischen MYCONN3 und dem Resitor als INPUTtoR.

	
Sie müssen den Verbindungen von VCC und GND keine Labels zuordnen, diese Label sind schon von den Objekten der jeweiligen Spannungen impliziert.

	
Nachfolgend können Sie sehen wie das finale Ergebnis aussehen sollte.

[image: gsik_tutorial1_050_png]


	
Kommen wir nun zum Umgang mit nicht verbundenen Signalen. KiCad wird bei der Schaltplan Überprüfung für jeden Pin oder Leitung/Signal welche(s) nicht verbunden ist eine Fehlermeldung generieren. Um diese Fehlermeldungen zu vermeiden müssen wir KiCad bewusst mitteilen das diese nicht verbundenen Signale keine Fehler sind.

	
Click on the Place no connection flag icon [image: noconn_png] on the right toolbar. Click on pins 2, 3, 4 and 5. An X will appear to signify that the lack of a wire connection is intentional.

[image: gsik_tutorial1_060_png]


	
Einige Bauteile haben Pins zur Spannungsversorgung die unsichtbar sind. Diese können Sie aber sichtbar machen indem Sie auf das Icon Versteckte Pins einblenden [image: Versteckte Pins einblenden] in der linken Toolbar klicken. Versteckte Spannungspins werden automatisch miteinander verbunden wenn es zugehörige gleich benannte Pins mit VCC und GND gibt. Allgemein gültig gesprochen sollten Sie versuchen keine versteckten Pins zur Spannungsversorgung zu erstellen.

	
It is now necessary to add a Power Flag to indicate to KiCad that power comes in from somewhere. Press [a] and search for PWR_FLAG which is in power library. Place two of them. Connect them to a GND pin and to VCC as shown below.

[image: gsik_tutorial1_070_png]

Anmerkung
This will avoid the classic schematic checking warning: Pin connected to some other pins but no pin to drive it.


	
Sometimes it is good to write comments here and there. To add comments on the schematic use the Place text icon [image: text_png] on the right toolbar.

	
All components now need to have unique identifiers. In fact, many of our components are still named R? or J?. Identifier assignation can be done automatically by clicking on the Annotate schematic symbols icon [image: annotate_png] on the top toolbar.

	
In the Annotate Schematic window, select Use the entire schematic and click on the Annotate button. Click Close. Notice how all the ? have been replaced with numbers. Each identifier is now unique. In our example, they have been named R1, R2, U1, D1 and J1.

	
Prüfen wir nun unseren Schaltplan auf Fehler. Klicken Sie dazu auf das Icon Electrical Rules Check durchführen [image: Electrical Rules Check durchführen]. Im erscheinenden Fester klicken Sie auf den Start Button. Ein Bericht wird erstellt und informiert Sie über Fehler und Warnungen wie z.B. nicht verbundene Pins oder Signale. Sie sollten Null Fehler und Null Warnungen angezeigt bekommen. Wenn ein Fehler oder eine Warnung festgestellt worden ist wird ein kleiner grüner Pfeil im Schaltplan die Stelle zeigen, an der der Fehler oder die Warnung lokalisiert worden ist. Aktivieren Sie die Checkbox ERC Protokolldatei erstellen und führen Sie den Test erneut durch, es wird nun eine *.erc Datei erstellt, abgespeichert und geöffnet in der weitere Information über die Fehler/Warnungen stehen.

Anmerkung
If you have a warning with "No default editor found, you must choose it", try setting the path to c:\windows\notepad.exe (windows) or /usr/bin/gedit (Linux).


	
The schematic is now finished. We can now create a Netlist file to which we will add the footprint of each component. Click on the Generate netlist icon [image: netlist_png] on the top toolbar. Click on the Generate Netlist button and save under the default file name.

Anmerkung
Netlist was necessary in previous versions of KiCad. In the recent versions you can ignore it and instead use Tools → Update PCB from Schematic. If you do that you have to assign footprints to symbols first.


	
Nach dem Erstellen der Datei mit der Netzliste klicken Sie auf das Icon Starte CvPcb [image: Starte CvPcb] in der oberen Toolbar. Sollte es zu einer Fehlermeldung über eine fehlende Datei kommen ignorieren Sie dies bitte und betätigen den OK Button.

Anmerkung
Es gibt noch verschiedene andere Wege einen Footprint dem Symbol zuzuordnen.
	
Rechtsklick auf das Symbol → Eigenschaften → Beabeitung des Footprint
Double click on a symbol, or right click on a symbol → Properties → Edit Properties → Footprint

	
Werkzeuge →Bearbeiten des Symbol Feldes*
Check Show footprint previews in symbol chooser in Eeschema’s preferences
and select the footprint when you select a new symbol to place





	
Cvpcb allows you to link all the components in your schematic with footprints in the KiCad library. The pane on the center shows all the components used in your schematic. Here select D1. In the pane on the right you have all the available footprints, here scroll down to LED_THT:LED-D5.0mm and double click on it.

	
Es ist möglich das im rechten Fenster nur Footprints einer ausgewählten Untergruppe sichtbar sind. Dies kann vorkommen wenn Kicad versucht eine Teilmenge von möglichen passenden Footprints zusammenzustellen. Klicken Sie auf die Icons [image: Liste der Footprints nach Schaltplan Schlüsselwörtern filtern], [image: Liste der Footprints nach Pinanzahl filtern] und [image: Liste der Footprints nach Bibliotheken filtern] um diese Filterfunktion ein oder auszuschalten.

	
For U1 select the Package_DIP:DIP-8_W7.62mm footprint. For J1 select the Connector:Banana_Jack_3Pin footprint. For R1 and R2 select the Resistor_THT:R_Axial_DIN0207_L6.3mm_D2.5mm_P2.54mm_Vertical footprint.

	
If you are interested in knowing what the footprint you are choosing looks like, you can click on the View selected footprint icon [image: show_footprint_png] for a preview of the current footprint.

	
You are done. You can save the schematic now by clicking File → Save Schematic or with the button Apply, Save Schematic & Continue.

	
You can close Cvpcb and go back to the Eeschema schematic editor. If you didn’t save it in Cvpcb save it now by clicking on File → Save. Create the netlist again. Your netlist file has now been updated with all the footprints. Note that if you are missing the footprint of any device, you will need to make your own footprints. This will be explained in a later section of this document.

Anmerkung
Now every symbol has a footprint. Instead of the net list and the next two steps you can use Tools → Update PCB from Schematic. If you do that, Pcbnew is opened with Update PCB from Schematic dialog. Click Update PCB. Then You can follow the instructions in the Pcbnew section of this tutorial.


	
Switch to the KiCad project manager. You can see the net list file in the file list.

	
Die Netzlistendatei beschreibt alle Bauteile und deren zugehörigen Pin Verbindungen. Die Netzlistendatei ist aktuell eine Textdatei welche Sie sich einfach anschauen, verändern oder skripten können.

Anmerkung
Bibliotheksdateien (*.lib) sind auch Textdateien und sind ebenso einfach veränderbar oder skriptfähig.


	
To create a Bill Of Materials (BOM), go to the Eeschema schematic editor and click on the Generate bill of materials icon [image: bom_png] on the top toolbar. By default there is no plugin active. You add one, by clicking on Add Plugin button. Select the *.xsl file you want to use, in this case, we select bom2csv.xsl.

Anmerkung
Linux:
Wenn das Programm xsltproc nicht vorhanden ist können Sie es herunterladen und installieren durch:
sudo apt-get install xsltproc
für Debian und auf Debian basierte Distributionen wie Ubuntu, oder
sudo yum install xsltproc
für eine RedHat basierte Distribution. Wenn Sie keine Distributionen dieser Art in Benutzung haben verwenden Sie den zu Ihrer Distribution zugehörigen Paketmanager um das xsltproc Paket zu installieren.
*.xsl Dateien sind abgelegt unter: /usr/lib/kicad/plugins/.
Apple Mac OS:
Wenn xsltproc nicht vorhanden ist können Sie Apple Xcode von der Apple Webseite installieren, welche das Programm enthalten sollte. Oder Sie laden es herunter und installieren es mit:
brew install libxslt
*.xsl Dateien sind abgelegt in: /Library/Application Support/kicad/plugins/.
Windows:
xsltproc.exe und die zugehörigen *.xsl Dateien können gefunden werden in ＜KiCad Installationsverzeichnis＞\bin und in_＜KiCad Installationsverzeichnis＞\bin\scripting\plugins_.
Alle Plattformen:
Sie können die aktuellste Version von bom2csv.xsl erhalten durch:
https://gitlab.com/kicad/code/kicad/raw/master/eeschema/plugins/xsl_scripts/bom2csv.xsl

KiCad erstellt den Programmaufruf automatisch, zum Beispiel: 

xsltproc -o "%O" "/home/<user>/kicad/eeschema/plugins/bom2csv.xsl" "%I"


Wenn Sie die Erweiterung hinzufügen wollen dann verändern Sie das Kommando zu: 

xsltproc -o "%O.csv" "/home/<user>/kicad/eeschema/plugins/bom2csv.xsl" "%I"


Benutzen Sie den Hilfe Button für mehr Information.

	
Klicken Sie nun auf Erstellen. Die Datei die erstellt wird (mit dem gleichen Namen wie das Projekt) wird im Projektordner abgespeichert. Öffnen Sie die *.csv Datei mit LibreOffice oder auch Excel.



Sie können nun die Erstellung des PCB Layouts beginnen, dies wird in der nächsten Sektion erklärt. Aber zuvor schauen wir uns noch schnell an wie man Bauteilpins mit Bus Linien verbindet.

4.2. Bus Verbindungen in KiCad



Manchmal müssen Sie einige aufeinander folgende Pins von Bauteil A mit aufeinander folgenden Pins am Bauteil B verbinden. Dazu gibt es zwei Möglichkeiten, entweder Sie benutzen Bezeichner (Labels), welche wir schon kennen gelernt haben, oder man benutzt Bus Verbindungen. Folgend ein paar Informationen wie man dies umsetzt.
	
Wir nehmen an das wir drei Verbinder haben an denen jeweils 4 Pins zu den anderen Verbindern 1:1 verbunden werden müssen. Benutzen Sie die Bezeichnungsoption (betätigen Sie die Taste [l]) um dem Pin 4 am Bauteil P4 zu labeln. Benennen Sie den Bezeichner a1. Nun betätigen Sie die Taste [Einfg] um ein weiteren Bezeichner automatisch an den nächsten unten liegenden Pin unter Pin 4 (Pin 3) hinzuzufügen. Beachten Sie wie dieser Bezeichner automatisch a2 benannt wird.

	
Betätigen Sie die [Einfg] Taste ein zweites Mal. Die Einfg Taste entspricht der Wiederhole letzten Vorgang Aktion und ist ein sehr hilfreiches Kommando welches das Arbeiten in KiCad sehr erleichtert.

	
Wiederholen Sie das Bezeichnen für die zwei anderen Verbinder CONN_2 und CONN_3, danach ist alles fertig. Wenn Sie mit dem PCB Layout beginnen werden Sie sehen, dass alle drei Verbinder miteinander verbunden sind. Figur 2 zeigt das Ergebnis von dem was geschildert worden ist. Ebenfalls gebräuchlich ist die Benutzung einer Serie von Elektr. Verbindung an Buseingang führen unter Benutzung des Icons [image: Elektr. Verbindung an Buseingang führen] und [image: Buseingang zu Buseingang führen], wie in Figur 3 gezeigt. Aber bedenken Sie, das hat keinen Effekt auf die Leiterplatte.

	
Es sei noch darauf hingewiesen das die kurzen Verbindungen an den Pins in Figur 2 nicht unbedingt nötig sind. Es ist statt dessen möglich die Bezeichner direkt auf die Pins anzuwenden.

	
Wir nehmen nun an es gibt einen weiteren vierten Verbinder der mit CONN_4 benannt ist. Und, aus welchem Grund auch immer, das Bezeichnen muss geringfügig anders erfolgen (b1, b2, b3, b4). Nun möchten wir Bus a mit Bus b mit den Pins 1:1 verbinden. Wir möchten dies ohne Pin Bezeichner erledigen (was auch möglich ist), statt dessen wird die Bus Verbindung bezeichnet mit einer Bezeichnung pro Bus.

	
Verbinden und Bezeichnen Sie CONN_4 wie zuvor erklärt nach der Bezeichnungsmethode. Benennen Sie die Pins b1, b2, b3 und b4. Verbinden Sie die Pins zu einer Serie Elektr. Verbindung an Buseingang führen durch das Icon [image: Elektr. Verbindung an Buseingang führen] und mit einer Bus Verbindung unter Benutzung des Icons [image: Einen Bus verlegen]. Siehe Figur 4.

	
Setzen Sie einen Bezeichner (benutzen Sie die Taste [l]) auf den Bus von CONN_4 und benennen diesen b[1..4].

	
Put a label (press [l]) on the previous bus and name it a[1..4].

	
Was wir nun tun können ist den Bus a[1..4] mit dem Bus b[1..4] mit einer Busverbindung durch den Button [image: Einen Bus verlegen] zu verbinden.

	
Wenn die beiden Busse verbunden werden dann wird Pin a1 automatisch mit Pin b1, a2 mit b2 und so weiter verbunden. Figur 4 zeigt wie das finale Ergebnis aussieht.

Anmerkung
Die Funktion Wiederhole letzten Vorgang durch die [Einfg] Taste kann hier wieder benutzt werden um die periodischen Einfügungen zu tätigen. Zum Beispiel, die kurzen Verbindungen zu allen Pins in Figur 2, Figur 3 und Figur 4 wurden mit dieser Funktion erstellt.


	
Die Funktion Wiederhole letzten Vorgang durch die [Einfg] Taste wurde ebenfalls mehrfach benutzt um die verschiedenen Serien Elektr. Verbindung an Buseingang führen mit Hilfe des Buttons [image: Elektr. Verbindung an Buseingang führen].

[image: gsik_bus_connection_png]





Kapitel 5. Gedruckte Schaltungen (Leiterplatten) entwerfen



Es ist an der Zeit die Netzlistendatei zu benutzen um eine Leiterplatte (PCB; Printed Ciruit Board) zu erstellen. Dies wird mit dem Pcbnew Tool durch geführt.
Anmerkung
If you used Update PCB from Schematic from Eeschema you don’t need the netlist and step 5. You can now drop the footprints into the board as in steps 6 and 7, then enter sheet information and design rules with steps 2…4.


5.1. Benutzung von Pcbnew



	
From the KiCad project manager, click on the Pcb layout editor icon [image: pcbnew_png]. You can also use the corresponding toolbar button from Eeschema. The Pcbnew window will open. If you get a message saying that a *.kicad_pcb file does not exist and asks if you want to create it, just click Yes.

	
Begin by entering some schematic information. Click on the Page settings icon [image: sheetset_png] on the top toolbar. Set the appropriate paper size (A4,8.5x11 etc.) and title as Tutorial1.

	
It is a good idea to start by setting the clearance and the minimum track width to those required by your PCB manufacturer. In general you can set the clearance to 0.25 and the minimum track width to 0.25. Click on the Setup → Design Rules menu. If it does not show already, click on the Net Classes Editor tab. Change the Clearance field at the top of the window to 0.25 and the Track Width field to 0.25 as shown below. Measurements here are in mm.

[image: Design Rules Fenster]


	
Click on the Global Design Rules tab and set Minimum track width to 0.25. Click the OK button to commit your changes and close the Design Rules Editor window.

	
Now we will import the netlist file if you created one. Click on the Read netlist icon [image: netlist_png] on the top toolbar. The netlist file tutorial1.net should be selected in the Netlist file field if it was created from Eeschema. Click on Read Current Netlist. Then click the Close button.

	
All components should now be visible. They are selected and follow the mouse cursor.

	
Move the components to the middle of the board. If necessary you can zoom in and out while you move the components. Click the left mouse button.

	
All components are connected via a thin group of wires called ratsnest. Make sure that the Show/hide board ratsnest button [image: general_ratsnest_png] is pressed. In this way you can see the ratsnest linking all components.

	
You can move each component by hovering over it and pressing [m]. Click where you want to place them. Alternatively you can select a component by clicking on it and then drag it. Press [r] to rotate a component. Move all components around until you minimise the number of wire crossovers.

[image: gsik_tutorial1_080_png]


	
Note how one pin of the 100 ohm resistor is connected to pin 6 of the PIC component. This is the result of the labelling method used to connect pins. Labels are often preferred to actual wires because they make the schematic much less messy.

	
Now we will define the edge of the PCB. Select the Edge.Cuts layer from the drop-down menu in the top toolbar. Click on the Add graphic lines icon [image: add_dashed_line_png] on the right toolbar. Trace around the edge of the board, clicking at each corner, and remember to leave a small gap between the edge of the green and the edge of the PCB.

[image: Wähle den Edgs.Cut Layer aus.]


	
Verbinden Sie alle Bauteile miteinander außer dem Netz GND. Wir werden später alle GND Verbindungen in einem Schritt erstellen in dem wir einen ausgefüllten Flächenbereich auf der unteren Lage (B.Cu → Bottom Copper genannt) erstellen.

	
Wie müssen nun die Kupfer Lage auswählen auf der wir arbeiten wollen. Wählen Sie F.Cu (PgUp) im Auswahlmenü der oberen Toolbar. Das ist die Front Top Kupfer Lage, also die Lage der Platinen Vorderseite auf die Sie direkt schauen.

[image: Wähle den Front top Copper Layer aus.]


	
If you decide, for instance, to do a 4 layer PCB instead, go to Setup → Layers Setup and change Copper Layers to 4. In the Layers table you can name layers and decide what they can be used for. Notice that there are very useful presets that can be selected via the Preset Layer Groupings menu.

	
Click on the Route tracks icon [image: add_tracks_png] on the right toolbar. Click on pin 1 of J1 and run a track to pad R2. Double-click to set the point where the track will end. The width of this track will be the default 0.250 mm. You can change the track width from the drop-down menu in the top toolbar. Mind that by default you have only one track width available.

[image: pcbnew_select_track_width_png]


	
If you would like to add more track widths go to: Setup → Design Rules → Global Design Rules tab and at the bottom right of this window add any other width you would like to have available. You can then choose the widths of the track from the drop-down menu while you lay out your board. See the example below (inches).

[image: custom_tracks_width_png]


	
Alternatively, you can add a Net Class in which you specify a set of options. Go to Setup → Design Rules → Net Classes Editor and add a new class called power. Change the track width from 8 mil (indicated as 0.0080) to 24 mil (indicated as 0.0240). Next, add everything but ground to the power class (select default at left and power at right and use the arrows).

	
If you want to change the grid size, Right click → Grid. Be sure to select the appropriate grid size before or after laying down the components and connecting them together with tracks.

	
Wiederholen Sie diesen Prozess bis alle Verbindungen, außer Pin 3 von J1, verlegt sind. Ihr Board sollte aussehen wie im folgenden Beispiel.

[image: gsik_tutorial1_090_png]


	
Let’s now run a track on the other copper side of the PCB. Select B.Cu in the drop-down menu on the top toolbar. Click on the Route tracks icon [image: add_tracks_png]. Draw a track between pin 3 of J1 and pin 8 of U1. This is actually not necessary since we could do this with the ground plane. Notice how the colour of the track has changed.

	
Verbindung von Pin A und Pin B mit einem Wechsel der Lage. Es ist auch möglich die Lage beim Verlegen einer Leiterbahn mit Hilfe einer Durchkontaktierung (DoKu, auch Via genannt) zu wechseln. Wenn Sie eine Leiterbahn auf der oberen Kupfer Lage verlegen können Sie nach einem Rechtsklick Durchgehende  DoKu platzieren auswählen, oder auch die Taste [v] betätigen, um eine Durchkontaktierung einzufügen. Dies erstellt eine Durchkontaktierung auf die untere Kupfer Lage und führt die Leiterbahnverlegung auf der Unterseite fort.

[image: place_a_via_png]


	
When you want to inspect a particular connection you can click on the Highlight net icon [image: net_highlight_png] on the right toolbar. Click on pin 3 of J1. The track itself and all pads connected to it should become highlighted.

	
Now we will make a ground plane that will be connected to all GND pins. Click on the Add filled zones icon [image: add_zone_png] on the right toolbar. We are going to trace a rectangle around the board, so click where you want one of the corners to be. In the dialogue that appears, set Default pad connection to Thermal relief and Outline slope to H,V and 45 deg only and click OK.

	
Trace around the outline of the board by clicking each corner in rotation. Finish your rectangle by clicking the first corner second time. Right click inside the area you have just traced. Click on Zones→'Fill or Refill All Zones'. The board should fill in with green and look something like this:

[image: gsik_tutorial1_100_png]


	
Run the design rules checker by clicking on the Perform design rules check icon [image: drc_png] on the top toolbar. Click on Start DRC. There should be no errors. Click on List Unconnected. There should be no unconnected items. Click OK to close the DRC Control dialogue.

	
Speichern Sie Ihre Datei durch klicken auf Datei → Speichern. Um Ihr Board in 3D zu betrachten klicken Sie auf Ansicht → 3D Viewer.

[image: pcbnew_3d_viewer_png]


	
Benutzen Sie die Maus um die Platine zu rotieren.

	
Ihre Leiterplatte ist nun fertig. Um die Platine fertigen lassen zu können müssen Sie noch Gerber Dateien von Ihrer Platine erstellen.




5.2. Erstellung von Gerber Dateien



Wenn Sie das Erstellen der Leiterplatte abgeschlossen haben können Sie Gerber Dateien für jede Lage erstellen und zu Ihren favorisierten PCB Hersteller schicken, der die Leiterplatte dann für Sie produzieren kann.
	
Öffne unter Kicad den _Pcbnew_board Editor.

	
Click on File → Plot. Select Gerber as the Plot format and select the folder in which to put all Gerber files. Proceed by clicking on the Plot button.

	
Um eine Bohrdatei zu erstellen gehen Sie wieder in Pcbnew und wählen wieder Datei → Plotten. Die Standard Einstellungen sind in Ordnung, klicken Sie auf den Button Bohrdatei generieren.

	
Dies sind die Lagen die Sie selektieren müssen um eine typische 2-lagige Leiterplatte zu erstellen:



	Layer 	KiCad Layer Name 	Default Gerber Extension
    	"Use Protel filename extensions" is enabled
	Bottom Layer
	B.Cu
	.GBR
	.GBL

	Top Layer
	F.Cu
	.GBR
	.GTL

	Top Overlay
	F.SilkS
	.GBR
	.GTO

	Bottom Solder Resist
	B.Mask
	.GBR
	.GBS

	Top Solder Resist
	F.Mask
	.GBR
	.GTS

	Edges
	Edge.Cuts
	.GBR
	.GM1




5.3. Benutzen von GerbView



	
To view all your Gerber files go to the KiCad project manager and click on the GerbView icon. On the drop-down menu or in the Layers manager select Graphic layer 1. Click on File → Open Gerber file(s) or click on the icon [image: gerber_file_png]. Select and open all generated Gerber files. Note how they all get displayed one on top of the other.

	
Open the drill files with File → Open Excellon Drill File(s).

	
Use the Layers manager on the right to select/deselect which layer to show. Carefully inspect each layer before sending them for production.

	
The view works similarly to Pcbnew. Right click inside the view and click Grid to change the grid.




5.4. Automatisches Routen mit FreeRouter



Routing a board by hand is quick and fun, however, for a board with lots of components you might want to use an autorouter. Remember that you should first route critical traces by hand and then set the autorouter to do the boring bits. Its work will only account for the unrouted traces. The autorouter we will use here is FreeRouting.
Anmerkung
FreeRouting is an open source java application. Currently FreeRouting exists in several more or less identical copies which you can find by doing an internet search for "freerouting". It may be found in source only form or as a precompiled java package.

	
From Pcbnew click on File → Export → Specctra DSN and save the file locally. Launch FreeRouter and click on the Open Your Own Design button, browse for the dsn file and load it.

	
FreeRoute besitzt Features die KiCad aktuell noch nicht unterstützt, für beide Arten des Routing; manuell oder automatisch. FreRouter arbeitet in zwei Schritten: Durchführung des Routings und danach die Optimierung des Routings. Eine komplette Optimierung kann eine sehr lange Zeit in Anspruch nehmen, dies können Sie aber zu jeder Zeit unterbrechen wenn nötig.

	
Sie können das automatische Routing starten indem Sie auf den Button Autorouter in der oberen Toolbar klicken. Die untere Leiste gibt Ihnen Informationen über den fortschreitenden Routing Prozess. Wenn die Anzahl von Pass über 30 geht wird der Autorouter das Board nicht weiter bearbeiten können. Ziehen Sie die Komponenten mehr auseinander oder verändern Sie die Lage durch Rotieren der Bauteile und starten das Autorouting neu. Durch Veränderung der Bauteilpositionen lassen sich meistens die Anzahl von Netzkreuzungen der einzelnen Netze verringern.

	
Ein Klick auf die linke Maustaste lässt das automatische Routing stoppen und beginnt den automatischen Optimierungsprozess.

	
Klicken Sie auf Datei → Export Specctra Session File und speichern die Datei mit der .ses Erweiterung. Die Freerouter Regel Dateien müssen Sie nicht speichern.

	
Back to Pcbnew. You can import your freshly routed board by clicking on File → Import → Spectra Session and selecting your .ses file.



If there is any routed trace that you do not like, you can delete it and re-route it again, using [Delete] and the routing tool, which is the Route tracks icon [image: Add Track icon] on the right toolbar.

Kapitel 6. Vorwärts Annotation in KiCad



Wenn Sie Ihren elektronischen Schaltplan vervollständigt, die Footprintzweisungen, das Boardlayout und die Gerber Dateien erstellt haben, dann können Sie alles zu einem Leiterplatten Hersteller schicken damit Ihr Board Realität werden kann.
Oft stellt sich heraus, dass dieser geradlinige Workflow nicht so unidirektional ist wie eben aufgezählt. Zum Beispiel, wenn Sie Ihr Board verändern/erweitern wollen für das Sie den kompletten Arbeitsablauf schon durchschritten haben, dann ist es nötig Bauteile zu verschieben, diese gegen andere Bauteile zu tauschen, Footprints zu verändern und noch anderes mehr. Beim Durchführen dieser Modifikationen möchten Sie nicht das gesamte Board komplett neu Routen müssen. Statt dessen möchten Sie wohl folgendes tun:
	
Nehmen wir an Sie möchten den hypothetischen Verbinder CON1 mit CON2 tauschen.

	
Sie haben einen vollständigen Schaltplan und eine vollendete Leiterplatte.

	
Vom KiCad Projektmanager aus starten Sie Eeschema und führen die Veränderungen im Schaltplan durch, löschen Sie CON1 und fügen Sie CON2 hinzu. Speichern Sie den Schaltplan durch Klicken auf das Icon [image: Schaltplanprojekt speichern] und klicken Sie dann auf das Icon Netzliste erstellen [image: Netzliste erstellen] in der oberen Toolbar.

	
Speichern Sie die Netzliste unter dem vorgegebenen Dateinamen, Sie müssen die alte Datei überschreiben.

	
Weisen Sie nun CON2 einen Footprint zu. Klicken Sie auf das Icon Starte Cvpcb [image: Starte Cvpcb] in der oberen Toolbar. Weisen Sie dem neuem Bauteil CON2 einen Footprint hinzu. Die restlichen Bauteile haben alle noch eine gültige vorherige Footprint Zuweisung. Schließen Sie Cvpcb.

	
Zurück im Schaltplan Editor, speichern Sie das Projekt durch aufrufen von Datei → Schaltplanprojekt speichern. Schließen Sie den Schaltplaneditor.

	
Klicken Sie im KiCad Projektmanager auf das Icon Pcbnew [image: Pcbnew]. Das Fenster von Pcbnew öffnet sich.

	
Das alte, schon geroutete Board sollte sich automatisch öffnen. Importieren Sie nun die neue Netzlistendatei. Klicken Sie auf das Icon Netzliste einlesen in der oberen Toolbar.

	
Klicken Sie auf den Button Durchsuchen, wählen Sie im Dateidialog die Netzlistendatei aus und klicken Sie auf auf Aktuelle Netzliste einlesen. Schließen Sie den Dialog.

	
An diesem Punkt sollten Sie das Leiterplatten Layout mit allen vorherigen schon platzierten Komponenten sehen. In der Nähe der vorhandenen Platine sehen Sie neue noch nicht geroutete Bauteile, in unserem Fall CON2. Selektieren Sie CON2 und verschieben Sie das Bauteil an den vorgesehenen Platz.

	
Platzieren Sie CON2 und erstellen die Leiterzüge. Wenn fertig dann speichern Sie und erstellen erneut die Gerber Dateien wie zuvor.



Der hier beschriebene Prozess kann einfach so oft wiederholt werden wie nötig. Zusätzlich zur hier beschriebenen Vorwärts Annotation gibt es noch eine andere Methode die als Rückwärts Annotation bekannt ist. Diese Methode erlaubt es Ihnen Veränderungen zuerst am Leiterplatten Design durchzuführen und diese dann zurück in den Schaltplan zu führen. Jedoch ist die Rückwärts Annotation nicht so zweckdienlich und deswegen nicht weiter hier beschrieben.

Kapitel 7. Make schematic symbols in KiCad



Sometimes a symbol that you want to place on your schematic is not in a KiCad library. This is quite normal and there is no reason to worry. In this section we will see how a new schematic symbol can be quickly created with KiCad. Nevertheless, remember that you can always find KiCad components on the Internet.
In KiCad, a symbol is a piece of text that starts with DEF and ends with ENDDEF. One or more symbols are normally placed in a library file with the extension .lib. If you want to add symbols to a library file you can just use the cut and paste commands of a text editor.

7.1. Benutzen des Bauteileditors



	
Wir können den Bibliothekseditor benutzen (Teil von Eeschema) um neue Bauteile zu erstellen. In unserem Projektordner tutorial1 erstellen wir einen Ordner library. In diesem Ordner speichern wir die neue Bibliothek myLib.lib ab sobald wir unser neues Bauteil kreiert haben.

	
Now we can start creating our new component. From KiCad, start Eeschema, click on the Library Editor icon [image: libedit_png] and then click on the New component icon [image: new_component_png]. The Component Properties window will appear. Name the new component MYCONN3, set the Default reference designator as J, and the Number of units per package as 1. Click OK. If the warning appears just click yes. At this point the component is only made of its labels. Let’s add some pins. Click on the Add Pins icon [image: pin_png] on the right toolbar. To place the pin, left click in the centre of the part editor sheet just below the MYCONN3 label.

	
In the Pin Properties window that appears, set the pin name to VCC, set the pin number to 1, and the Electrical type to Power input then click OK.

[image: Pin Eigenschaften]


	
Platzieren Sie den Pin durch Klicken an der Stelle wo er gezeichnet werden soll, direkt unter dem Bezeichner MYCONN3.

	
Wiederholen Sie den Schritt, dieses mal mit dem Pinnamen INPUT, der Pinnummer 2 und dem Elektrischer Typ Passive.

	
Wiederholen Sie den Schritt ein drittes Mal, der Pinname soll nun GND sein, die Pinnummer ist 3 und der Elektrischer Typ ist ebenfalls wieder Passive. Verteilen Sie die Pins gleichmäßig übereinander. Der Bauteil Bezeichner MYCONN3 sollte im mittig in der vertikalen Achse der Zeichnung liegen.

	
Als nächstes zeichnen Sie einen Umriss um das Bauteil. Klicken Sie dazu auf das Icon Rechteck hinzufügen [image: Rechteck hinzufügen]. Wir wollen ein Rechteck zeichnen was die Pins einschließt wie nachfolgend zu sehen. Um dies zu erstellen klicken Sie zuerst die linke obere Ecke des Rechtecks an und ziehen das Rechteck durch anfahren der unteren rechten Ecke auf. Klicken Sie wieder wenn die untere rechte Ecke des Rechtecks erreicht ist.

[image: gsik_myconn3_l_png]


	
Wenn Sie das Rechteck mit der Farbe Gelb ausfüllen wollen öffnen Sie im Fenster Eeschema den Menüpunkt Einstellungen → Einstellungen des Schaltplaneditors den Reiter Farben und wählen in der Gruppe Komponente für Gehäusehintergrund zum Beispiel die Farbe Hellgelb.

	
Speichern Sie das Bauteil in Ihrer Bibliothek myLib.lib. Klicken Sie dazu auf das Icon Gegenwärtiges Bauteil in einer neuen Bibliothek speichern [image: Gegenwärtiges Bauteil in einer neuen Bibliothek speichern]. Öffnen Sie den zuvor erstellten Ordner tutorial1/library/ und speichern Sie die Bibliothek unter dem Namen myLib.lib.

	
Öffnen Sie Einstellungen → Bauteil Bibliotheken und fügen Sie in Benutzerdefinierter Suchpfad den Ordner tutorial1/library/ hinzu und myLib.lib zu den Bauteilebibliotheksdateien.

	
Klicken Sie auf das Icon Arbeitsbibliothek auswählen [image: Arbeitsbibliothek auswählen]. Im Auswahlfenster der Elemente wählen Sie myLib und klicken auf OK. Beachten Sie das in der Fensterzeile nun die aktuell gewählte Bibliothek angezeigt wird, es sollte dort nun [/Pfad/zu]/myLib.lib zu lesen sein.

	
Klicken Sie auf das Icon Gegenwärtiges Bauteil in aktueller Bibliothek aktualisieren [image: Gegenwärtiges Bauteil in aktueller Bibliothek aktualisieren] in der oberen Toolbar. Speichern Sie alle neuen Änderungen durch anklicken des Icons Aktuelle Bauteilbibliothek speichern [image: Aktuelle Bauteilbibliothek speichern] in der oberen Toolbar. Bestätigen Sie die Rückfrage mit Ja. Das neue Bauteil ist nun fertig und in der Bibliothek enthalten welche im Fenstertitel benannt ist.

	
Sie können nun den Bauteilbibliothekseditor schließen. Sie werden wieder in den Schaltplaneditor zurück gelangen. Das neue Bauteil ist in der Bibliothek myLib auswählbar.

	
Sie können jede Bibliothek Datei.lib auswählbar machen indem Sie diese in den Bibliothekssuchpfad hinzufügen. In Eeschema öffnen Sie Einstellungen → Bauteil Bibliotheken und fügen Sie in Benutzerdefinierter Suchpfad den Ordner der Bibliothek hinzu und Datei.lib zu den Bauteilebibliotheksdateien.




7.2. Export, Import und Verändern von Bauteilkomponenten



Anstatt mit einer leeren neuen Bibliothek zu starten ist es meistens einfacher mit einer vorhandenen Bibliothek zu beginnen und diese zu verändern. In diesem Abschnitt werden wir sehen wie man ein Bauteil aus der Standard Bibliothek device in eine eigene Bibliothek exportiert und dann verändert.
	
Im KiCad Projektmanager, starten Sie Eeschema und klicken auf das Icon Bibliothekseditor - Bauteile erstellen oder bearbeiten [image: Bibliothekseditor - Bauteile erstellen oder bearbeiten], klicken Sie auf das Icon Arbeitsbibliothek wählen [image: Arbeitsbibliothek wählen] und wählen die Bibliothek device. Klicken Sie nun auf das Icon Bauteil aus der gegenwärtigen Bibliothek laden [image: Bauteil aus der gegenwärtigen Bibliothek laden] und importieren RELAY_2RT.

	
Klicken Sie auf das Icon Bauteil exportieren [image: Bauteil exportieren], navigieren in den Ordner library/ und speichern die neue Bibliothek unter dem Namen myOwnLib.lib.

	
Sie können dieses Bauteil und die komplette Bibliothek myOwnLib.lib benutzen indem Sie diese zum Bibliothekspfad hinzufügen. In Eeschema, gehen Sie zu Einstellungen → Bauteil Bibliotheken und fügen Sie in Benutzerdefinierter Suchpfad den Ordner der Bibliothek hinzu und myOwnLib.lib zu den Bauteilebibliotheksdateien.

	
Klicken Sie auf das Icon Arbeitsbibliothek auswählen [image: Arbeitsbibliothek auswählen]. Im Auswahlfenster der Elemente wählen Sie myOwnLib und klicken auf OK. Beachten Sie das in der Fensterzeile nun die aktuell gewählte Bibliothek angezeigt wird, es sollte dort nun [/Pfad/zu]/myOwnLib.lib zu lesen sein.

	
Klicken Sie auf das Icon Bibliothekseditor - Bauteile erstellen oder bearbeiten [image: Bibliothekseditor - Bauteile erstellen oder bearbeiten] und importieren RELAY_2RT.

	
Sie können nun das Bauteil gemäß Ihren Vorstellungen verändern. Bewegen Sie den Mauszeiger über den Bezeichner RELAY_2RT, betätigen Sie die Taste [e] und benennen diesen in MY_RELAY_2RT um.

	
Klicken Sie auf das Icon Gegenwärtiges Bauteil in aktueller Bibliothek aktualisieren [image: Gegenwärtiges Bauteil in aktueller Bibliothek aktualisieren] in der oberen Toolbar. Speichern Sie alle neuen Änderungen durch anklicken des Icons Aktuelle Bauteilbibliothek speichern [image: Aktuelle Bauteilbibliothek speichern] in der oberen Toolbar.




7.3. Erstellen von Schaltplansymbolen mit quicklib



In dieser Sektion wird ein alternativer Weg zum Erstellen des Schaltplansymbols für MYCONN3 (siehe MYCONN3 weiter oben) unter Benutzung des Internet Tools quicklab gezeigt.
	
Öffnen Sie die quicklab Webseite: http://kicad.rohrbacher.net/quicklib.php

	
Fügen Sie folgende Informationen in die Felder ein: Component name: MYCONN3 Reference Prefix: J Pin Layout Style: SIL Pin Count, N: 3

	
Klicken Sie auf den Assign Pins Button. Fügen Sie folgende Informationen in die Felder ein: Pin 1: VCC Pin 2: Input Pin 3: GND. Type: Passive für alle drei Pins.

	
Klicken Sie auf das Icon Preview und, wenn Sie zufrieden sind, klicken Sie auf Build Library Component. Laden Sie die Datei herunter und speichern Sie diese unter tutorial1/library/myQuickLib.lib.. Sie sind fertig!

	
Betrachten Sie das Ergebnis in KiCad. Im KiCad Projektmanager, starten Sie Eeschema, klicken auf das Icon Bibliothekseditor - Bauteile erstellen oder bearbeiten [image: Bibliothekseditor - Bauteile erstellen oder bearbeiten], klicken nun auf das Icon Bauteil importieren [image: Bauteil importieren] und öffnen den Ordner tutorial1/library/ und öffnen myQuickLib.lib.

[image: gsik_myconn3_quicklib_png]


	
Sie können dieses Bauteil und die gesamte Bibliothek myQuickLib.lib auswählbar machen indem Sie diese in den KiCad Bibliothekssuchpfad hinzufügen. In Eeschema öffnen Sie Einstellungen → Bauteil Bibliotheken und fügen Sie in Benutzerdefinierter Suchpfad den Ordner library hinzu und myQuickLib.lib zu den Bauteilebibliotheksdateien.



Wie Sie sich vorstellen können kann diese Methode eine Bauteilbibliothek zu erstellen sehr effektiv sein wenn Sie Bauteile mit einer hohen Pin Anzahl erstellen wollen.

7.4. Erstellen eines Bauteils mit zahlreichen Pins



Im Abschnitt Erstellen von Schaltplansymbolen mit quicklib haben wir gesehen wie man Schaltplansymbole mit quicklib, einem Web basierten Tool, erstellen kann. Vereinzelt besteht die Notwendigkeit Schaltplansymbole mit einer sehr hohen Anzahl an Pins (mehrere hundert) zu erstellen. Dies ist keine besonders schwierige Aufgabe in KiCad.
	
Stellen Sie sich vor Sie möchten ein Bauteil mit 50 Pins erstellen. Es ist eine übliche Praxis diese aus mehrfachen Zeichnungen mit kleinerer Pin Anzahl zu erstellen, zum Beispiel zwei Zeichnungen mit jeweils 25 Pins. Diese Komponentendarstellung ermöglicht einen einfachen Pin Anschluss.

	
Der einfachste Weg unser Bauteil zu erstellen ist, zwei separate 25-Pin Bauteile mit quicklib zu erzeugen, die Pin Nummerierung mit einem Python Skript anzupassen und final die beiden Bauteile durch Copy&Paste in ein einziges DEF und ENDEFF Bauteil zu mergen.

	
Hier ist ein Python Beispiel Skript welches in Verbindung mit einer Datei in.txt und out.txt benutzt werden kann um die Zeile X PIN1 1 -750 600 300 R 50 50 1 1 I in X PIN26 26 -750 600 300 R 50 50 1 1 I abzuändern. Dies wird auf alle Zeilen in der Datei in.txt angewendet.



Einfaches Skript. 

#!/usr/bin/env python
''' simple script to manipulate KiCad component pins numbering'''
import sys, re
try:
    fin=open(sys.argv[1],'r')
    fout=open(sys.argv[2],'w')
except:
    print "oh, wrong use of this app, try:", sys.argv[0], "in.txt out.txt"
    sys.exit()
for ln in fin.readlines():
    obj=re.search("(X PIN)(\d*)(\s)(\d*)(\s.*)",ln)
if obj:
    num = int(obj.group(2))+25
    ln=obj.group(1) + str(num) + obj.group(3) + str(num) + obj.group(5) +'\n'
    fout.write(ln)
fin.close(); fout.close()
#
# for more info about regular expression syntax and KiCad component generation:
# http://gskinner.com/RegExr/
# http://kicad.rohrbacher.net/quicklib.php


	
Beim Zusammenführen der zwei Bauteile in eines ist es nötig den Bibliothekseditor von Eeschema zu benutzen um das erste Bauteil zuerst zu bewegen damit das Zweite nicht vor dem Ersten eingefügt wird. Folgend ein Beispiel einer finalen *.lib Datei und deren Darstellung in Eeschema.



Inhalt einer *.lib Datei. 

EESchema-LIBRARY Version 2.3
#encoding utf-8
# COMP
DEF COMP U 0 40 Y Y 1 F N
F0 "U" -1800 -100 50 H V C CNN
F1 "COMP" -1800 100 50 H V C CNN
DRAW
S -2250 -800 -1350 800 0 0 0 N
S -450 -800 450 800 0 0 0 N
X PIN1 1 -2550 600 300 R 50 50 1 1 I

...

X PIN49 49 750 -500 300 L 50 50 1 1 I
ENDDRAW
ENDDEF
#End Library


[image: gsik_high_number_pins_png]

	
Das hier gezeigte Python Skript ist ein sehr mächtiges Tool um Pin Nummern und Pin Bezeichnungen zu manipulieren. Dessen Mächtigkeit stammt aus dem verborgenen und verblüffenden Gebrauch von Regular Expressions: http://gskinner.com/RegExr/.




Kapitel 8. Erstellen eines Footprints



Unlike other EDA software tools, which have one type of library that contains both the schematic symbol and the footprint variations, KiCad .lib files contain schematic symbols and .kicad_mod files contain footprints. Cvpcb is used to map footprints to symbols.
Wie .lib Dateien sind auch .kicad_mod Dateien reine Textdateien die einzelne oder mehrere Elemente enthalten können.
In KiCad ist eine umfangreiche Footprint Bibliothek enthalten, aber gelegentlich finden Sie vielleicht in der KiCad Bibliothek nicht den Footprint den Sie benötigen. Hier sind die nötigen Schritte um einen neuen PCB Footprint in KiCad zu erstellen:

8.1. Benutzen des Footprint Editors



	
Im KiCad Projektmanager starten Sie das Pcbnew Tool. Klicken Sie auf das Icon Footprinteditor öffnen [image: Footprinteditor öffnen] in der oberen Toolbar. Dies öffnet den Footprint Editor.

	
We are going to save the new footprint MYCONN3 in the new footprint library myfootprint. Create a new folder myfootprint.pretty in the tutorial1/ project folder. Click on the Preferences → Footprint Libraries Manager and press Append Library button. In the table, enter "myfootprint" as Nickname, enter "${KIPRJMOD}/myfootprint.pretty" as Library Path and enter "KiCad" as Plugin Type. Press OK to close the PCB Library Tables window. Click on the Select active library icon [image: open_library_png] on the top toolbar. Select the myfootprint library.

	
Klicken Sie auf das Icon Neuer Footprint [image: Neuer Footprint] in der oberen Toolbar. Geben Sie MYCONN3 als Footprintname ein. In der Mitte des Bildschirms erscheint der Bezeichner MYCONN3. Unter dem Bezeichner sehen Sie das REF* Label. Klicken Sie mit der rechten Maustaste auf MYCONN3 und verschieben Sie dieses Element über REF*. Klicken Sie mit der rechten Maustaste auf REF__*, wählen Sie Text verändern und benennen die Referenz nach SMD um. Setzen Sie die Darstellung auf Nicht sichtbar.

	
Betätigen Sie das Icon Pads hinzufügen [image: Pads hinzufügen] in der rechten Toolbar. Klicken Sie in das Arbeitsblatt um einen Pad hinzuzufügen. Machen Sie einen Rechtsklick auf das Pad und wählen Pad editieren. Alternativ können Sie die Taste [e] betätigen.

[image: Pad Eigenschaften]


	
Setzen Sie Padnummer auf 1, die Form auf Rechteck, den Padtyp auf SMD, die Größe X zu 0,4 und die Größe Y zu 0,8. Klicken Sie auf OK. Klicken Sie wieder auf Pads hinzufügen und platzieren zwei weitere Pads.

	
Wenn Sie die Rastergröße ändern wollen klicken Sie mit der rechten Maustaste auf das Arbeitsblatt und wählen Rasterauswahl. Bedenken Sie, dass Sie die richtige Rastergröße auszuwählen bevor Sie Bauteile platzieren.

	
Verschieben Sie die Bezeichner MYCONN3 und SMD so weit das es so aussieht wie oberhalb zu sehen.

	
Beim Platzieren von Pads ist es oft nötig Abstände mit relativen Maßen zu messen. Platzieren Sie den Cursor an der Stelle von der ausgehend der temporäre Nullpunkt der Messung sein soll und betätigen die Leertaste. Beim Bewegen der Maus können Sie in der Fußleiste den relativen Abstand zum zuvor gesetzten Bezugspunkt sehen. Betätigen Sie die Leertaste wiederholt um einen neuen Nullpunkt zu setzen.

	
Fügen Sie nun dem Footprint einen Umriss hinzu. Klicken Sie auf das Icon Grafische Linie oder Polygon hinzufügen [image: Grafische Linie oder Polygon hinzufügen] in der rechten Toolbar. Ziehen Sie eine Linie um das Bauteil herum.

	
Klicken Sie auf das Icon Footprint in aktiver Bibliothek speichern [image: Footprint in aktiver Bibliothek speichern] in der oberen Toolbar, behalten Sie den Namen MYCONN3 bei.




Kapitel 9. Informationen über die Portabilität von KiCad Projektdateien



Welche Daten müssen Sie jemanden übersenden damit diese Person Ihr KiCad Projekt laden und benutzen kann?
Wenn Sie ein KiCad Projekt mit jemand anderen teilen möchten ist es wichtig, dass Sie die Schaltplandatei .sch, die Platinendatei .kicad_pcb, die Projektdatei .pro und die Netzlistendatei .net zusammen mit den Bauteil spezifischen Dateien für Schaltplansymbole (.lib) und für die Footprints (.kicad_mod) zusammen weiter geben. Nur so haben andere Personen die komplette Freiheit und Kontrolle den Schaltplan und die Platine zu verändern.
Mit den KiCad Schaltplänen zusammen werden auch die .lib Dateien benötigt die die Schaltplansymbole enthalten. Diese Bibliotheken müssen durch die Eeschema Einstellungen geladen werden. Auf der anderen Seite, mit den Platinen (die .kicad_pcb Dateien) können auch die Footprintdateien innerhalb der .kicad_pcb Dateien gespeichert werden. Sie können jemanden anderen nur die .kicad_pcb Datei geben und es sollte anderen möglich sein die Platine betrachten und bearbeiten zu können. Aber, wenn andere Personen Bauteile von einer Netzeliste laden wollen müssen die Footprint Bibliotheken (.kicad_mod Dateien) vorhanden und über die Einstellungen von Pcbnew geladen sein, analog zu den Schaltplansymbolen in Eeschema. Ebenfalls ist es nötig die .kicad_mod Dateien über die Einstellungen von Pcbnew zu laden damit für diese Footprints in Cvpcb gezeigt werden.
Wenn Ihnen jemand eine .kicad_pcb Datei mit den Footprints schickt und Sie möchten diese in einer anderen Platine benutzen, dann können Sie den Footprint Editor öffnen, ein Footprint aus der aktueller Platine laden und diesen in eine andere Footprint Bibliothek abspeichern oder exportieren. Sie können auch alle Footprints aus einer .kicad_pcb Datei mit einem mal exportieren indem Sie Pcbnew → Datei → Footprints archivieren → Neue Bibliothek erstellen und Footprints speichern aufrufen. Dies erstellt eine neue .kicad_mod Datei mit allen Footprints der Platine.
Als Schlusswort, wenn die Platine das einzige ist was Sie weiter geben wollen, dann ist die Platinendatei .kicad_pcb ausreichend. Wenn Sie aber anderen Personen alle Möglichkeiten geben wollen Ihren Schaltplan, die Bauteile und die Platine ändern zu können dann ist es sehr sinnvoll das Sie den kompletten Projektordner als Zip Datei komprimieren und senden:
tutorial1/
|-- tutorial1.pro
|-- tutorial1.sch
|-- tutorial1.kicad_pcb
|-- tutorial1.net
|-- library/
|   |-- myLib.lib
|   |-- myOwnLib.lib
|   \-- myQuickLib.lib
|
|-- myfootprint.pretty/
|   \-- MYCONN3.kicad_mod
|
\-- gerber/
    |-- ...
    \-- ...

Kapitel 10. Mehr KiCad Dokumentation



Dies war ein kurzer Guide durch die meisten Funktionen von KiCad. Für noch mehr detailliertere Instruktionen besuchen Sie die Hilfe Dateien der jeweiligen KiCad Module die über den Menüpunkt Hilfe aufgerufen werden können. Klicken Sie jeweils auf Hilfe → [KiCad Modul]-Benutzerhandbuch.
KiCad kommt mit einem Set von multilingualen Benutzerhandbüchern für alle vier Software Komponenten.
Die englischen Versionen von allen KiCad Modulen wird mit KiCad verteilt.
Als Ergänzung zu den Benutzerhandbüchern wird KiCad mit diesem Tutorial verteilt, welches auch in andere Sprachen übersetzt worden ist. All die verschiedenen Versionen dieses Dokuments werden kostenfrei mit allen aktuellen Versionen von KiCad verteilt. Dieses Tutorial und auch die Handbücher sollten zusammen mit der Version von KiCad passend zu Ihrer Plattform verteilt werden.
Zum Beispiel, unter Linux sind die typischen Orte die folgenden Verzeichnisse, abhängig von der genauen Distribution:
/usr/share/doc/kicad/help/de/
/usr/local/share/doc/kicad/help/de
Unter Windows ist dies Anleitungen zu finden unter:
<Installationsverzeichnis>\share\doc\kicad\help\de
In Apple Mac OS:
/Library/Application Support/kicad/help/de

10.1. KiCad Dokumentation im Internet



The latest version of KiCad documentation can be found in multiple languages at http://docs.kicad.org
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