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Авторские права

This document is Copyright The KiCad Documentation Contributors. You may distribute it and/or modify it
under the terms of either the GNU General Public License (https://www.gnu.org/licenses/gpl.html), version 3
or later, or the Creative Commons Attribution License (https://creativecommons.org/licenses/by/3.0/),

version 3.0 or later.

Все торговые марки, используемые в данном руководстве, принадлежат их законным владельцам.

Авторы

Graham Keeth, Jon Evans, Glenn Peterson.

Прежние авторы

David Jahshan, Phil Hutchinson, Fabrizio Tappero, Christina Jarron, Melroy van den Berg.

Обратная связь

В проекте KiCad приветствуются отзывы, сообщения об ошибках и предложения по улучшению

связанные с программным обеспечением или его документацией. Более подробную информацию о
том, как оставить отзыв или сообщить о проблеме, можно найти в инструкции по адресу
https://www.kicad.org/help/report-an-issue/

Software and Documentation Version

This user manual is based on KiCad 10.0.0. Functionality and appearance may be different in other versions
of KiCad.

Documentation revision: 90e4b228 .

https://www.gnu.org/licenses/gpl.html
https://creativecommons.org/licenses/by/3.0/
https://www.kicad.org/help/report-an-issue/
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Introduction to KiCad 10.0
KiCad - это программный комплекс с открытым исходным кодом для создания принципиальных
схем, печатных плат, а также связанных с проектированием компонентов. KiCad поддерживает как
интегрированный процесс проектирования, при котором схема и печатная плата разрабатываются
одновременно, так и их редактирование по отдельности для особых случаев. KiCad также содержит

несколько инструментов, помогающих в проектировании схем и печатных плат, таких как PCB
калькулятор для определения электрических свойств элементов схемы, Gerber-просмотрщик для
проверки файлов используемых в производстве печатных плат, 3D-просмотрщик для
визуализации готовой печатной платы, а также встроенный SPICE-симулятор для исследования

работы схем.

KiCad работает на всех основных операционных систем и на компьютерах самой разной
конфигурации. Поддерживает разработку многослойных печатных плат (до 32 слоёв) и может

использоваться в проектах любой сложности. KiCad разрабатывается командой энтузиастов из
числа инженеров-программистов и инженеров-электронщиков со всего мира, цель которых -
создание свободного программного обеспечения с открытым исходным кодом пригодного для
профессионального проектирования и разработки электроники.

The latest documentation for KiCad is available at https://docs.kicad.org.

Загрузка и установка KiCad
KiCad работает на множестве операционных систем, включая Microsoft Windows, Apple macOS и
большинстве распространённых дистрибутивов Linux.

You can find the most up to date download links and installation instructions at

https://www.kicad.org/download/. These instructions are not included in this manual as they may change
over time with the release of operating system updates.

If you run into problems running KiCad on your system, check the list of known system-related issues and
workarounds at https://www.kicad.org/help/known-system-related-issues/.

IMPORTANT

Стабильные выпуски KiCad создаются периодически в соответствии с
политикой выпуска стабильных версий KiCad. Новые возможности, прежде чем
попасть в стабильный выпуск, сначала добавляются в ветку разработки. Если вы
хотите воспользоваться этими возможностями и помочь в их тестировании,
скачайте последнюю ночную сборку для своей платформы. Ночные сборки могут
содержать ошибки, такие как повреждение файлов, генерация некорректных
Gerber-файлов и т.д., но цель команды разработчиков KiCad сохранить ветку
разработки пригодной для использования, насколько это возможно при
разработке новых функций.

Поддержка
Если у вас имеются идеи, замечания, вопросы или просто нужна помощь:

Посетите официальный форум пользователей KiCad, это отличное место для общения с другими
пользователями KiCad и получения помощи.

https://docs.kicad.org/
https://www.kicad.org/download/
https://www.kicad.org/help/known-system-related-issues/
https://dev-docs.kicad.org/en/rules-guidelines/release-policy/
https://forum.kicad.info/
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Присоединяйтесь к нашему сообществу в Discord или IRC для общения с пользователями и
разработчиками в реальном времени.

Посетите веб-сайт KiCad с обучающими ресурсами созданными сообществом KiCad.

https://www.kicad.org/community/chat/
https://www.kicad.org/help/learning-resources/
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Basic concepts and workflow
Типичный рабочий процесс в KiCad состоит из двух основных задач: рисования схемы и разводки
печатной платы.

Схема - это символьное представление электрической цепи: какие используются компоненты и
какие соединения между ними выполнены. Символы схемы - это мнемонические изображения

электронных компонентов в схеме, например, зигзаг или прямоугольник для резистора или
треугольник для ОУ. Схема содержит символы для каждого компонента разрабатываемого
электронного устройства и проводники, соединяющие контакты этих символов. Обычно, сначала
рисуется схема, а затем делается разводка печатной платы.
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Плата - это физическая реализация схемы, на которой размещены посадочные места компонентов и
медные дорожки, создающие соединения, описанные в схеме. Посадочные места представляют

собой набор медных площадок, которые соответствуют физическим выводам компонента. При
изготовлении и сборке печатной платы непосредственно к ним и припаиваются электронные
компоненты схемы.

KiCad имеет отдельные окна для рисования схем («Редактор схем»), разводки плат («Редактор
печатных плат»«) и редактирования символов и посадочных мест («Редактор символов» и
«Редактор посадочных мест»»). KiCad поставляется с большой библиотекой высококачественных

символов и посадочных мест, созданных пользователями, но вы можете легко создавать
собственные символы и посадочные места или, при необходимости, редактировать уже
существующие.
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Наконец, важно понимать, что в KiCad реализована проектно-ориентированная схема работы.
Проект KiCad это каталог, в котором хранится файл проекта, файлы со схемой, макетом платы и, по

необходимости, другими сопутствующими файлами, такими как библиотеки символов и
посадочных мест, данных для моделирования, информация о закупках и т.д. Многие настройки,
связанные с проектом, включая классы цепей и правила проектирования, хранятся на уровне
проекта. Имейте ввиду, что открытие платы вне связанного с ней проекта может привести к

отсутствию информации о компоновки элементов или не согласованности со схемой, поэтому
обязательно храните все файлы, связанные с проектом, вместе.
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PCB design workflow
Как правило, сначала рисуется принципиальная схема. Это означает, что на схему добавляются
символы и рисуются соединения между ними. Если необходимые символы отсутствуют в

библиотеках, то пользователь может создать их самостоятельно. На этом этапе также выбираются
посадочные места для каждого компонента и, при необходимости, создаются собственные
посадочные места. После завершения разработки схемы и прохождения проверки электрических
правил (ERC) информация о схеме переносится в редактор печатных плат, и начинается ее

разводка.

The schematic describes which components are in the design and how they are connected; the board editor
uses this information to make layout easier and to prevent mismatches between the schematic and PCB. The
layout process requires careful placement of each footprint on the circuit board. After component

placement, copper tracks are drawn between components based on the connections in the schematic as well
as other electrical considerations, such as track resistance, controlled impedance requirements, crosstalk,
etc.

Часто, уже после начала разводки платы, возникает необходимость обновить принципиальную

схему - эти изменения можно легко перенести в проект платы. Иногда бывает и обратная ситуация -
правка вносится в разводку платы, эти изменения также могут быть перенесены в
принципиальную схему. Этим обеспечивает согласованность схемы и печатной платы на всём

этапе проектирования.

Когда разводка платы завершена и она прошла проверку на соответствие правилам
проектирования (DRC), генерируются выходные данные для изготовления платы, после чего она
может быть изготовлена на заводе по производству печатных плат.
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First time setup
The first time you open KiCad, a Welcome window appears to guide you through the initial setup.

The next page asks you if you want to start with fresh preferences or if you want to import your settings

from an older version of KiCad.
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The next page asks you how you want to configure your symbol and footprint libraries. In most cases, you
should select the first option, Start with the built-in KiCad libraries (recommended). This initializes your
library tables to include all of the libraries that come with KiCad.

The other options are to import your library table setup from the previously installed KiCad version, or to

start with no libraries and do all of the configuration yourself. Refer to the Schematic Editor and PCB Editor
documentation for details on how to manually configure libraries.

Depending on your system and how KiCad was installed, some options may not be available. KiCad may also
not be able to locate any libraries installed on your system. In this case, you should ensure you have installed

the libraries, or you can manually configure the libraries after completing setup.

NOTE On some systems the KiCad libraries are installed as a separate package.

Расположение файлов таблиц библиотек по умолчанию зависит от операционной системы и может

меняться в зависимости от места установки. Ниже приведены значения по умолчанию для каждой
операционной системы:

file:///src/build/src/getting_started_in_kicad/eeschema/eeschema.html#managing-symbol-libraries
file:///src/build/src/getting_started_in_kicad/pcbnew/pcbnew.html#managing-footprint-libraries


10

Windows C:\Program Files\KiCad\10.0\share\kicad\template\

Linux /usr/share/kicad/template/

macOS /Applications/KiCad/KiCad.app/Contents/SharedSupport/template/

The last page asks you whether you want to automatically check for updates to the KiCad application and to
third-party packages you may have installed through KiCad’s Plugin and Content Manager (plugins, themes,

libraries, etc.).

On Windows, you also have the option to enable anonymous crash reporting, which helps the KiCad team
diagnose and fix critical issues in the application.
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Учебное пособие Часть 1: Проект
Opening KiCad will bring up the Project Manager. To create a new project:

1. Click File → New Project

2. Select the Default project template and click OK.

3. Browse to the location where you want to save your project, and give your project a name, such as

getting-started .

4. Make sure the Create a new folder for the project checkbox is ticked.

5. Click Save.

This will create your project files in a new subfolder with the same name as your project.

Слева, на панели "Файлы проекта", отображается список файлов текущего проекта: файл с
расширением .kicad_pro , это файл проекта, файл с расширением .kicad_sch  это схема, а файл с
расширением .kicad_pcb , это печатная плата. Все они имеют общее название, состоящее из имени

вашего проекта.

Также может присутствовать каталог -backups : KiCad будет автоматически создавать резервные
копии проекта при его сохранении и, по желанию, через определенные промежутки времени.
Параметры резервного копирования настраиваются в меню Настройки → Настройки…​ → Общие →

Резервное копирование проекта.
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NOTE Opening the Preferences dialog may trigger a library table configuration
 dialog. This
dialog is explained below.

NOTE On macOS, the Preferences dialog is in the KiCad menu, not the
Preferences menu.

В правой части окна проекта расположены кнопки для запуска различных инструментов,
поставляемых с KiCad. При запуске редактора схем или редактора печатных плат автоматически

открывается соответствующий файл проекта (схема или печатная плата из текущего проекта).
Начните с открытия редактора схем.
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Tutorial part 2: schematic
Schematic editor basics
Для перемещения по схеме нажмите среднюю или правую кнопку мыши и перетащите ее.
Увеличение и уменьшение масштаба осуществляется с помощью колесика мыши или клавиш  и

. Пользователям ноутбуков может быть полезно изменить управление мышью так, чтобы оно
лучше подходило для сенсорной панели; управление мышью настраивается в меню Настройки →

Настройки… → Мышь и сенсорная панель.

NOTE On macOS, the Preferences dialog is in the KiCad menu, not the
Preferences menu.

По умолчанию в KiCad включена настройка мыши Центрировать по курсору при
масштабировании. При включении этой функции курсор мыши автоматически перемещается в
центр экрана при увеличении или уменьшении масштаба. Таким образом, область
масштабирования всегда остается в центре. Эта функция необычна, но многие пользователи
находят ее полезной, когда привыкают к ней. Попробуйте увеличить или уменьшить масштаб

курсором мыши в различных областях листа. Если поведение масштабирования по умолчанию
неудобно, отключите эту функцию в настройках.

The toolbar at the left side of the schematic editor screen contains basic display settings. The toolbar at the

right side of the screen contains tools for editing the schematic.

F1

F2
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NOTE

Some toolbar buttons have a small triangle in the bottom
right corner . The triangle

indicates that the button has an expanding palette containing several
related tools, for
example different kinds of labels. To select an
alternate tool, click and hold on the button
until the palette appears,
then click on the alternate tool. Another way to use the palettes
is to
click on the button and drag to the left until the palette appears, then
release the
mouse button when the desired tool is highlighted.

Most tools in KiCad either have default hotkeys assigned, or can have custom hotkeys assigned. To view all
hotkeys, go to Help → List Hotkeys…​. Hotkeys can be changed in the Hotkeys panel of the Preferences
dialog.

Schematic sheet setup
Прежде чем начать рисовать схему, необходимо настроить сам лист схемы. Нажмите Файл →

Параметры листа. Дайте схеме название и установите дату. Если хотите, то можете измените
размер листа.

Adding symbols to the schematic
Start making the circuit by adding some symbols to the schematic. Open the Choose Symbol dialog by
clicking the Add Symbols button  on the right side of the window or pressing .

В диалоговом окне «Выбор символа» перечислены доступные библиотеки символов и
содержащиеся в них символы компонентов. Основные устройства, такие как пассивные
компоненты, диоды и другие общие символы, находятся в библиотеке Device . Конкретные

устройства, например, определенный светодиод, могут находиться в других библиотеках.

A



16

Прокрутите вниз до библиотеки Device , раскройте ее и выберите символ LED . Нажмите OK, затем
кликните мышью еще раз, чтобы поместить символ на схему.

Далее добавьте токоограничительный резистор. Для этого снова вернитесь к выбору символов, но
на этот раз попробуйте найти резистор, введя R  в поле фильтра в верхней части. И снова он будет
найден в библиотеке Device . Компонент R  представляет собой прямоугольный символ резистора

в стиле МЭК. Для пользователей, предпочитающих символ зигзага в стиле ANSI, также доступен
символ R_US . Выберите символ резистора и добавьте его в схему.

И наконец, добавьте батарейку для питания светодиода. В библиотеке Device  содержится
соответствующий символ Battery_Cell .
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Selecting and moving objects
Next, position the symbols correctly relative to each other, as shown in the screenshot. You will do this by

selecting each symbol, then moving and rotating it.

In KiCad, objects are selected by clicking on them while the selection tool is active. The selection tool is the

default tool when no other tool is active, so you can enter the selection tool by quitting any active tool (

) or by clicking the  button in the right toolbar.

Additional objects can be added to the selection with +click, or removed with + +click
(macOS: + +click). You can toggle an item’s selection state with +click (macOS: +click).

Также возможен выбор объекта с помощью функции выделения перетаскиванием (нажать левую
кнопку мыши и, не отпуская ее, обвести символ); при выделении мышью слева направо

Esc

Shift Ctrl Shift

Cmd Shift Ctrl Cmd
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выбираются объекты, полностью заключенные в поле выделения, а при перетаскивании справа
налево - объекты, частично заключенные в поле выделения. С помощью клавиш , +

и  можно добавлять, убирать или переключать выделение соответственно.

Обратите внимание, что можно выделить весь символ (щелчком мыши на самой форме символа)
или выделить только одно текстовое поле в символе без выделения остальной части символа
(щелчком мыши на тексте). Если выделено только текстовое поле, то все действия будут

производиться только с выделенным текстом, а не с остальной частью символа.

Перемещение выделенных объектов осуществляется нажатием клавиши , а вращение - . Для
перемещения объектов можно также использовать горячую клавишу  (перетаскивание). При
перемещении не подключенных символов клавиши  и  ведут себя одинаково, но при

перемещении символов с подключенными проводниками клавиша  перемещает символ вместе
с проводниками, а клавиша  перемещает только символ, не затрагивая проводники.
Выделенные объекты можно удалить с помощью клавиши .

Wiring the schematic
The symbol pins all have small circles on them, indicating that they are not connected. Fix that by drawing

wires between symbol pins as shown in the screenshot. Click the Add a Wire button  on the right-hand

toolbar or use the  hotkey. Click and release to start drawing a wire, and finish drawing the wire by
clicking on a symbol pin or double clicking anywhere. Pressing Escape will cancel drawing the wire.

Другой удобный способ рисования проводников - наведение курсора мыши на не подключенный

вывод. Курсор мыши изменит свой вид, указывая на то, что от этого вывода можно нарисовать
проводник. Теперь если щелкнуть на этом выводе, то автоматически включиться режим
рисование проводника.

Shift Ctrl Shift

Ctrl

M R

G

G M

G

M

Del

W
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Далее добавьте в схему символы питания и земли. Хотя это и не обязательно для такой простой
схемы как эта, но в больших схемах это существенно облегчает их восприятие.

Ряд символов питания и земли доступен в библиотеке символов Power . Однако для их добавления

существует более быстрый способ: нажмите кнопку Добавить символ питания  или

воспользуйтесь горячей клавишей . При этом откроется диалоговое окно Выбор символа, но
отображаться будут только те библиотеки, которые содержат символы питания.

Добавьте символы VCC  и GND  на лист, а затем подключите их к схеме с помощью проводников.

Finally, add a label to the wire between the LED and resistor. Again, this may not be necessary in a simple
circuit, but it is good practice to label important nets. Click the Place Net Labels button  in the right

toolbar ( ), type a label name ( led ), and place the label into the schematic so that the square attachment
point overlaps with the wire. Rotate and align the label as necessary.

P

L
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Обратите внимание на то, что метки с одинаковым именем объединяются в одну цепь. То же самое
касается и символов питания с одинаковыми именами. Поэтому, если мы добавим на эту схему еще
один символ GND  или проводник с меткой led , то они буду соединены с уже существующими

одноименными цепями даже без проводников, визуально их соединяющих.

Annotation, symbol properties, and footprints

Обозначение
Каждому символу должно быть присвоено уникальное условное обозначение. Этот процесс также
известен как аннотация.

By default, symbols are automatically annotated when they are added to the schematic. Automatic

annotation can be enabled or disabled using the  button in the left toolbar.

Хотя в данном руководстве это и не требуется, но вы всегда можете вручную обозначить или

переобозначить символы, используя кнопку Заполнить обозначения символов схемы ( ) на

панели инструментов сверху.
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Symbol properties
Далее заполним значения для каждого компонента. Выберите светодиод, щелкните правой
кнопкой мыши и выберите Свойства… ( ). В данном проекте будет использоваться красный
светодиод, поэтому измените поле Значение  на Red . В реальном же проекте, возможно, лучше
будет написать обозначение светодиода из тех.документации производителя (Datasheet). Обратите

внимание, что позиционные обозначения можно редактировать индивидуально в свойствах
каждого символа.

В этом проекте будет использоваться литиевая батарейка типа «таблетка» на 3 В, поэтому
измените`BT1`, в поле Значение , на 3 В . Так же измените значение резистора на 1k .

Footprint assignment
Наконец, назначьте каждому компоненту посадочное место. Оно определяет, как каждый
компонент будет крепиться к печатной плате. Некоторые символы поставляются с уже заданными
посадочными местами, но для многих из них существует несколько вариантов, поэтому
пользователю необходимо выбрать наиболее подходящее.

Существует несколько способов назначения посадочных мест, но одним из удобных является
использование инструмента "Назначения посадочных мест", для чего необходимо нажать кнопку 

 на панели инструментов вверху.

В колонке слева, окне назначения посадочных мест, перечислены все доступные библиотеки
посадочных мест. В средней колонке отображаются символы из схемы. Для всех этих символов в

дальнейшем будут назначены посадочные места. В колонке справа показаны посадочные места,
которые можно выбрать для выделенного в средней колонке символа. Чтобы назначить
посадочное место, выберете символ из средней колонки и укажите необходимое посадочное место

двойным нажатием мышки по нему в правой колонке. Посадочное место можно просмотреть,
щелкнув правой кнопкой мыши на нём и выбрав пункт Просмотреть выбранное посадочное
место.

E
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В состав KiCad входит множество посадочных мест, поэтому инструмент назначения посадочных
мест предлагает несколько способов их фильтрации, позволяя скрыть те, которые не

соответствуют рассматриваемому символу.

Крайняя левая кнопка  включает фильтры, которые содержатся в самом символе. Например,

символ операционного усилителя может содержать фильтры, отображающие только
посадочные места SOIC и DIP. Иногда эти предопределенные фильтры отсутствуют или имеют
слишком строгие ограничения, поэтому в некоторых ситуациях этот фильтр лучше отключить.

Средняя кнопка  фильтрует по количеству выводов, таким образом для 8-контактных

символов будут отображаются только 8-ми контактные посадочные места. Этот фильтр будет

полезен практически всегда.

Крайняя правая кнопка  включает фильтр по выбранной библиотеке. Библиотеки

выбираются в левой колонке; посадочные места, не входящие в выбранную библиотеку, будут
скрыты. Этот фильтр полезен до тех пор, пока известно какая из библиотек содержит нужное
посадочное место. Зачастую, не рекомендуется использовать этот фильтр совместно с
фильтрами в символах.

Текстовое поле позволяет отфильтровать посадочные места, не совпадающие с текстом в этом
поле. Данный фильтр отключается, если поле пустое.

Using the filters, find each of the footprints shown in the central column in the screenshot above. The
footprints for each symbol are also listed in the table below. Assign each footprint to a symbol by selecting

the symbol in the central column and then double clicking the appropriate footprint in the right column.
Once all of the footprints have been assigned, click OK.

Symbol Reference Footprint to assign

BT1 Battery:BatteryHolder_Keystone_1058_1x2032

D1 LED_THT:LED_D5.0mm

R1 Resistor_THT:R_Axial_DIN0309_L9.0mm_D3.2mm_P12.70mm_Horizontal

Существуют и другие способы назначения посадочных мест; один из них - через окно свойств
символа. Более подробную информацию о назначении посадочных мест см. в этом руководстве.

Electrical rules check
Последнее, что осталось сделать в схеме, это проверить ее на наличие электрических ошибок.
Программа проверки электрических правил (ERC) KiCad не может гарантировать

работоспособность схемы, но она может проверить наличие некоторых распространенных ошибок
подключения, таких как не подключенные контакты, замыкание выходов питания или вход
питания, на который ничего не подается. Кроме того, программа проверяет и другие ошибки,

например, отсутствие обозначений у компонентов или опечатки в обозначениях цепей. Для
просмотра полного списка параметров проверки электрических правил и настройки уровня их

file:///src/build/src/getting_started_in_kicad/eeschema/eeschema.html#assigning-footprints
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строгости перейдите в меню Файл → Параметры схемы… → Электрические правила → Уровень
нарушения. Перед началом разводки платы рекомендуется всегда запускать ERC.

Запустите проверку электрических правил, нажав кнопку ERC ( ) на панели инструментов

вверху, а затем щелкнув на кнопке Проверить.

Даже в этой простой схеме KiCad обнаружил две потенциальные ошибки. Ошибки перечислены в
окне ERC, а стрелки указывают на места ошибок в схеме. Если в окне ERC щёлкнуть на найденной
ошибке, то она будет выделена на схеме соответствующей стрелкой.

Вы можете исключить отдельные нарушения или игнорировать целые классы нарушений,
щелкнув правой кнопкой мыши на каждом сообщении об ошибке. Тем не менее, обычно стоит

устранять нарушения, даже если они не являются реальными ошибками проектирования, чтобы
получить чистый отчет ERC и не пропустить реальные проблемы.

В данном случае KiCad выдает сообщение "Вход питания не подключен ни к одному выходу
питания" для цепей VCC  и GND . Это распространенная ошибка ERC в KiCad. Символы питания

настроены таким образом, что требуют наличия ввода питания, например, от выхода
стабилизатора напряжения в той же цепи; в противном случае KiCad считает что, цепь не запитана.
Для человека очевидно, что VCC  и GND  питаются от батарейки, но в схеме это необходимо
указывать в явном виде.



24

В библиотеке символов Power  есть специальный символ PWR_FLAG , который используется для
решения этой проблемы, сообщая KiCad, что цепи действительно запитаны. Добавьте этот символ к
цепям VCC  и GND  и повторно запустите ERC. Если проверка ERC пройдет без нарушений, можно

считать, что схема готова.

Bill of materials
A final optional step is to generate a Bill of Materials listing all components used in the project. Click Tools
→ Generate Bill of Materials…​.
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KiCad has a GUI for BOM export. You can configure which symbol metadata will be exported, and how the
symbols are grouped, in the Edit tab, and configure the output format in the Export tab.

For now, the default settings should be fine, but you can see a raw view of what will be exported in the
preview pane. Specify an output file in the Export tab, then press the Export button.

The BOM should look like the below image when it is opened in a spreadsheet program.
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Tutorial part 3: circuit board
После того как схема готова, вернитесь в окно проекта и откройте редактор печатных плат, нажав
кнопку "Редактор печатных плат" или открыв файл печатной платы.

PCB editor basics
Навигация в редакторе печатных плат такая же, как и в редакторе схем: перемещение
осуществляется с помощью средней или правой кнопки мыши, а масштабирование - с помощью

колеса прокрутки или / .

Основная часть редактора печатных плат представляет собой лист, на котором будет происходить
проектирование платы. На панели инструментов слева расположены различные инструменты
управления отображением платы, включая единицы измерения и переключатели режимов

отображения контура/заливки для дорожек, каналов, площадок и зон (полигонов). Панель
инструментов справа от листа содержит инструменты для проектирования печатной платы.

NOTE

Some toolbar buttons have a small triangle in the bottom
right corner . The triangle

indicates that the button has an expanding palette containing several
related tools, for
example different kinds of dimensions. To select an
alternate tool, click and hold on the
button until the palette appears,
then click on the alternate tool. Another way to use the
palettes is to
click on the button and drag to the left until the palette appears, then
release
the mouse button when the desired tool is highlighted.

Крайняя панель справа, это панель внешнего вида и фильтра выделения. Панель "Внешний вид"
используется для работы с цветом и прозрачностью слоев, объектов и цепей печатной платы, а
также для включения и выключения видимости соответствующих элементов. Смена активного

слоя производится щелчком мыши на его имени.

Под панелью "Внешний вид" находится "Фильтр выделения", который включает и выключает
выделение различных типов объектов печатной платы. Это удобно для выбора конкретных
элементов в перегруженной компонентами схеме.

Board setup and stackup
Перед созданием печатной платы настройте размер страницы и добавьте информацию в
титульный блок. Нажмите Файл → Параметры листа…, и задайте в параметрах подходящий
формат листа, добавьте дату, номер ревизии и заголовок.

F1 F2
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Далее перейдите в меню Файл → Настройка платы…, чтобы определить, как будет
изготавливаться печатная плата. Наиболее важными настройками являются параметры структуры
(stackup), т.е. количество медных и диэлектрических слоев в печатной плате (и их толщина), а

также правила проектирования, например, размеры и расстояние между дорожками и
переходными отверстиями.

Для установки параметров структуры платы откройте страницу Структура платы → Физическая
структура окна "Параметры платы". В данном руководстве используется 2 слоя меди, однако в

более сложных проектах иногда их требуется гораздо больше.
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Теперь перейдите на страницу Правила проектирования → Ограничения. Настройки на этой

странице определяют основные правила проектирования для всех элементов платы. Для данного
руководства вполне подойдут настройки по умолчанию. Однако, в реальном проекте, эти
параметры должны быть установлены в соответствии с возможностями завода-изготовителя
печатных плат, чтобы макет платы был пригоден для её производства.
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Finally, open the Design Rules → Net Classes page. A net class is a set of design rules associated with a
specific group of nets. This page lists the design rules for each net class in the design and allows assigning

nets to each net class (nets can also be assigned to net classes in the schematic editor).

Ширина дорожек и расстояние между ними могут задаваться проектировщиком вручную - в
процессе разводки, однако рекомендуется использовать классы цепей, поскольку они
обеспечивают автоматический способ управления и проверку правил проектирования.

In this design, no net classes are specified, so all nets will belong to the Default  net class. A single net class
is acceptable for this project, but other designs may have multiple net classes, each with different design
rules. For example a board might have a High Current  netclass with wide tracks, or a 50 ohm  netclass with

specific width and clearance rules for 50 ohm controlled-impedance tracks.

This project has relatively few components and is not space constrained, so we can be generous with track
sizing. Larger tracks can carry more current and are more mechanically robust. Increase the Default  net
class’s Track Width  from 0.2 mm  to 0.4 mm . When we route tracks, they will automatically have a width of

0.4 mm .

Importing changes from schematic
Разработка схемы завершена, но на плате еще нет ни одного компонента. Чтобы импортировать
схему в проект плат, выберите Инструменты → Обновить печатную плату из схемы… или

используйте клавишу . Также, для этого есть кнопка , на панели инструментов сверху,

которая дублирует команду обновления из меню.

Прочитайте сообщения в окне вывода информации Изменения к применению, где будет сказано,
что три компонента, указанные на схеме, будут добавлены на плату. Нажмите Обновить плату,
закройте окно и щелкните в любом месте рабочей области, чтобы разместить три посадочных
места. Расположение каждого посадочного места относительно других мы изменим позже.

F8
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В KiCad обновление печатной платы с учётом изменений в схеме выполняется вручную:
разработчик сам решает, когда целесообразно обновить плату, синхронизировав с изменениями в
схеме. Каждый раз, когда редактируется схема, разработчик должен использовать инструмент
Обновить плату из схемы, чтобы синхронизировать изменения.

Drawing a board outline
Теперь в рабочей области размещены три компонента, но сама плата еще не определена. Для
создания макета платы необходимо нарисовать ее контур на слое Edge.Cuts .

Контур платы рекомендуется рисовать на мелкой сетке, благодаря чему можно подобрать круглые
числа для размера платы. Выберите в раскрывающемся меню "Сетка", расположенном на верхней

панели, сетку с шагом 1 мм.
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To draw on the Edge.Cuts  layer, click Edge.Cuts in the Layers tab of the Appearance panel at right. Choose
the rectangle tool  in the right toolbar, click on the canvas to place the first corner, then click again to

place the opposite corner so that the rectangle roughly surrounds the three footprints. The other graphic

tools (line , arc , circle , polygon , bezier , or a combination of them) could also be used to

define the board outline; the only requirement is that the outline is a single closed shape that doesn’t
intersect itself.

The board outline should look like this:
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The lighter grey color inside the outline indicates the interior of the board.

Placing footprints
Следующим шагом в процессе компоновки является расположение посадочных мест на плате. В
целом, при их размещении можно руководствоваться несколькими общими соображениями:

К некоторым посадочным местам могут предъявляться точные требования по их

месторасположению на плате, например, к разъемам, индикаторам, кнопкам и переключателям.

Для некоторых компонентов может потребоваться размещение в соответствии с техническими

требованиями. Шунтирующие конденсаторы должны находиться вблизи выводов питания
соответствующей микросхемы, а чувствительные аналоговые компоненты - вдали от цифровых
помех.

Almost all components have a "Courtyard" (or two if both Front and Back are defined). Generally
courtyards should not intersect.
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Otherwise components should be positioned for ease of routing. Connected components should
generally be close together, and arranged to minimize routing complexity. The ratsnest (the thin lines

indicating connections between pads) is useful for determining how best position footprints relative to
other footprints.

В рамках данного руководства размещать компоненты мы будем таким образом, чтобы
максимально упростить процесс трассировки.

Start by moving the battery holder BT1  onto the back side of the board. Click it to select it, then press  to
move it. Press  to flip it to the opposite side, then click to place it. It now appears mirrored and its pads

have changed from red to blue.

Все слои рассматриваются с верхней стороны печатной платы. Поэтому посадочные места с нижней

стороны платы перевернуты и выглядят зеркально.

M

F
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Каждый слой печатной платы имеет свой цвет, который отображается в виде эскиза на вкладке
"Слои" панели "Внешний вид". В цветовой схеме по умолчанию элементы на слое F.Cu  (Front

Copper - Верхний слой меди) имеют красный цвет, а элементы на слое B.Cu  (Back Copper - Нижний
слой меди) - синий.

Now place the other two components. One at a time, select each component, then move and rotate it with 
 and . The thin lines between pads are called ratsnest lines; they indicate connections in the schematic

that you have not yet created in the PCB. Watch the ratsnest lines between each pad to choose the simplest
arrangement of components; a good arrangement will leave the lines untangled, which means it will be easy
to route the tracks between pads. One possible arrangement is shown in the screenshot below.

Routing tracks
With the components in place, it’s time to connect the pads with copper tracks.

M R
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The first track will be drawn on the front of the board, so change the active layer to F.Cu  in the Layers tab
of the Appearance panel.

Click Route Tracks  in the right-hand toolbar or press . Click on the led  pad of D1  and release the

mouse button. The ratsnest line indicates there is an unrouted connection to the led  pad of R1 , so click on
that pad to draw a track connecting the two pads. Clicking on the second pad completes the track. The
ratsnest line between the led  pins is no longer drawn because the connection has been made in copper.

Now draw a track between the GND  pads of BT1  and D1 , starting with the BT1  pad on the back of the
board. Notice that the active layer automatically changed to B.Cu  after clicking on the BT1  pad. Click on the
D1  pad to finish the track.

While BT1  has surface mount pads that are only on the bottom of the board, D1  has through hole pads that
can connect to tracks on both the front and back. Through hole pads are one way to make a connection
between multiple layers. In this case, D1  is a component on the front side of the board, but its through hole
pads are used to connect to a track on the back of the board.

X
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Другой способ создания соединения между слоями - это переходы. Начните трассировку на нижней
стороне платы с контактной площадки VCC , держателя батарейки BT1 . Нажмите клавишу  и

щелкните мышью на полпути между BT1  и R1 , чтобы вставить переход, при этом автоматически
активным станет слой F.Cu . Завершите трассировку на верхней стороне платы, щелкнув на
контакте VCC  резистора R1 .

На данном этапе все цепи разведены. В этом можно убедиться, посмотрев на панель информации в
левой, нижней части окна, где количество не разведенных цепей равно 0.

Placing copper zones
Copper zones are regions of copper with an associated net. Zones automatically connect to copper objects

belonging to the same net and avoid objects belonging to other nets. Zones are often used for ground and
power connections because they provide a lower impedance connection than tracks.

V
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Добавьте зону GND  на обратной стороне платы, переключившись на нижний слой и нажав кнопку

Добавить зону заливки  на панели инструментов справа. Щелкните на печатной плате, чтобы

разместить первый угол зоны.

In the Copper Zone Properties dialog that appears, select the GND  net from the Net name dropdown and
make sure that the B.Cu  layer is selected. Click OK, then click to place the other three corners of the zone.
Double click when placing the last corner to complete the zone.

The zone outline is displayed on the canvas, but the zone is not yet filled — there is no copper in the zone
area, and therefore the zone is not making any electrical connections. Fill the zone with Edit → Fill All
Zones ( ). Copper has been added to the zone, but it doesn’t connect to the VCC  or led  pads and tracks,

and is clipped by the board edge. It overlaps with the GND  track drawn earlier, and it connects to the GND
pads through thin tracks. These are thermal reliefs, which make the pads easier to solder. Thermal reliefs
and other zone settings can be modified in the zone properties dialog.

B
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В KiCad зоны не заполняются автоматически при их создании, редактировании или при

перемещении в них посадочных мест. Заполнение зон всегда производится вручную, а также при
выполнении проверки правил проектирования (DRC) (примечание: если установлен
соответствующий флажок). Убедитесь что заполнение зон актуально, прежде чем создавать
выходные данные для производства.

Иногда, заполненные зоны мешают увидеть другие компоненты на плате из за их большого
количества и плотности монтажа. В таком случае зоны можно просто скрыть, оставив видимыми

только их контуры. Делается это с помощью кнопки Показать только контуры зон  на панели

инструментов слева. Но имейте ввиду - зоны сохраняют статус заполненных, если показаны только

их контуры, так что скрыть заливку зоны не означает что вы ее удалили.

Еще зоны можно сделать прозрачными с помощью панели «Внешний вид». Таким же образом, с
помощью Параметров отображения слоев на панели «Внешний вид», можно скрыть или
затемнить неактивные слои.
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Design rule checking
Design Rule Checking is the layout equivalent of Electrical Rule Checking for the schematic. DRC looks for
design mistakes like mismatches between the schematic and layout, copper regions that have insufficient

clearance or are shorted together, and tracks that do not connect to anything. You can also write custom DRC
rules. To view the full list of design rules that are checked and to adjust their severity, go to File → Board
Setup…​ → Design Rules → Violation Severity. Running DRC and fixing all errors is strongly advised before
generating fabrication outputs.

Запустите проверку DRC с помощью команды Проверка → Проверка правил проектирования или
используйте кнопку  на верхней панели инструментов. Нажмите кнопку Проверить DRC. По

окончании проверки не должно быть никаких сообщений об ошибках или предупреждений.
Закройте окно DRC.

Now intentionally cause a DRC error by moving the resistor footprint to overlap the filled area of the zone.

Use  (Drag) to move the resistor footprint slightly while keeping the tracks attached to its pads. This
creates a clearance violation because the VCC  and led  pads of the resistor are shorted to the GND  zone fill.
Ordinarily this would be fixed by refilling the zone, but don’t refill the zone yet.

D
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Run DRC again, but make sure to uncheck the Refill all zones before performing DRC checkbox. DRC
reports 6 violations: for each pad of R1 , there is a clearance violation between the pad and the zone,
another clearance violation between the pad’s through hole and the zone, and a third violation where the
pad’s solder mask opening exposes the copper of two different nets (the GND  fill and the track connected to

the pad). Arrows point to each violation in the canvas. Clicking on each violation message zooms in on the
respective violation.
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Закройте диалоговое окно проверки правил проектирования, нажмите клавишу , чтобы
обновить заливку зоны, и повторно запустите DRC. Можно использовать альтернативный вариант,
установить флажок Перезалить все зоны перед проверкой правил проектирования DRC в

диалоговом окне проверки правил проектирования, и повторно запустить проверку. Все ошибки
будут устранены.

3D viewer
KiCad поставляется с 3D-просмотрщиком, который полезен для визуальной проверки печатных
плат. Откройте программу 3D-просмотра командой Вид → Просмотрщик 3D. Перемещение

осуществляется с помощью средней кнопки мыши, а вращение - перетаскиванием левой кнопки
мыши. Вращая печатную плату, можно увидеть сверху светодиод и резистор, а снизу - держатель
батареи.

В 3D-просмотрщике есть режим трассировки лучей, который работает медленнее, но обеспечивает
более точную визуализацию. Переключиться в этот режим можно с помощью команды Настройки
→ Трассировка лучей.

B
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Многие посадочные места в библиотеке KiCad поставляются с 3D-моделями, в том числе и все
посадочные места, используемые в данном руководстве. Некоторые посадочные места

поставляются без 3D-моделей, но пользователи могут добавить их самостоятельно.

Fabrication outputs
После завершения проектирования платы необходимо сформировать выходные данные для ее
изготовления.

Откройте диалоговое окно "Чертить" с помощью команды Файл → Чертить…. В этом окне можно

создать чертеж платы в нескольких форматах, но обычно, для заказа у изготовителя печатных плат,
используется формат Gerber.

Specify an output directory so that the plotted files will be collected in a folder. Otherwise, the default
settings are fine, but make sure all the necessary layers are checked:

Copper layers ( *.Cu ).

Board outline ( Edge.Cuts ).

Solder mask ( *.Mask ).

Silkscreen ( *.Silkscreen ).

Solder paste ( *.Paste ). This layer is needed for manufacturing solder paste stencils, but is otherwise
optional.

Other layers may be useful to plot, but are not typically necessary for PCB fabrication.
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Нажмите кнопку Чертить, чтобы сгенерировать Gerber-файлы. Также нажмите кнопку
Сформировать файлы сверловки… и в следующем окне нажмите на кнопку Создать файл
сверловки для создания файлов, содержащих информацию о расположение всех отверстий,
которые будут просверлены на плате. Наконец, закройте диалоговое окно "Чертить".
Проектирование завершено.
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Tutorial part 4: custom symbols and footprints
Схему можно улучшить, добавив в нее выключатель для включения/выключения светодиода. Для
начала мы создадим новые библиотеки символов и посадочных мест, далее нарисуем символ
выключателя и сделаем для него посадочное место.

В данном руководстве будет использоваться конкретный выключатель SPST (от английской

аббревиатуры Single Pole, Single Throw - один полюс, одно направление) NKK M2011S3A1W03. Можно
использовать и другие выключатели, но для этого вам потребуется изменить нумерацию выводов
и размеры посадочного места.

Library and library table basics
Symbols and footprints are organized into libraries. A library can hold symbols or footprints, but not both.

KiCad keeps track of the user’s symbol libraries and footprint libraries in the symbol library table and
footprint library table, respectively. Each library table is a list of library names and the location of where
each library exists on disk. Library tables can also include other library tables, which effectively adds all of

the libraries in the child table to the parent table.

In addition to global symbol and footprint library tables, there are also project library tables for symbols and
footprints. Symbols and footprints that are added to the global tables are available in all projects, while
symbols and footprints in the project-specific tables are available only for that specific project. Users can

add their own libraries to the global library tables or to project-specific tables.

Таблицы библиотек символов можно просмотреть или отредактировать с помощью команды
Настройки → Управление библиотеками символов…, в окнах "Редактор схем" или "Редактор
символов". Таблицы библиотек посадочных мест можно просмотреть или отредактировать с

помощью команды Настройки → Управление библиотеками посадочных мест…, в окнах
"Редактор плат" или "Редактор посадочных мест". Также, доступ к обеим таблицам библиотек,
возможен из "Менеджера проекта".

https://www.nkkswitches.com/pdf/MtogglesBushing.pdf
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Often, paths to libraries are defined with path substitution variables. This enables a user to move all of their
libraries to a new location without modifying the library tables. The only thing that needs to change is to

redefine the variable to point to the new location. KiCad’s path substitution variables are edited with
Preferences → Configure Paths…​ in the Project Manager or any of the Editor windows.

Одной из полезных переменных подстановки пути является ${KIPRJMOD} . Эта переменная всегда
указывает на текущий каталог проекта, поэтому ее можно использовать для включения

специфических для проекта библиотек, которые хранятся внутри каталога проекта.

On first run, KiCad prompts the user to set up the symbol and footprint library tables. To reset your libraries
to default, press the Reset Libraries button in the library table dialog.

Creating new global or project libraries
Первым шагом, при создании нового символа или посадочного места. является выбор библиотеки,

в которой он будет храниться. В данном руководстве символ выключателя и его посадочное место
будут помещены в новые библиотеки, предназначенные для конкретного проекта.

1. Open the Symbol Editor from the Project Manager.

2. Click File → New Library.

3. Select the Add new library to project library table option in the file browser.

4. Choose a name for the new library (e.g. getting-started.kicad_sym ).

5. Save the new symbol library in the project directory.

The empty new library is now selected in the Libraries pane at left, and has been automatically added to the
project library table (check the Project Specific Libraries tab in Preferences → Manage Symbol Libraries…​
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).

Creating new symbols
Now create the switch symbol in the new library.

1. Select the getting-started  library in the Libraries pane at left.

2. Click File → New Symbol…​.

3. In the Symbol name field, enter the part number: M2011S3A1W03 .

4. Switch symbols should have reference designators that start with SW , so change the Default reference
designator field to SW .

5. Uncheck Show pin name text.

6. Leave all other fields as the defaults.

7. Press OK.

In the Libraries pane, the M2011S3A1W03  symbol now appears under the getting-started  library. In the
canvas, a cross indicates the center of the footprint, and text has been added for the reference designator.
For now, move the text away from the center of the symbol to get it out of the way.

Symbol pins
Start drawing the symbol by adding a pin. This symbol will not have a pin 1, so we will start with a pin
numbered 2. Click the Add a pin button  on the right toolbar. The Pin Properties dialog will appear. Set

the pin properties as follows:

Pin name: A

Pin number: 2

Electrical type: Passive

Orientation: Right

X Position: -200 mils

Y Position: 0

Click OK, then click on the canvas to place the pin. If the pin moved after clicking OK, it might be necessary
to edit the pin’s properties again (double click the pin, or right click on the pin → Properties…​) to set the
position correctly.

NOTE

It is strongly recommended to always use mils (or inches) in the Schematic
Editor and
Symbol Editor, particularly for symbol pins. Mixing imperial and
metric units will result in
symbol pins that cannot be properly connected
because they do not align with wires or
other pins. The KiCad libraries
 use a 50 mil grid for their pins; using a different unit
system will
prevent your symbols and schematics from connecting with KiCad’s builtin
symbols. Note that unlike in the PCB editor, units in the schematic have
 no physical
meaning.
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Добавьте второй вывод, но на этот раз не используя инструмент Добавить вывод, а просто нажав
клавишу . К символу добавится новый вывод под номером 3 , расположенный
непосредственно под выводом 2 .

TIP

Во многих местах KiCad, нажатие клавиши  приводит к повторению
последнего действия. При этом местоположение нового элемента будет смещено, а
нумерация, в зависимости от ситуации, автоматически увеличится. В редакторе
символов это можно использовать для быстрого размещения большого
количества выводов. В редакторе схем это может быть использовано для
многократного размещения однотипного компонента или для маркировки
большого количества выводов компонента нумерованными метками. Также,
клавиша  может быть полезна в редакторе посадочных мест и редакторе
плат.

We want Pin 3 to be on the right side of the switch symbol, so we will edit its properties to change the
location and orientation. Instead of using the Pin Properties dialog, this time we can use the Properties
Panel. This is a docked panel on the left side of the editing canvas that lets you view and edit the properties

of the selected object or objects. To show or hide the Properties Panel, use the  button in the left toolbar.

With pin 3 selected, use the Properties panel to set its properties as follows:

Pin Name: B

Position X: 200 mils

Position Y: 0

Orientation: Left

Insert

Insert

Insert
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NOTE The Properties Panel is available in every KiCad editor (Schematic, Board,
Symbol, and
Footprint).

Symbol graphics
Разместив все необходимые выводы, с помощью инструментов «Круг»  и «Линия»  придайте

символу вид переключателя SPST. На этом этапе полезно переключиться на более мелкую сетку:

щелкните правой кнопкой мыши в рабочей области и выберите в подменю Сетка более мелкий
шаг. После добавления графических фигур снова переключитесь на сетку 50 мил (1.27 мм).

WARNING

Мелкие сетки удобны для рисования графических элементов, но выводы
символов всегда должны располагаться на сетке с шагом 50 мил (1.27 мм).
Выводы, не выровненные по сетке 50 mil, не получится соединить с
проводниками в схеме.

Symbol properties
Now edit the properties for the whole symbol with File → Symbol Properties, or by double clicking on the
canvas. Change the Value field to M2011S3A1W03 , and add spst switch toggle  to the Keyword field to
make it easier to find the symbol by searching.

После нажатия кнопки OK переместите текстовое поле обозначения ниже, чтобы оно не
перекрывало графику символа.
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На этом этап создание символа завершен. Сохраните его и переходите к следующему - созданию для

него посадочного места.

Creating new footprints
To create a new footprint, follow a similar process as for symbols. First you need to create a library, then
create a new footprint in the library.

1. Open the Footprint Editor from the Project Manager.

2. Click File → New Library…​.

3. Select the Add new library to project library table option in the file browser.

4. Choose a name for the new library (e.g. getting-started.pretty )

5. Save the new footprint library in the project directory.

As with the symbol library, the new footprint library is added to the project library table. You can now add a
footprint to the new library.

1. Select the getting-started  library in the Libraries pane at left.

2. Click File → New Footprint. This creates an empty, untitled footprint.

3. Edit the footprint’s properties (  button in the top toolbar) and set the following properties:

Footprint name: Switch_Toggle_SPST_NKK_M2011S3A1x03

Value: Switch_Toggle_SPST_NKK_M2011S3A1x03

Component type: Through hole
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Footprint pads
The switch has two pins, numbered in the datasheet as 2 and 3, and spaced 4.7 mm apart. For ease of
placement, adjust the grid to match the pad spacing. Open the grid settings by right-clicking the  button

in the left toolbar and selecting Edit Grids…​. Add a new grid with the plus button at the bottom. Set the new
grid’s X size to 4.7 mm . Accept the dialog, go back to the editing canvas, and then switch to the new grid in
the grid dropdown in the top toolbar, if it is not already selected.

By convention, through-hole footprints have pin 1 located at (0,0)  and are oriented with pin 1 in the top
left. We are using the SPST version of this switch which does not have pin 1, so the footprint will leave
(0,0)  empty and place pads 2 and 3 at (0, 4.7 mm)  and (0, 9.4 mm) . Note that in KiCad’s default
coordinate system, the positive Y-axis is oriented downwards.

NOTE
The X and Y coordinates of the cursor are displayed in the status bar at
the bottom of the
window. You can use this to check the coordinates when
 you are drawing or placing
something.

1. Use the Add a pad tool  in the right toolbar to place a pad one grid division below the origin, which is

(0, 4.7 mm).

2. Press  to exit the pad tool.

3. Double click on the pad to edit its properties.

4. Change the pad number to 2 .

5. Verify that the position is correct.

6. Set the pad shape to Circular.

7. Set the hole diameter. The switch pins are 1.17 mm x 0.8 mm, which gives a diagonal (maximum pin
dimension) of 1.42 mm. Therefore set the hole diameter to 1.42 mm + 0.2 mm = 1.62 mm .

8. Set the pad diameter. For a hole diameter of 1.62 mm, set the pad diameter to 1.62 mm + 2*0.15 mm =
1.92 mm  to provide a sufficient annular ring.

9. Press OK to apply the pad modifications.

Esc
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Now use the Add a pad tool again to place the other pad at (0, 9.4 mm) . Notice that the pad number is
automatically incremented and the properties including pad size and hole size are copied from the previous
pad.

При размещении обеих контактных площадок, поясок выглядит несколько маловатым. Чтобы

выключатель было легче паять и он прочнее держался на плате, лучше сделать пояски контактных
площадок чуть побольше. Поэтому увеличьте толщину пояска с 0.15 мм до 0.3 мм, отредактировав
свойства контактной площадки 2 и изменив ее размер до 1.62 мм + 2*0.3 мм = 2.22 мм . Размер

отверстия не меняйте. Обратите внимание, что поле "Размер контактной площадки" принимает
математические выражения, поэтому 1.62+2*0.3  можно ввести напрямую и получить значение
2.22 мм.

TIP Многие текстовые поля в KiCad поддерживают математические выражения,
включая преобразования единиц измерения.

Выполните аналогичную модификацию пояска и для другой контактной площадки. Для этого
щелкните правой кнопкой мыши на контактной площадке 2, выберите Использовать настройки
контактной площадки…, а затем нажмите Изменить контактные площадки на текущем
посадочном месте.

Footprint graphics
Правильное посадочное место имеет точный контур детали на слое изготовления ( F.Fab ), немного
больший контур на слое шелкографии ( F.Silkscreen ) и границу посадочного места ( F.Courtyard ),
окружающую все посадочное место для предотвращения наложения на другие посадочные места.

The fabrication outline should precisely match the physical dimensions of the part, which is 7.9 mm wide and
13 mm tall. One way to precisely place the outline is to create a new grid with the correct X and Y spacing, as
we did for the pads. Make sure to uncheck the Linked checkbox in the Grid Settings dialog to allow unequal

X and Y grid spacing. You can then adjust the grid origin by right clicking the  button and selecting Grid

Origin…​.
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Configure the grid spacing and origin as follows:

Сетка пользователя Размер X: 7.9 мм

Сетка пользователя Размер Y: 13 мм

Начало координат по оси X: 7.9 мм / 2 = 3.95 мм

Y origin: 4.7 mm - (13 mm / 2) = -1.8 mm .

To draw the fab outline, switch to the front fabrication layer by clicking F.Fab in the Layers panel at right.

Use the line , rectangle , or polygon  tools to draw the outline of the part as shown in the

screenshot below, with corner coordinates annotated.

NOTE

If you use the rectangle tool, you will need to make sure the line mode is set to the free-
angle mode or you will only be able to draw squares.
To change the line mode to free-
angle, click the  /  /  button on the left toolbar until it shows .
You can also

use +  to cycle the line mode.

Next, switch to the F.Silkscreen  layer. We want the silkscreen outline to be just outside of the part outline,
so the silkscreen lines will be drawn 0.11 mm to the outside of the lines on the fabrication layer (0.11 mm is
half of the 0.10 mm fab line width, plus half of the 0.12 mm silkscreen line width). The exact coordinates are

shown in the screenshot below, and helpful grid settings are:

Сетка пользователя Размер X: 7.9 мм + 2 * 0.11 мм = 8.12 мм

Сетка пользователя Размер Y: 13 мм + 2 * 0.11 мм = 13.22 мм

Начало координат по оси X: 8.12 мм / 2 = 4.06 мм

Начало координат по оси Y: -1.8 мм - 0.11 мм = -1.91 мм

Also change the silk outline thickness to 0.12 mm  by selecting each outline segment and editing its
properties (right click → Properties…​ or press ).

Shift Space

E
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Finally, select the F.Courtyard  layer. We want the courtyard outline to surround the part with a 0.25 mm

clearance.

For variety, we can use a different strategy to draw the shape on this layer. Switch to a 1mm grid instead of a
custom grid, and draw a rectangle roughly surrounding the footprint. Select the rectangle and press  to

edit its properties, and enter the corner coordinates of the rectangle directly. The corner coordinates are:

Top left: (-4.2, -2.05)

Bottom right: (4.2, 11.45)

После заполнения контуров расположите текст так, как показано ниже. Посадочное место готово.

E
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Соглашения по библиотекам Kicad
Для поддержания высокого качества библиотек символов и посадочных мест, в KiCad существует

документ KiCad Library Conventions, который представляет собой набор рекомендаций по
использованию символов и посадочных мест. Не обязательно следовать этим соглашениям для
личных библиотек, но они являются хорошей отправной точкой. Посадочные места и символы в
официальной библиотеке должны соответствовать KLC. Также KLC используется в качестве основы

для создаваемого символа и посадочного места в данном руководстве.

Add switch to schematic
Теперь, когда создание посадочного места завершено, можно отредактировать символ
выключателя таким образом, чтобы по умолчанию для него использовалось соответствующее
посадочное место.

Вернитесь в "Редактор символов" и откройте символ выключателя. Отредактируйте его свойства.
Щелкните на поле Посадочное место , затем щелкните на появившемся значке библиотеки книг .
Перейдите в библиотеку посадочных мест проекта и дважды щелкните на посадочном месте
выключателя. Сохраните символ.

Теперь посадочное место выключателя назначено этому символу по умолчанию и его не нужно
выбирать вручную при каждом добавлении символа в схему.

https://klc.kicad.org/
https://gitlab.com/kicad/libraries
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Откройте схему и добавьте новый символ, выбрав созданный нами ранее выключатель.

Подключите его между светодиодом и плюсом батареи.

It isn’t necessary to manually choose a footprint for the switch, because the switch symbol already specifies
a footprint. Run ERC to make sure that the modified schematic doesn’t violate any electrical rules.
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Add switch to layout
Make sure the schematic is saved, then open the Board Editor to add the symbol to the layout. Update the
PCB with the schematic changes using Tools → Update PCB from Schematic…​ and place the switch
footprint onto the board as shown. If needed, resize the board outline and copper zone (the copper zone

will unfill if it is resized, but you can re-fill it as necessary with ).B
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Линиями связи показаны новые соединения, которые необходимо развести. Кроме того,
необходимо удалить старое соединение между батарейкой и резистором.

First, delete the unneeded tracks. Select one of the tracks between the battery and the resistor — it doesn’t
matter which. Press  several times to expand the selection to include all the segments between the

battery and resistor. Press  to remove the connection.

Route the new tracks between the battery and the switch, and between the switch and the resistor. Press 
to refill the zones.

Наконец, запустите DRC, чтобы убедиться, что модифицированная плата не нарушает никаких

правил проектирования.

U

Delete

B
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Linking symbols, footprints, and 3D models

Symbols and footprints
Как описано в разделе назначение посадочных мест, в процессе создания схемы каждому символу в
ней должно быть назначено посадочное место. Имя посадочного места, назначенного каждому
символу, хранится в поле Посадочное место  в свойствах символа.
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Символы могут содержать заранее заданное посадочное место. Для таких символов нет

необходимости назначать посадочное место вручную, поскольку оно было выбрано при создании
символа. Но пользователи могут переназначить выбранное посадочное место в процессе
назначения посадочных мест обычным образом. Определение посадочного места по умолчанию,
целесообразно для символов, которым всегда или почти всегда будет назначаться одно и то же

посадочное место, например, для компонентов, доступных только в одном корпусе. Для символа
выключателя, по умолчанию, было задано соответствующее посадочное место.

Символы также могут содержать фильтры посадочных мест, с помощью которых можно скрыть

посадочные места, несовместимые с данным символом. Например, символ 74HC00  имеет фильтры
посадочных мест, в результате чего в инструменте назначения посадочных мест отображаются
только допустимые посадочные места DIP и SO14.
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На странице Требования KLC к фильтрам посадочных мест содержат несколько полезных советов
по созданию эффективных фильтров посадочных мест.

Footprints and 3D models
3D-модели компонентов хранятся в отдельных файлах. Имена файлов 3D-моделей компонентов
сохраняются в посадочном месте. В каждое посадочное место может быть добавлено любое

количество 3D-моделей. Имена файлов 3D-моделей, а также их масштаб, поворот, смещение и
непрозрачность задаются на вкладке 3D-модели свойств посадочного места.

https://klc.kicad.org/symbol/s5/s5.2/
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Both STEP ( .step ) and VRML ( .wrl ) 3D model formats are supported. STEP files are useful where
dimensional accuracy is needed, while VRML files can be used for more visually attractive renders. Many

footprints in KiCad’s library have associated 3D models; these models are provided in STEP format.

NOTE

Не все посадочные места в библиотеке KiCad снабжены 3D-моделями, но все они
содержат имя файла 3D-модели, даже если таковой не существует. Это сделано для
того, чтобы впоследствии можно было добавлять 3D-модели без редактирования
посадочного места.

FreeCAD together with the StepUp Workbench are useful for creating component 3D models; they are used

for many of the models in KiCad’s library. StepUp is used to generate STEP and VRML files with correct
placement, scaling, and rotation.

https://www.freecad.org/
https://github.com/easyw/kicadStepUpMod/
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Where to go from here
More learning resources
Для получения дополнительной информации о том, как использовать KiCad, см. документацию.

Есть и другие полезные ресурсы, такие как официальный форум пользователей KiCad, Discord или
IRC, а также дополнительные познавательные ресурсы сообщества KiCad.

Чтобы узнать больше о возможностях KiCad, посетите раздел сайта Сделано в KiCad или откройте

демонстрационные проекты, входящие в состав KiCad (Файл → Открыть демонстрационный
проект…).

Help improve KiCad
Чтобы сообщить об ошибке или запросить какую-либо функцию, воспользуйтесь командой
Справка → Сообщить об ошибке или создайте запрос на Gitlab.

Чтобы узнать, как внести свой вклад в развитие KiCad, посетите страницу Вклад разработчика.
Пользователи также могут внести свой вклад в развитие библиотек или документации и перевода.
Наконец, для дальнейшего развития KiCad можно оказать финансовую поддержку.

https://docs.kicad.org/
https://forum.kicad.info/
https://www.kicad.org/community/chat/
https://www.kicad.org/help/learning-resources/
https://www.kicad.org/made-with-kicad/
https://gitlab.com/kicad/code/kicad/-/issues
https://dev-docs.kicad.org/en/contribute/
https://www.kicad.org/libraries/contribute/
https://www.kicad.org/contribute/docs-team/
https://www.kicad.org/donate/faq/
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